Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

24/03/2008 #301


Propuesta Conmutacion VPP 5V/13V
Eclip-se dijo:
Hola a todos.

Bueno la propuesta para obtener 0-5-13 V. Queda planteada. Si alguien implementa el esquematico y PCB modificare el software y firmware para que se puede hacer el reset desde el programa.

Caso contrario seguiremos usando el mismo hardware.....

Gracias
Hola a todos...soy nuevo en este tema...... después de leer las 32 paginas del mismo quisiera colaborar con el proyecto dado que me parece MUY INTERESANTE Y DIDÁCTICO.
Creo entender que lo que buscan es conmutar el VPP entre los 13V que requieren los PIC y los 5V que requieren loa AVR.
Mi propuesta esta en la imagen que adjunto y es una solución que yo ya tengo implementada en mi version 1.0 del programador Eclip-se(aunque también arme la versión 0 con buenos resultados) y funciona con los PIC que tengo sin problemas.Habría que habilitar uno de los pines del 18F2250 para tal fin y rehacer el PCB con dicho agregado pero espero vuestra aprobación antes de proseguir.
Mi prototipo esta armado en una placa de múltiples perforaciones como la que figura en la pagina web y no he tenido problemas alguno para programar los siguientes PIC 18F2550 , 16F877A, 16F84A, 16F628A a pesara de que el cable del USB ni siquiera es apantallado dado que esta "canibalizado" de un ratón PS2 común y mide 50cm eso si mi Duron 1400 con Win XP SP2 solo va con USB1.1.
Quiero felicitar a todos por el trabajo realizado y en especial a ECLIP-SE por su GRANDEZA al compartir des interesadamente su trabajo.

Saludos y abrazos.

Ric.

PD: si no es lo que están buscando sepan disculpar el mal entendido.
25/03/2008 #302

Avatar de Eclip-se

Hola ricbevi.

Gracias por tu colaboracion. Te cuento que yo tambien implemente algo parecido tengo el ESQUEMATICO y PCB, en estos dias estoy en la etapa de pruebas y he distribuido el diseño a algunos amigos del foro para que lo prueben y sacar la version final que pronto lo publicare.

Debido a que ya tengo diseñado el PCB, no seria conveniente realizarlo otro y mi sugerencia seria que nos esperemos unos dias mas hasta publicarlo en la pagina y de ahi mejorar el PCB.

Gracias y en los proximos dias subo la información.
25/03/2008 #303

Avatar de microtronic

q bien eclip-se esperaremos ansiosos...
25/03/2008 #304


Eclip-se dijo:
Hola ricbevi.

Gracias por tu colaboracion. Te cuento que yo tambien implemente algo parecido tengo el ESQUEMATICO y PCB, en estos dias estoy en la etapa de pruebas y he distribuido el diseño a algunos amigos del foro para que lo prueben y sacar la version final que pronto lo publicare.

Debido a que ya tengo diseñado el PCB, no seria conveniente realizarlo otro y mi sugerencia seria que nos esperemos unos dias mas hasta publicarlo en la pagina y de ahi mejorar el PCB.

Gracias y en los proximos dias subo la información.
Ok esperaremos .

Ric.
26/03/2008 #305


Hola a todos, espero que mi propuesta no llege muy tarde. Realice una placa base (y el soft)en la que programaba los pics por el pueto paralelo del pc y una vez programados el soft permitia el funcionamiento del pic, sin tener que sacarlo del zocalo de la placa base. El esquema esta mas que probado.
Archivos Adjuntos
Tipo de Archivo: pdf unidad5_655.pdf (203,9 KB (Kilobytes), 144 visitas)
26/03/2008 #306

Avatar de Eclip-se

Hola a todos.

Esta lista la nueva version del hardware (Falta realizar las pruebas), espero que las personas que esten interezadas comenten el diseño y si lo pueden lo prueben armandolo en un Proto-Board. Y verifiquen si se obtienen los voltajes respectivos (0-5-13 V).

Este es el esquematico.



Y el PCB.



Y los archivos diseñados en PROTEL.
Archivos Adjuntos
Tipo de Archivo: zip newhard_110.zip (405,1 KB (Kilobytes), 201 visitas)
26/03/2008 #307

Avatar de microtronic

Oye eclip-se y el Firmware del pic? para esta nueva version?

saludos
26/03/2008 #308

Avatar de Eclip-se

Hola.

El hardware esta en la etapa de pruebas, todabia no he probado si los voltajes son los correctos. Y tampoco se si el diseño sera el final, por eso publico el diseño del PCB para que verifiquen y comenten.

Tengan en cuenta que la idea del RESET en el software, es solo una idea que todabia falta ver si funciona o si realmente es conveniente.

El firmware lo publicare en 1 o 2 semanas..
26/03/2008 #309


Hola a todos nuevamente.

He estado bastante ocupado ultimamente y lamentablemente no he tenido tiempo para realizar mas pruebas. Sin embargo veo que hay una iniciativa por agregar una mejora al programador y me gustaria mucho compartir mi idea al respecto.

Temo que no uso el mismo software para editar circuitos que tu Eclip-se, asi que tome prestada una imagen de tu sitio para editarla y hacer la adicion lo mas rapido pisible.

Tambien debo comentar que la idea de agregar un simple transistor con una resistencia (para eliminar el jumper de seleccion de voltaje) me habia estado dando vueltas por la cabeza desde varios dias despues que sugirieron hacer la selección de voltaje por medios electrónicos.

En el esquema hay un pin que dejo abierto, ese como es de esperar, es el pin de control para conectar al 18F2550; dejo a eleccion de Eclip-se que pin usar, ya que el mismo conoce la distribucion de los recursos del MCU que mejor convenga. Esto permitira seleccionar voltajes con un 1 (para 5 voltios) o un 0 (para 13V). El voltaje de salida se puede reducir a 0V como siempre por medio de activar Q2 con un 1 logico independientemente de que se tengan 5 o 13V.

En cuanto a la operacion de la modificacion, esta es bastante simple: Al encender el transistor agregado, este cortocircuitara el anodo del Zener de 5.1V a tierra, con lo cual el Zener de 13V dejara de conducir, puesto que se encontrara muy abajo del voltaje de avalancha (o voltaje Zener) ya que el otro Zener conduce toda la corriente necesaria de R4 para reducir el voltaje de operacion a 5.1V.

Si al caso el Zener de 13V conduce corriente, sera muy escasa (y despreciable) al encontrarse en su zona de no-conducción (los diodos zener polarizados inversamente que no alcanzan el voltaje de avalancha se encuentran en su zona de no-conduccion y funcionan como diodos comunes y corrientes). Aparte estoy seguro que funcionara con el mismo rendimiento que el circuito original.

Espero que esta simple modificacion cumpla las espectativas de todos ustedes. Por mi parte puedo decir que la adicion se hace con un minimo de componentes agregados (solo 2) con respecto del diseño anterior (de hecho es prácticamente igual al anterior), ademas no hay que reemplazar ningun componente de los que ya estan (se puede seguir usando el mismo Zener de 5.1V y el de 13V) y lo unico que descartamos es el jumper.

Aquellos que lo tienen armados en tableta perforada incluso podrian tener un poco de espacio extra para el transistor y la resistencia al remover el jumper (segun su propia distribucion de componentes) y podrian solo modificar lo que ya tienen para adaptarlo.

Con la eliminacion del jumper existe una ganancia adicional tambien que me gustaria comentar, y es la de seguridad. El circuito anterior tenia la desventaja de que al desconectar el jumper completamente (es decir, sin seleccionar ni 5 ni 13V), el circuito podria dañarse al no tener un limitador de voltaje de carga (la bomba de carga con inductor empujaria corriente hacia C6 sin limite). Esto definitivamente es una buena ganancia :-)



Cambiando tema, en cuanto a la modificacion del software para controlar el Reset, me parece una excelente idea, sobretodo al tener control electronico de 5 o 13V para el pin MCLR de los PIC (No se que pase con los AVR - pero caso que no lo soporten podria ser una caracteristica exclusiva de los PIC que se activaria solamente al seleccionar uno de la lista de microcontroladores soportados).

El programador ICD2 de Microchip tiene esa precisa caracteristica y debo comentar que es extremadamente util. Si no nos importa sacrificar 2 pines de I/O en el MCU (los pines PGC y PGD que usualmente son RB6 y RB7 en los modelos de 18, 28 y 40 pines), entonces podemos dejarlos permanentemente conectados al programador y dejarlos abiertos (como entradas) en el firmware. Con ello el programador puede programar el MCU al colocarle 13V como es usual, pero tambien puede ponerlo en marcha al colocarle 5V.

Para que nos sirve esto? Simple: podemos dejar el programador permanentemente conectado al MCU en todo momento (sobretodo en la etapa de desarrollo que bien puede ser en una protoboard), y de esa forma se puede programar al PIC "in situ" dentro de su circuito aplicativo formal. Con ello basicamente no es necesario sacar el MCU cada vez que se quiere programar (ni tampoco hay que arriesgarse a dañarlo en el proceso), aparte que cambiar entre "prueba" y "programar" es tan facil como un click. Si el codigo funciona mal, basta con corregirlo en la PC y luego reprogramar al MCU en caliente, ya que esta conectado al programador en todo momento. Que tan rapido puede hacerse eso? Respuesta: tan rapido como puedas hacer click en "compilar", luego "programar" y finalmente en "liberar RESET"... una caracteristica adorable del ICD si me lo preguntan.

Personalmente, yo votaria porque lo agregues Eclip-se, eso haria el programador todavia mejor . Solo haria falta agregar la funcion de "in-circuit-debugger" (solo bromeando :-P) Jejeje.

Bueno, espero no haberlos aburrido con mi post tan largo. Estare a la expectativa de sus opiniones respecto a la modificacion del circuito.

Hasta luego.
Imágenes Adjuntas
Tipo de Archivo: gif esquematico_199.gif (161,0 KB (Kilobytes), 113 visitas)
28/03/2008 #310

Avatar de Eclip-se

Hola a todos.

Estupenda explicación f point.

He realizado las pruebas y los voltajes son los correctos, pero tengo un problema en el PIN 12 (RC1), tengo la señal PWM que se obtiene en el PIN 13 (RC1). Esto hace que al momento de poner la salida en 1L para que el transistor este en estado de corte y no polarice los diodos y obtener 0V, se genere la señal PWM en (RC1) haciendo que el voltaje varíe y no se obtenga los 0V esperados.

Este funcionamiento tiene que ver con el uso de los puertos PWM, que no soy muy experto en ese tema.

Lo solucione cortando la pista que une el PIN 12 y el transistor Q3, y le conecte al PIN 5 (RA3), el problema es que al tratar de rediseñar el PCB no existe forma de llegar a ese PIN, por todo lado hay cruces de pistas.

Voy a tratar de eliminar elementos tal como lo sugiere f point, a ver si se puede rediseñar el PCB sin puentes.

Si alguien sabe porque en el PIN 12 obtengo la misma señal PWM del PIN 13, le agradecería que comente, y digan si se puede evitar eso.

O también si alguien rediseña el PCB de tal forma que se realice la conexión mencionada sin que exista puentes.

Gracias a todos…
30/03/2008 #311


Hola de nuevo.

Por lo que explicas Eclip-se, parece que tienes activado el modulo CCP2 en modo PWM tambien y que el bit de CCP2MX (CONFIG3H) esta en 1 (Salida del modulo CCP2 puesta a RC1). Si obtienes incluso la misma señal de PWM, parece que tambien el periodo del CCP2 es igual al del CCP1.

Hay que recordar que el PIC18F2550 cuenta con un doble modulo CCP: Denominados CCP1 y CCP2 acordemente. Cada uno puede operar independientemente del otro en cualquiera de los 3 modos disponibles (Capture, Compare o PWM), con la excepcion de que cuando ambos estan en modo PWM comparten el mismo Timer2 para determinar su periodo; Sin embargo, el ciclo de trabajo de cada uno puede ser controlado independientemente.

Verifica si en tu firmware haces la doble inicializacion tanto para el CCP1 como para el CCP2. Si tienes codigo duplicado, inicializa solamente el CCP1 y deja el modulo CCP2 sin inicializar (eso deberia liberar el pin RC1 para que opere normalmente). Siempre y cuando apagues el CCP2, la configuracion de CCP2MX no importara. Alternativamente, si mueves la salida del CCP2 a RB3 podrias resolver tu problema parcialmente, pero entonces lo trasladas a un problema futuro ya que inutulizas el pin RB3 (que segun veo en tu diseño, parece estar reservado para futura ampliación).

Otra posible causa para tu problema podria ser un cortocircuito entre los pines 12 y 13, con el pin 13 (RC2/CCP1) dominando la salida de ambos. La posibilidad se mira muy plausible, ya que ambos pines estan contiguos.

Espero te sea de ayuda.
31/03/2008 #312

Avatar de Eclip-se

Hola a todos.

Gracias f point por tu sugerencia, voy a tratar de ver si lo puede corregir aunque ya estoy haciendo las pruebas del programador utilizando otro PIN, tambien tengo el PCB unicamente con los circuitos que tu indicas, me falta comprobar como funciona asi, y lo bueno es que ya se eliminaron los puentes.

Los proximos dias subo la nueva version.
03/04/2008 #313


Saludos a todos
Saludos Eclipse hice tu programador y no lo puedo hacer funcionar, batallé un poco para cargar el Firmware pero ya quedó ok ahora sucede que cuando conecto el programador empiezan e encender los LEDs alternadamente, y la compu laptop me dice que no reconoce el dispositivo USB
y al Iniciar el Software y probar el hardware me dice que no esta conectado el programador

Saludos y Gracias
04/04/2008 #314


Inductor ya somos varios con ese mismo problema, algo tenemos que nos falla a todos, tiene que ser del sistema operativo, aunque yo he probado en varios ordenadores y con el mismo resultado.
saludos
04/04/2008 #315


Entonces debe haber algun detalle en el Firmware, ya revisé todo probé en varias computadoras y en algunas de escritorio se blockean al conectar el programador.

Ojalá NOS pueda Eclip-se dar la solucion.

Ademas estuve probando con Osciloscopio las señales de comunicacion y nada se cortan,probe la salida para el transistor de switcheo del elevador de tension y se corta en la patita 13 del PIC

Aunque el oscilador de 20 Mhz sigue trabajando.

Esperemos que nos ayude Eclipse. Sad
04/04/2008 #316


Temo que en el firmware de Eclip-se dificilmente haya errores, dado que a mi me funciona perfectamente bien y debo señalar que lo he probado con dos PCs distintas y todo funciona bien. Si existe un error de firmware, posiblemente tu PIC este mal programado.

Lo mas probable es que se trate de ruido en la comunicacion USB. Yo tuve un problema similar al principio y lo resolvi inmediatamente cuando hice el circuito en un impreso de calidad mas o menos aceptable. Deberias buscar por pistas muy delgadas o suciedad (si lo tienes en impreso). Tambien deberias probar tu cable USB; Prueba usando un cable mas corto, eso deberia ayudar tambien.

El parpadeo de los LEDs al inicio es perfectamente normal y es un buen indicio de que el PIC ha arrancado y que tu oscilador a cristal trabaja bien.

Saludos.
04/04/2008 #317


Gracias f point por tu comentario lo revisaré nuevamente
me pudieras decir que programador usaste para programar el PIC 18f2550 yo usé un programador paralelo

y en cuanto al PCB usé uno en Fibra de Vidrio

Gracias..
05/04/2008 #318

Avatar de Eclip-se

Hola a todos.

Con respecto a los problemas comentados, voy a ver a que se deben pero es relacionado al S.O. Solo lo he probado en maquinas P IV, S.O. WinXp 2002, ServiPack 2.

Esta lista la nueva versión del programador, el PCB, quedo de la siguiente forma siguiendo el esquemático que propuso f point.



El PCB esta en revisión, que ustedes debería aprobar, según eso seguiremos usando el mismo, en caso de haber problemas se corregirán los mismo.

El Firmware y Software, como saben cada día se va mejora, con esta nueva característica del programador se presentaron ciertos inconvenientes que pronto lo solucionare.

Gracias a todos y espero sus comentarios.
07/04/2008 #319


Hola eclipse tengo muchas ganas de realizar mi programador, quisiera saber si el esquematico de fpoint y en tus pruebas ya obtienes los voltajes correctos, y quisiera saber si ya esta programando pics con el nuevo diseño, se que tal ves no has hecho tu pcb pero en tus pruebas. Si es que ya funciona yo me comprometo a realizar el nuevo diseño del pcb incluyendo el zocalo zip para poder programar todos los pics que soporta, aunque tambien necesitaria utilizar un jumper para seleccionar pis de 28, 40 ó 18 y menores.
08/04/2008 #320


Pues chicos ,viendo q mi portatil no tiene puerto serie ,no me queda otra q currarme este programador,el problema es q yo no uso el protel ni se utilizarlo asi q viendo q todo esta hecho con protel no me queda mas remedio que pediros el favor de "alguien a exportado el esquemativo y el pcb a un formato algo mas conocido por los aficionados" como por ejemplo el del Eagle. Muchas gracias por haberme escuchado.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.