Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/05/2008 #381

Avatar de culebrasx

Hola, tengo una duda un poco tonta,jeje.
Voy a montar el programador (Gracias de nuevo,eclipse!), pero no tengo muy claro exactamente el firmware donde lo tengo que grabar? como hago para funcionar? solo veo un zocalo en la placa, si ahi va el pic a grabar, donde se supone que va el integrado con el firmware grabado?
He estado leyendo las paginas del hilo pero no he encontrado respuesta, por eso he tenido que postear, un saludo a todos...
07/05/2008 #382


Ola yo tambien tuve esa duda y ya lo solucione:

El zocalo que se ven en la placa es para el micro graado con el firmware y el otro micro se conecta a las lineas de salida que son sda scl vdd gnd vpp si no recuerdo mal
08/05/2008 #383

Avatar de culebrasx

thelscIVRF dijo:
Ola yo tambien tuve esa duda y ya lo solucione:

El zocalo que se ven en la placa es para el micro graado con el firmware y el otro micro se conecta a las lineas de salida que son sda scl vdd gnd vpp si no recuerdo mal
Gracias ya entiendo(mas o menos,jeje):tendria que poner el pic en una protoboard, ya que como cada pic tiene distinto patillaje seria inutil hacer una pcb,no? y las salidas del circuito las conecto:
GND-->No la tengo todavia muy loalizada, pero no creo que sea muy dificil,no?jeje
Vcc--> Va a Vss o a Vdd del pic?
Vpp-->Tampoco la tengo clara, Vss o Vdd?
Dat-->Patilla Dt del pic?
Aux1-->Lo he leido pero ahora no me acuerdo
Aux2-->Lo mismo que Aux1

De momento creo que no tengo mas dudas, continuo leyendo de todas formas, espero no haber tratado temas ya vistos...
08/05/2008 #384


Programador USB
Felicito a Eclipse por tan grandioso esquema del programador usb que ha desarrollado.
mi duda es la siguietne: realize el montaje en una placa de prueba, y al realizar las pruebas de hardware todo anda bien, pero al momento de programar un microcontrolador , me sale un error de lectura o de escritura. verifique el voltaje de alimentacion que sale del conmutador de voltaje PNP 3906, pero no esta llegando el suficiente voltaje al pic a programar, le llega aproximadamente 2.6 v, lo que estoy haciendo es mandar la alimentacion del pic directamente a vcc y muy pocas veces sale el error. sera que habra una forma de garantizar los 5 voltios para el pic a programar, o sera que cometiste un error en el diseño del firware.?
realize una prueba con un transistor 2n3904 y le conecte en cascada otro igual, esto para simular un transistor PNP pero el problema persistio, luego le deje solo un 2n3904 y siguio igual.

no siendo mas te felicito por grandioso desarrollo y por darlo a conocer a toda la comunidad de electronicos.
08/05/2008 #385


Mi estimado chip986, lo que encontraste es precisamente una falla menor del programador, misma que ya habiamos comentado en la pagina 35 de este tema. No te preocupes que es un error "de dedo" (falla no intensiónal) en el firmware y Eclip-se ya esta mas que enterado del mismo.

La solucion temporal del error tu mismo acabas de mencionarla: conectar el VDD del PIC directamente a +5V. Dale un poco de tiempo a nuestro amigo Eclip-se, que seguro lo publicara ya arreglado en la siguiente version. Ten por seguro que esta trabajando duramente en el proyecto.

Saludos.
09/05/2008 #386


Eclip-se en portatil HP
Un amigo tiene el programador de eclip-se,

pero tiene un gran inconveniente que sera mio si es verdad.......

mi pregunta antes de montar el programador es si este funciona para portatiles HP, Mi amigo me dijo que por los controladores del Portatil, no es posible hacer funcionar este programador.

Si funciona en cualquier pc ya sea portatil?
09/05/2008 #387

Avatar de Eclip-se

Hola a todos.

El DRIVE es generico, por lo que en la mayoria de las maquina con S.O XP se instala.

El programador funciona con el PIC18F2550 el cual debe estar programador con el firmware.

Se necesitan todo los elementos del programador para que funcione, ya que la programacion necesita 13 V el cual se obtiene con la bobina y el transistor.

En mi programador si se calienta el transistor (poco), pero he medido el voltaje y obtengo 27 Voltios voy a bajar ese voltaje a ver que sucede. La variacion del voltaje depende de la bobina y del capacitor y de la señal PWM.

En mi caso yo si obtengo VDD que es de 4.5 Voltios. No entiendo por que a utedes no les funciona ya que el circuito es el mismo. Con todo voy a probar la salida ya que ultimamente lo he etado alimentando directamente del circuito y el conector esta en OFF.

Pero en las pruebas de hardware su funcionamiento es el correcto.
09/05/2008 #388


Gracias ya entiendo(mas o menos,jeje):tendria que poner el pic en una protoboard, ya que como cada pic tiene distinto patillaje seria inutil hacer una pcb,no? y las salidas del circuito las conecto:
GND-->No la tengo todavia muy loalizada, pero no creo que sea muy dificil,no?jeje
Vcc--> Va a Vss o a Vdd del pic?
Vpp-->Tampoco la tengo clara, Vss o Vdd?
Dat-->Patilla Dt del pic?
Aux1-->Lo he leido pero ahora no me acuerdo
Aux2-->Lo mismo que Aux1

De momento creo que no tengo mas dudas, continuo leyendo de todas formas, espero no haber tratado temas ya vistos...

weno a ver t digo como son las salidas

gnd ------> vss del pic a programar
Vcc -------> vdd del pic a programar
Vpp-------> Al pin de MCLR del pic
Dat ------> Al pin PGD del pic
Clk -------> Al pin PGC del pic
Aux1 ------> No se usa en los pic. Corresponde al MISO de los AVR
Aux2-----> No se usa en los pic. Corresponde al MOSI de los AVR

Espero que te aya quedado claro
-----------------------------------------------------------------------------------------------------------------------
Weno ahora pongo mi duda.
-----------------------------------------------------------------------------------------------------------------------
Hoy he conseguido unos transistores que creia que me podrian valer

Los BC548C y BC558C

Tengo el mismo problema que otros. El transistor del pwm se calienta y a la salida en vpp tengo
13v= 5.47
5v = 2.81
0 v = 0.01

Estos valores estan muy bajos pero no se porqué. Parece una situacion como cuando una fuente se pone en corto (baja el voltage y se calientan los transistores)
Revisare que no hay ningun corto.


PD: El problema de calentamiento del pic se solucione al poner los transistores
aora solo se calienta un pokito pero nada alarmante

A ver si alguien averigua el porque de este calentamiento en los transistores de PWM.

Gracias a todos
10/05/2008 #389


circuito final
Hola soy nuevo aca y me interesa mucho el proyecto que estan realizando, pueden colgar el circuito final ya sin errores por favor y otra peticion funciona para el 16f877a? muy agradecido
10/05/2008 #390


thelscIVRF dijo:
Gracias ya entiendo(mas o menos,jeje):tendria que poner el pic en una protoboard, ya que como cada pic tiene distinto patillaje seria inutil hacer una pcb,no? y las salidas del circuito las conecto:
GND-->No la tengo todavia muy loalizada, pero no creo que sea muy dificil,no?jeje
Vcc--> Va a Vss o a Vdd del pic?
Vpp-->Tampoco la tengo clara, Vss o Vdd?
Dat-->Patilla Dt del pic?
Aux1-->Lo he leido pero ahora no me acuerdo
Aux2-->Lo mismo que Aux1

De momento creo que no tengo mas dudas, continuo leyendo de todas formas, espero no haber tratado temas ya vistos...

weno a ver t digo como son las salidas

gnd ------> vss del pic a programar
Vcc -------> vdd del pic a programar
Vpp-------> Al pin de MCLR del pic
Dat ------> Al pin PGD del pic
Clk -------> Al pin PGC del pic
Aux1 ------> No se usa en los pic. Corresponde al MISO de los AVR
Aux2-----> No se usa en los pic. Corresponde al MOSI de los AVR

Espero que te aya quedado claro
-----------------------------------------------------------------------------------------------------------------------
Weno ahora pongo mi duda.
-----------------------------------------------------------------------------------------------------------------------
Hoy he conseguido unos transistores que creia que me podrian valer

Los BC548C y BC558C

Tengo el mismo problema que otros. El transistor del pwm se calienta y a la salida en vpp tengo
13v= 5.47
5v = 2.81
0 v = 0.01

Estos valores estan muy bajos pero no se porqué. Parece una situacion como cuando una fuente se pone en corto (baja el voltage y se calientan los transistores)
Revisare que no hay ningun corto.


PD: El problema de calentamiento del pic se solucione al poner los transistores
aora solo se calienta un pokito pero nada alarmante

A ver si alguien averigua el porque de este calentamiento en los transistores de PWM.

Gracias a todos
Hola a todos..... "thelscIVRF" tenes que tener aproximadamente 21v medidos en la unión del diodo 1N4148, electrolítico de 4,7uF y la R de 2200 ohms(2,2K) y GND o masa del circuito. El consumo de esa parte del circuito es de aproximadamente 100mA alimentando el programador con una fuente externa solamente sin estar conectado a la PC y por esa causa puede ser que caliente el Choque de RF de 220uH dado que para soportar dicha corriente circulando en forma permanente tendría que estar echo con un alambre de 0,22 mm y seria muy voluminoso.Los que yo conseguí por aquí son parecidos a resistencias de 1/4W y sospecho que de no mas de 50mA de corriente con suerte...aunque funcionan obviamente calienta.En cuanto al transistor BC548 funcionara pero calentar debido a que su disipación máxima es de 625mW a 25ºC y 5Vx100mA=500mW estas acercándote peligrosamente al limite máximo de trabajo(no se las lleva mejor el 2N3904 de similares paramentos pero específicamente pensado en conmutación). A todo lo expuesto hay que sumarle que existen gran cantidad de semiconductores en general apócrifos o de dudoso origen de fabricación que se desconoce si realmente cumplen con los paramentos de los dispositivos de las casas de re-nombre(Motorola, Philips, etc).
Para terminar y agregando algo al tema de la fabricación del choque 220uH en forma casera es prácticamente imposible bobinar esos valores (220uH y 100mA) sin la presencia de un núcleo de ferrite dado que si no seria "grande" para poner en el circuito y obviamente tendríamos que considerar si no es mas difícil encontrar un ferrite de calidad conocida y de mas fácil adquisición que el mismo choque en si para dar una formula de vuelta/grosor de alambre para fabricarlo.

Por ultimo el consumo de mi programador como ya he dicho en otras oportunidades ronda los 130mA eso si los led son de 3mm de diámetro y no de 5mm.

Ric.
10/05/2008 #391


Hola a todos; primero gracias a eclipse por el programador. Yo realice el programador en pcb y debo decir que al principio tenia el mismo problema del transistor se calentaba demasiado, el problema era que aca donde vivo no logre conseguir el inductor de 220uH; el problema fue resuelto al desoldar inductores de distintas placas y aproximarme a los 220uH ahora tengo un voltaje de 21 volts en el 1n4148 y pude programar exitosamente distintos pics entre ellos el 2550, en resumen yo creo que el problema esta en la bobina; ademas debes checar que los zener esten conectados correctamente.
12/05/2008 #392


vale hoy tengo el dia libre asik mirare a ver si hay algo mal conectado.
me e fijado en una cosa k decis. Decis un diodo 1n4148 y el mio es 1n4001 en el esquema pone 1n48 creo y ese era de los de commutacion si no recuerdo mal. Creeis k puede ser por eso?

Weno tambien el condensador en el esquema pone 1µf y vosotros lo habiais puesto de 4,7µf. Cambiare todo esto aver como influye.

PD: En la union esa tengo 5 voltios
12/05/2008 #393


thelscIVRF dijo:
vale hoy tengo el dia libre asik mirare a ver si hay algo mal conectado.
me e fijado en una cosa k decis. Decis un diodo 1n4148 y el mio es 1n4001 en el esquema pone 1n48 creo y ese era de los de commutacion si no recuerdo mal. Creeis k puede ser por eso?

Weno tambien el condensador en el esquema pone 1µf y vosotros lo habiais puesto de 4,7µf. Cambiare todo esto aver como influye.

PD: En la union esa tengo 5 voltios
Hola el diodo es efectivamente 1N4148 o 1N4149 o 1N914(conmutación no rectificador común 1N4007) y el capacitor es de 4,7uFx63v y debe haber aproximadamente 21V en ese punto si o si(si no no esta trabajando como debería el oscilador PWM ).

Saludos.

Ric.
13/05/2008 #394


thelscIVRF dijo:
vale hoy tengo el dia libre asik mirare a ver si hay algo mal conectado.
me e fijado en una cosa k decis. Decis un diodo 1n4148 y el mio es 1n4001 en el esquema pone 1n48 creo y ese era de los de commutacion si no recuerdo mal. Creeis k puede ser por eso?

Weno tambien el condensador en el esquema pone 1µf y vosotros lo habiais puesto de 4,7µf. Cambiare todo esto aver como influye.

PD: En la union esa tengo 5 voltios
Aja! esa podria ser la razon!
Saben, un diodo trabajando a una frecuencia muy alta puede comportarse como un capacitor. Eso explicaria porque el transistor se calienta, ya que tiene que conducir la corriente generada por la capacitancia del diodo a esa frecuencia. El diodo 1N4001 es un rectificador de baja potencia, ideado para fuentes y frecuencias de 60Hz, mientras que el 1N4148 es un rectificador de pequeña señal y por lo tanto su frecuencia de trabajo es mucho mayor.

Que opinan al respecto. Creen que sera esa la causa por la que se calienta el transistor para algunos?

Saludos.
13/05/2008 #395


saludos...................sigo con una duda..........actualmente puedo programar avr's dspic y es compatible con eeprom?
15/05/2008 #396


Programador eclipse con conector ICSP. El PCB fué hecho en eagle.
Imágenes Adjuntas
Tipo de Archivo: jpg modulo_programador_205.jpg (33,1 KB (Kilobytes), 1068 visitas)
15/05/2008 #397


Acá les dejo los archivos de eagle.

En la ventana donde se abre el board se debe aplicar ratsnest en "Tools/Ratsnets" antes de imprimir. Con esto se logra que el circuito quede con plano de tierra.

...

La versión 1.0 del PCB no es compatible con la versión 1.1 del firmware debido a que las líneas XTAL, MOSI, MISO y CLK ya no son las mismas en el PIC.

Sin embargo, me di en la tarea de actualizar el PCB a la versión 1.1.

A continuación les dejo los archivos de eagle para las dos versiones.
Archivos Adjuntos
Tipo de Archivo: zip programador_eclipse__icsp_eagle_608.zip (118,4 KB (Kilobytes), 243 visitas)
Tipo de Archivo: zip programador_eclipse_11__icsp_eagle_199.zip (120,6 KB (Kilobytes), 254 visitas)
16/05/2008 #398

Avatar de microtronic

Andrés D dijo:
Acá les dejo los archivos de eagle.

En la ventana donde se abre el board se debe aplicar ratsnest en "Tools/Ratsnets" antes de imprimir. Con esto se logra que el circuito quede con plano de tierra.
quedo muy bien tu pcb..gracias
17/05/2008 #399


Actualización de eclipse
Hola eclipse, acabo de ver que colocaste en tu web las modificaciones del programador reducido. Pero en la carpeta de los archivos donde va el pcb en protel no pusiste nada :(
Es la unica manera que hallo de imprimir el silkscreen...
(Excelente proyecto, te felicito!)
17/05/2008 #400


saludos...........les comento que he tenido problemas para programar el pic16f84 y 16f84a, el programador los reconoce los lee, pero al momento de programarlo, sale error al escribir, no se si alguien sepa una solucion para esto, lo agradeceria mucho, gracias eclipse por ese aporte tan util
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.