Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

04/07/2008 #481


Hola a todos! tengo un problema a la hora de programar el pic 18f2550, ya que lo estoy programando con otro programador y no se que datos hay que ponerle en la configuracion. El programa que utilizo es el winpic. Aluien me puede decir que debo seleccionar en la configuracion?

Un saludo y gracias!
04/07/2008 #482


elensar dijo:
Hola a todos! tengo un problema a la hora de programar el pic 18f2550, ya que lo estoy programando con otro programador y no se que datos hay que ponerle en la configuracion. El programa que utilizo es el winpic. Aluien me puede decir que debo seleccionar en la configuracion?

Un saludo y gracias!
Hola elensar el winpic debe actualizar la palabra de configuracion, la cual fue configurada a la hora de elaborar el programa del pic, ya sea en C o Basic. No se si el winpic tiene la opcion para deshabilitar esta opcion para que no la actulize. pero en la version que yo tengo si lo hace actuliza la palabra cada vez que cargas el .hex te dejo una foto para que veas la configuracion que me da a mi para que cheques con la tuya
05/07/2008 #483


Gracias Pedro Pan!
No actualiza la configuracion cuando abres el archivo .hex por eso no sabia muy bien como configurarlo.
Probare y os cuento que tal funciona el programador!

Un saludo!
06/07/2008 #484


Saludos a todos, he leido el foro hace algun tiempo, ya realice mi programador gracias a Eclipse, muy buen aporte, tengo un laptop con procesador turion x2 y usb OpenHCD en windows vista, y el programador me ha funcionado bien con la version 1.1 de firmware, software y hardware. Pero en estos dias no me funcionó con un atmega8, las pruebas de hardware resultan bien.
La pregunta es por qué no funcionará, el programador no muestra ningun error, pero al leer el micro muestra cosas diferentes a las que se supone que programe; no se si sea problema de configuración de los fusibles.

Que pena alargarme tanto, me podrian explicar cual es el mejor hardware que hay, porque segun pude ver en la ultima actualizacion de eclipse tengo la version reducida, podrian aclarame cual usar. Gracias a todos y continuen mejorando este buen proyecto.
07/07/2008 #485


Hola a todos!

Al programar al PIC además verifica?

Otra consulta, si sólo voy a programar PICs de la línea 12, 16 y 18. Puedo mantener conectado el Vcc del PIC al 5V del USB siempre? Capás que esta pregunta es porque no sé para qué es el interruptor.

Saludos y gracias!
07/07/2008 #486


kuropatula dijo:
Hola a todos!

Al programar al PIC además verifica?

Otra consulta, si sólo voy a programar PICs de la línea 12, 16 y 18. Puedo mantener conectado el Vcc del PIC al 5V del USB siempre? Capás que esta pregunta es porque no sé para qué es el interruptor.

Saludos y gracias!
Los 5v si pueden estas conectados cuando programas un pic de 16 o 18 ya que cuando un micro entra a modo de programacion este voltaje no afecta en nada, ademas la quemadora conecta y desconecta este voltaje cuando programa el micro.

Ahora para el interruptor este sirve si utilizas el ICSP y programas el micro en el circuito original para explicarme de otra forma programas el micro sin sacarlo de la placa donde esta origalmente por medio del ICSP (5 lineas necesarias para programacion) este interruptor te servira para conectar o desconectar los 5v. del programador si tu utilizas los 5 volts externos o sea los de la placa orignal sino utilizas los del programador.

Ahora si el programador hace la verificacion del codigo eso si deberia contestarlo eclipse.

Saludos
10/07/2008 #487


Problema Programador USB Eclipse
Como están, compañeros electrónicos.

Hace ya varios meses que pude conseguir que el programador que ha facilitado Eclipse funcionase en mi laptop, que tiene WinVista, con resultados maravillosos (para mi, pues ya no tenía que preocuparme por estar pegado al desktop con el programador paralelo para poder trabajar).

Sin embargo, algunos dias atrás intenté actualizar el firmware y el software del programador, pero para mi sorpresa ya no ha vuelto a funcionar.

Primero cambié el software, pero tuve problemas pues este se "bloquea" cuando se programa, verifica, lee, etc... y finalmente Windows lo cierra. Pensé que era cuestión de cambiar el firmware, y así lo hice, pero ahora si ni siquiera funciona con la versión anterior de software.

Por eso quisiera pedirle el favor a Eclipse o a alguno que tuviese lo que necesito, si me podrían facilitar la versión 1.0 de firmware (las primeras que se publicaron y en las que al conectar el programador los LEDs parpadeaban, y que acompañaban el software de misma versión), pues en estos momentos estoy bloqueado en mi trabajo, y estoy seguro que estas si trabajan adecuadamente en Vista.

Además, quisiera comunicar, no se si ya lo han notado, que el estado del Watch Dog Timer reflejado en el programa Eclipse para el PIC16F84A (solo he visto este problema con este PIC, no se si otros presenten la misma situación) se encuentra invertido del estado real que se necesita al momento de programar. Esto es, cuando en la configuración aparece "WDT enabled" en realidad está deshabilitado, y visceversa. Esto se puede prestar para muchas confusiones...

Agradezco la atención de todos los foreros, y por supuesto, la ayuda de Eclipse para solucionar mi problema, porque en realidad necesito habilitar mi programador.
11/07/2008 #488


Hola QuimCri:

Aqui publico la version 1.0 del programador ECLIPSE con sus respectivo software y firmware.

Con respecto al WDT hasta el momento no me ha presentado falla alguna, mas sin embargo yo utlizo la ultima version de Firmware y Software publicada.
Archivos Adjuntos
Tipo de Archivo: rar version_10_132.rar (225,4 KB (Kilobytes), 207 visitas)
12/07/2008 #489


Problemas con el grabador
pues bueno, de casualidad di con este proyecto, me encontraba tratando de hacer un "pickit" y una amiga me menciono sobre este grabador y por su sencillez me animé a implementarlo, he hecho una placa con concector icsp y bueno al conectar todo era alegria y felicidad hice las pruebas y los voltajes son correctos, pero al colocar el pic a grabar (un 18f84a), al intentar hacer que lo reconozca pasó que tengo el mismo error que tiene pedro_pan en el post #514, tengo una

Laptop Compaq:
AMD semprom
512Mb Memoria
3 puertos USB
Windows SP2

al probar la version 1.1 ya no me sale el error pero de igual forma al intentar reconocer mi pic me sale : "dispositivo desconocido", que debo hacer ? porfavor agradeceria a alguien o a ti eclipse me den una solucion porque tengo un concurso los primeros dias de agosto y no se que hacer sin grabador, de ante mano agradecer la ayuda q me puedan dar y a ti eclipse por poner a disposicion libre este valioso aporte para todo aquel que ve en los microcontroladores una util e importante herramienta
Imágenes Adjuntas
Tipo de Archivo: jpg imagen1_213.jpg (164,3 KB (Kilobytes), 96 visitas)
12/07/2008 #490

Avatar de Moyano Jonathan

Problemas con programador
Zagume , con respecto a tu problema , puede ser que tu programador esté fallando debido a detalles constructivos o a problemas con el controlador open HCD estandar de USB que traen las laptops compaq con micro AMD
12/07/2008 #491


Pues a mi me aparece el mismo error que Zagume y no tengo el controlador open HCD, y no creo que sea problema de hardware.

tengo problemas al momento de reconecer el pic, leer y escribir. Al hacer la prueba del hardware desde el programa de programacion todo funciona bien, hasta se puede resetear micro desde el programa y hacer la verificacion de los pines de programacion.
12/07/2008 #492


Pero funciona todo
como dice el amigo pedro, todas las pruebas de hardware son correctas, y los voltajes igual, si puedo enviar comandos para estas verificaciones no veo porque no pueda escribir, y eso q he prbado la version 1.1 y la 1.2 pero nada que funciona, espero que puedan darme la ayuda necesaria y a celipse porfavor una forma en que tal vez ayudes, porque el pickit por ejemplo si funciona en mi laptop, solo que es muy costoso y dificil de conseguir por estos lares (Trujillo - Perú) y además me gustaria seguir aportando información a este proyecto para que salga adelante
14/07/2008 #493


Pues yo tengo los mismos problemas con el mismo pic. Todavia no e tenido oortunidad de probar con otro. De todas formas cuando hago pruebas de hardware las tensiones son las correctas. Os seguire informaciónrmando.

Un saludo!^^
14/07/2008 #494


yo ayer hize unas pruebas con el monitor del puerto usb y solo tiene habilitado para el programador 65mA ademas el 18F2550 envia siempre las tramas de comunicacion al computador yo no creo que el problema sea el controlador mas bien el soft de programador ya al hacer la verificacion de hardware todo funcion bien. No he podido medir la corriente que consume el programador aun. para ver si es suficiente los 65 mA que da el puerto.
14/07/2008 #495


Hola compañeros soy noevo en el foro y tengo el programador en protoboard y tengo problemas y me gustaria ayudar en el tema soy programador y programo en c/c++y java ya tengo un poco de espariencia con estos pic y me gustaria ayudarles con el soft pero queria pre guntarle a ECLIPSE si es posible que comparta conmigo como comunica el pic con el pc (me refiero a que datos envia, si los envia en paquetes o individuales,que le envia para que prendo o apague, etc ) para sacar la vercion en c/c++ para ver si se solucionan algunos problemas y ademas utilizar los drivers de instalacion que la microchip nos da ya que creo que posiblemente tenga mas soporte.

saludos desde Bogota Colombia.
Att: Afprog
15/07/2008 #496


Que ondas chavos
oigan talvez esto se oiga repetido, pero tengo una preguntilla desde que he empezado a armar el circuito...

no puedo cambiar la bobina por alguna otra cosa... lo malo de vivir en mexico... o si alguien sabe algun otro metodo de obtener los 13 volts, se lo agradeceria, se me ocurria voltaje externo... pero bueno, ustedes diran ok?

gracias por la ayuda brindada, i eclipse felicidades ijin, un saludo desde mexico!
15/07/2008 #497


Bueno creo que no habria mucho problema en ese asunto de la bobina puedes reciclar, yo compre hace algunos dias una placa de un monitor usado y le sacado casi todo, desde bobinas de varios valores, disipadores de calor, reguladores y una infinidad de capacitores. Ademas de eeprom serial.

Asi que podrias buscarte un mercadito me debo de imaginar que debe de haber alguno por ahi y te apuesto que encuentras la bobina que tu buscas.

Por cierto el monitor era digital.

Saludos
15/07/2008 #498

Avatar de Eclip-se

Hola a todos.

No he podido postear por que no he tenido mucho tiempo ya que he estado realizando otros proyectos.

Estoy preparando de nuevo, la version del programador ENIGMA, proto subire los archivo, con eso tenemos mas PICs para programar.

Con respecto a la ayuda ofrecida, creo que va a ser dificil por que no pienso liberar el codigo fuente, ya que se encesita del Software (Que esta echo en Visual C++) y Firmware (Que esta echo en C), los dos codigos trabajan en conjunto y sincronizadamente.

Si desean saber como esta echo, uso el principio de funcionamiento del PICKIT2, el cual es un programador de libre distribucion y codigo abierto.
15/07/2008 #499


Mmm...
ijate que si... el unico problema es que se me hace dificil encontrar las bobinas, debido a que casi nunca he visto una ¬¬... aunque mira, acabo de ir a una electronica... ahi encontre que una señora vende unas de 20MH ? a que se referira con la M?

le pongo esa? a ver que sucede? o uso asi como dije, una alimentacion externa, simplemente en la base de algun transistor aplico la salidas de las patitas de programancia?

saludos! y gracias por la ayuda
15/07/2008 #500


Re: Mmm...
megajhonny dijo:
ijate que si... el unico problema es que se me hace dificil encontrar las bobinas, debido a que casi nunca he visto una ¬¬... aunque mira, acabo de ir a una electronica... ahi encontre que una señora vende unas de 20MH ? a que se referira con la M?

le pongo esa? a ver que sucede? o uso asi como dije, una alimentacion externa, simplemente en la base de algun transistor aplico la salidas de las patitas de programancia?

saludos! y gracias por la ayuda
pues me imagino que debe de ser de 20mH (20 mili henrios) pues con esa no creo que llegues al voltaje del vpp pero deberias de probar a ver que voltaje consigues con esa.

aqui te dejo una foto, con estas son mas que suficientes para que funcionen el codigo de colores es casi parecido al de resistencias
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.