Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/11/2007 #81
Visitante


muchas gracias eclipse, lo que queria saber era que programa usaba para programarlo, pero ya vi que es el winpic 800, ya tengo el impreso, ya solo voy a colocar el pic en el, lo hice en eagle y con zocalos integrados para los pic de 8,18,28 y 40 pines, si funciona lo subire.
Una dud, tu programador tambien se podra utilizar con el winpic?
16/11/2007 #82


esteban guerrero dijo:
muchas gracias eclipse, lo que queria saber era que programa usaba para programarlo, pero ya vi que es el winpic 800, ya tengo el impreso, ya solo voy a colocar el pic en el, lo hice en eagle y con zocalos integrados para los pic de 8,18,28 y 40 pines, si funciona lo subire.
Una dud, tu programador tambien se podra utilizar con el winpic?
Va a ser que no. :-P
19/11/2007 #83
Visitante


PROBLEMA CON EL PROGRAMADOR
Hola, ya arme mi programador, hice las pruebas el hardware y realmente funciona, aemas de que verifique la tension en el zenner que me dio 12.3v.
Lo probe en una compu de mi escuela que tiene un procesador core duo a 2.0 y win xp, y me aparecen unas ventanas de error.
En mi casa lo probe en mi lap conun procesador turion 64 de un nucleo a 1.6 y win xp, y el software funciona de maravilla, sin embargo no reconoce los pic (18f2550 y 16f628), ademas al darle en programar me dice que hay un error que dice que hay un error al escribir ewn la direccion 0x0000 en el 18f2550 y 0x0020 en el 16f628, sin embargo si me permite leerlos.
No me podrian orientar a que se debera? ya verifique las soldaduras y las conexiones de los pines icsp ademas de que tengo el selector en vcc y con el zenner de 13v.
Los unicos componentes que cambie fuero los transistores ya que no los encontre, le puse los bc547 y 557, esto lo hice por que en proteus me dio el mismo resultado.
De antemano gracias.
19/11/2007 #84
Visitante


Programador
Hola , solo escribo esta respuesta para aclarar que el problema era el puerto usb de mi computadora, ahora que lo probe en otro el programador funciona de maravilla, sin embargo la unica funcion que no funciona es la de reconocer el pic 16f6877a con el que lo probe.
Imágenes Adjuntas
Tipo de Archivo: jpg error_en_intel_core_duo_20_y_win_xp_138.jpg (60,5 KB (Kilobytes), 2304 visitas)
22/11/2007 #85

Avatar de Eclip-se

Hola.

Como se indica en la pagina solo lo he probado en PC PIV, 3Ghz, SO Win XP, profesional. ServiPack 2.

Creo que al ser tu PC de 64 bit y la mia de 32. Existe incompatibilidad. Y por eso se genera el error.

Por el momento solo podra funcionar en XP. Y cuanto tenga la posiblidad lo adaptare a este nuevo tipo de PC.
22/11/2007 #86


Felicidades Eclip-se
Hola

yo soy nuevo en este foro y encontre lo que buscaba felicidades Eclip-se por tus aportes, voy a tomar en cuenta tu información ya que estoy muy interesado en programacion de PIC's, gracias y sigue adelante!
22/11/2007 #87


Hola, gente. Primero, mis felicitaciones a Eclip-se por el trabajo y lo segundo es una peticion, yo ocupo mucho el PIC648A ya que es el PIC de mas bajo costo con puerto USART, pero no lo soporta el software de grabacion. Podrias agregalo man?

Saludos cordiales

chaos
24/11/2007 #88


Una pregunta en que lenguaje hisiste el software del pc.

Te felicito y espero sigas adelante con esto ya que todos estamos agradesidos
27/11/2007 #89


Hola a todos.

Realmente estoy muy interezado en armar el proyecto de eclipse.
Estaria la posibilidad de qe alguien posteara el PCB para imprimir ?

Gracias y Salds
30/11/2007 #90


Hola amigos del foro. Felicitaciones Eclip-se por tu programador, esta excelente. Estaba a punto de comprar uno en la red pero prefiero armar el que diseñaste porque tambien permite grabar los Atmel ademas de los PICs. Tengo una duda ¿puedo cambiar el socket normal por un socket ZIF?. Muchas gracias por tu trabajo.
30/11/2007 #91


Yo he montado hoy el programador, cuando lo tenia preparado para la primera conexion no me ha funcionado, claro he pensado sin el micro como se van a encender ningun Led y cuando ha puesto el micro, ha sonado un clak y el micro se calienta muchisimo (el micro no estaba programado) y sigue sin encenderse ningun led.... Cuando mido la tension en los diodos zener me da el mismo valor, entorno a 5v pero no se si tengo mal montado el circuito, si el micro estaba defecuoso de fabrica o que es lo que pasa, he segido los esquemas y no encuentro el problema, la placa es la de la pagina que esta en PDF, la que no es SMD y la colocacion de los componentes es la que aparece en el foro. Aqui cuelgo una foto de como me ha quedado, mañana haber si saco otra con la camara buena que esta la he tomado con la camara web de ordenata.
02/12/2007 #92


Si ha sonado un clack y el micro se calienta está claro que el 18f2550 está quemado, bien por que lo hayas colocado al revés, segun esa foto debe estar orientado a la izquierda, o bien que tienes un cortocircuito de vcc con masa por algun lado.

Por otro lado no es bueno porner el micro sin grabar en el circuito... Si tiene la patilla que va a la bobina fija a nivel alto constante la quemará.

Revisa el circuito porque el problema estará por ahí.

1 saludo
02/12/2007 #93


Gracias por las observaciones, el problema era la inversion de polaridad de la conecion del USB, ahora he sustituido el micro por otro nuevo y he sustituido todos los transistores, la bobina esta bien por que le mido la resistencia y me dan 2.7 Ohm, los diodos todos dan valores entre 650 y 840 mV, segun el manual del polimetro no deberian sobre pasar los 800mV pero bueno..... Por favor revisar la correcta posicion de los componentes, es que cada micro me cuesta 11€ y lo de hacerme el programador era para ahorrar un poco. Aqui pongo una foto mejor que la anterior del montaje con el micro en su posicion......



Otra cosa, no me aclaro como hacer el programador JDM que vienen en el link, no me queda clara la posicion de los componentes, en las imagenes que aparece montado estan o sobre una placa perforada o en un fotolito del que no encuentro el esquema..... La verdad es que me corre un poco de prisa por que he pedido un ordenador que tiene puerto serie y tendre que devolverlo pronto.
02/12/2007 #94


La forma mas facil de programar el 2550 es el art2003. busca información en internet. Por cierto trabaja por puerto LPT que aun tienen todos los pc's...

http://www.micropic.es/index.php?opt...c=select&id=35

1 saludo.
02/12/2007 #95


Al final he montado el que recomienda eclipse, pero la información que he encontrado me dice como configurarlo para el IC-Prog y aunque me he bajado la ultima version no puede programar los 18F2550, ¿como deberia configurar el Winpic800? es que si lo dejo con la configuracion por defecto me da un error de lectura
02/12/2007 #96


Aporto mas datos. El error que me da es:

Error de verificacion en direccion 0x300000
Verificado:0xCF3F Leido:0xFFFF

La verdad es que no tengo ni idea de como configurar el dichoso JDM y claro si no programo el 18F2550 el programa de ecliipse no me detecta el programador. ¿Alguien me puede echar una mano?
02/12/2007 #97


si es un jdm normal deberia funcionar con la configuracion estandar de un JDM, tanto en winpic como en icprog... aunque icprog no lo aconsejo por ser antiguo

si no te funciona, o te da ese error seguramente es un fallo de montaje. Intenta darle al boton detectar pic... y sin o te dice que es un 18f2550... es que hay un fallo de montaje o configuración.

1 saludo.
02/12/2007 #98


Muchas gracias, pero me surgen dos preguntas ahora, ¿cual es la configuracion estandar para el winpic800? (es que he toqueteado todo y ya no me acuerdo como estaba al principio) y la segunda es ¿como puedo saber si mi montaje esta bien hecho?. El micro no me lo detecta, pero cuando le doy a leer no me da problemas, aunque no se si es correcto pues como el micro esta limpio las instrucciones son FFFF. Cuando le doy a verificar lo lee correctamente, me dice que el Codigo y la ID son ok pero al 98% haciendo la verificacion me da el error.
03/12/2007 #99

Avatar de Eclip-se

Hola a todos, con respecto al programador JDM. Si puede programar los otros pic y estan seguros de que funciona. Lo unico que deben hacer es poner el PIN PGM a tierra. Ahi lo reconoce el WinPiC800.

O tambien pueden utilizar el Art2003, el circuito es muy simples.

Espero que sepan disculparme la demora, pero ya estoy por terminar un proyecto pendiente y por eso no he podido estar muy seguido en el foro. Tampoco he podido revisar los incovenientes que se presentan en el programador.

Hola tambien algo que he visto del programador. Es que si ustedes hacen click en programar, leer o borrar. Aparece un error cuando no esta conectado el programador. Eso lo comprobe en mi PC. Pero al probarlo en un Celeron. No ocurre eso.

Creo que esos errores que se estan presentando tienen que ver con la configuracion S.O y con el hardware. Pero no se en donde se genera esos problemsa.

Yo lo he probado el programador y he podido programar y verficar que la mayoria de los PIC de la serie 16F y 18F los programa bien.

Por eso tengan confianza en el programador que pronto estara en su mejor momento.

Algo mas. Tal como lo decia elmasvital. No se debe conectar el PIC sin programarlo por que se debe generar la senal PWM para que funcione la bobina. caso contario estarian haciendo un corto circuito.

Gracias
04/12/2007 #100


Tras montar el ART2003 no consigo nada, pongo el 18F2550 en el zocalo y configuro el Winpic800 como dice en la pagina que indicaba elmasvital (MicroPic) no me encuentra el micro. Tras los 8 diodos mido un tension de 2.97v y entre la patilla 1 y la tierra una de 3.60v pero nada, me he compobado todas las conexiones midiendo la resistencia entre las patillas de los componentes (por la parte superior de la placa), entre los componentes y con los conectores y todo parece estar correcto. La unica diferencia con las recomendaciones de MicroPic es la version del Winpic800 es la version, la que yo tengo es la 3.62 y la del ejemplo es una anterior. En la ventana de configuracion de Hardware en mi version hay una pestaña que dice IC2 Addr y tiene un desplegable con 8 opciones del tipo 0x0a donde va desde 0 a 7.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.