Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/05/2011 #1


Ayuda con mi proyecto en LCD
Hola que tal... tengo un problema con mi LCD, resulta que se me quemo una LCD y ahora que compre una nueva no me arranca.. La lcd que ocupaba era una sencilla de esas que ni siquiera tienen backlight, y la cambie por una LMB162AFC, pero resulta que ahora no la puedo hechar a andar cuando prendo el programa sale la primera linea del dislpay con todos los cuadritos en negro, ya compre otras 3 Lcd's como la que se quemo (en estas ni siquiera sale nada) y aun asi no carga el programa, ya probé también como 3 pics y tampoco jala se supone que con solo jalar el hexadecimal al pic de nuevo bastaria para que este funcionara, pero no lo hace. las conexiones no creo que sean el problema ya que diseñe mi placa y la placa funcionaba bien con el LCD es una entrenadora para el pic, probé volver a hacer una placa exactamente igual y no funciona .. la verdad ya estoy desesperado .
Estoy controlando el LCD con 4 bits y no con 8, y ocupo para programar el software de mikroelectronica (mikrobasic pro para ser exactos) y el pic que ocupo es el 16f887, ocupo el oscilador interno del pic a 8 mhz.
Espero que puedan ayudarme xq ya probe todo lo que se me ocurre pero pues no encuentro el xq, sera que tuve tan mala suerte que compre 4 lcds defectuosas ?
28/05/2011 #2


Ajustaste el nivel del contraste?los cuadritos negros son tipico de ello.
29/05/2011 #3


le puse una resistencia de 120 ohms a tierra . podrán ser los puertos? apenas hoy se me ocurrio eso a ver le cambiare de puertos a ver si funciona
29/05/2011 #4

Avatar de fdesergio

Si sale solo la linea de arriba con cuadritos negros es porque esta mal inicializada o el programa no corre bien, casi 100% seguro falla el soft oel Micro que maneja la LCD, chauuuuuuuu
29/05/2011 #5


gracias.. yo creo que si es eso xq estoy ocupando el debugger del mikrobasic y nunca se enciende el bit del enable :S o bueno se prende pero por muy poco tiempo no esta siempre en alto como debiera
18/10/2012 #6


Activar mensaje en LCD 16X2 con botones
Hola tengo un problema con la conexión de botones para activar el mensaje y para que me pueda imprimir otro mensaje si se oprime otro botón, claro aparte del botón de Reset que igual creo no me funciona :(.

Apenas ando comenzando en la programación del pic16F84A y quiera saber como realizar dichas funciones que les comentaba.

De hecho ya tengo algo comenzado y me comienza el mensaje cuando oprimo un botón pero de igual forma todavía no logro poner el otro mensaje con el otro botón.

Deje mi código y el proyecto que llego jeje

Código:
Define LCD_BITS = 8
Define LCD_DREG = PORTB
Define LCD_DBIT = 0
Define LCD_RSREG = PORTA
Define LCD_RSBIT = 0
Define LCD_EREG = PORTA
Define LCD_EBIT = 2
Define LCD_RWREG = PORTA
Define LCD_RWBIT = 1
Define LCD_COMMANDUS = 5000
Define LCD_DATAUS = 100
Lcdinit 0

comienzo:

'Lcdcmdout LcdClear
If PORTA.0 = 1 Then  'Si el pulsador esta activado enciende el led

PORTB.0 = 1
PORTB.1 = 1
PORTB.2 = 1
PORTB.3 = 1
PORTB.4 = 1
PORTB.5 = 1
PORTB.6 = 1
PORTB.7 = 1

Lcdcmdout LcdLine1Clear

'Lcdcmdout LcdHome
'Lcdcmdout LcdLeft

Lcdout "Hola...."


Lcdcmdout LcdLine2Home

Lcdout "Mundo"
WaitMs 500

Else  

PORTB.0 = 0  

Endif  'FIN DEL CICLO


Goto comienzo


End
Imágenes Adjuntas
Tipo de Archivo: png lcd.PNG (41,5 KB (Kilobytes), 5 visitas)
Archivos Adjuntos
Tipo de Archivo: rar LCD.rar (14,3 KB (Kilobytes), 0 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.