Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/12/2010 #41


Disculpen alguien me podria ayuda a como controlar un motor por medio de labview y un pic 16f877A de favor gracias....
08/01/2011 #42

Avatar de banistelrroy

hola gracias por sus aportes les quiero hacer una pregunta es posible simular la comunicacion serial entre el pic y la pc toda simulada, esto va a que mi pc no cuenta con el puerto serie y solo me queda simularla pero aun no puedo establecer comunicacion es posible simular el Labview enlazado al circuito en Proteus osea comunicar el proteus con labview gracias por la respuesta....
27/01/2011 #43

Avatar de GT electronix

banistelrroy dijo: Ver Mensaje
hola gracias por sus aportes les quiero hacer una pregunta es posible simular la comunicacion serial entre el pic y la pc toda simulada, esto va a que mi pc no cuenta con el puerto serie y solo me queda simularla pero aun no puedo establecer comunicacion es posible simular el Labview enlazado al circuito en Proteus osea comunicar el proteus con labview gracias por la respuesta....
Pues si se puede, usando un software de simulacion de puerto virtual, hay uno que se llama virtualserial port, te dejo el link

http://www.virtualserialport.com/

con este software creas uno o mas puertos seriales virtuales en la pc que luego puedes usar con proteus y labview para comunicacion, yo lo he hecho varias veces y es bastante facil

snakewather dijo: Ver Mensaje
Solo envio este mensaje para agradecer este post gracias por compartir estos ejemplos me ayudaran para empezar con labview.
Saludos snakewather, que bueno que te sen utiles, se te agradece tu mensaje, estube ausente un tiempo, pero espero seguir aqui, gracas

sugnoel dijo: Ver Mensaje
tengo que decir que este es un buen articulo algo parecido tengo que hacer para comunicar un brazo robotico con motores a pasos y dc pero la verdad me esta costando un poco de trabajo, se te agredece tu publicacion muy buena saludos desde puebla, mexico UTP
gracias gugnoel

bbe dijo: Ver Mensaje
Disculpen alguien me podria ayuda a como controlar un motor por medio de labview y un pic 16f877A de favor gracias....
Que tipo de motor necesitas controlar?
06/04/2011 #44


Muchas gracias por tus aportes, me he podido comunicar con Labview Gracias, espero que regreses
11/04/2011 #45


no me jalo
GT electronix dijo: Ver Mensaje
Ahora un sinple ejemplo donde el PIC manda 1 byte de informacion que es leido por LabVIEW

Archivo Adjunto 33490

Archivo Adjunto 33489
mmmmmm lo prove en mi lap y no me jalo
12/04/2011 #46

Avatar de banistelrroy

GT electronix muy buenos los aportes probe y si que funciona gracias por todo
12/05/2011 #47


GT electronix dijo: Ver Mensaje
Aqui dejo el primer ejemplo dondel LabVIEW manda 1 byte de informacion que recibe el pic y lo despliega en el puerto B.

Archivo Adjunto 33470

Archivo Adjunto 33471

Archivo Adjunto 33472

Aqui dejo el PCB en Eagle 4.13 de la tarjeta de desarrollo sobre la cual he probado todos mis proyectos

Archivo Adjunto 33474

Archivo Adjunto 33475



Hola, muy bueno. Ya estoy algo familiarizado con la comunicación serial en labview con max 232 y 16f877a. Solo me falta el recibir datos desde labview.
Veo que acá haces un ejemplo de ello.
Mi pregunta es, que pic usas???
Tendrás el proyecto en PICC (CCs) o en C?
SLDS y gracias de antemano!!!
13/05/2011 #48

Avatar de GT electronix

kaymar dijo: Ver Mensaje



Hola, muy bueno. Ya estoy algo familiarizado con la comunicación serial en labview con max 232 y 16f877a. Solo me falta el recibir datos desde labview.
Veo que acá haces un ejemplo de ello.
Mi pregunta es, que pic usas???
Tendrás el proyecto en PICC (CCs) o en C?
SLDS y gracias de antemano!!!
Hola kaymar, para responder tu primera pregunta el PIC que utilizo en todas las practicas aqui expuestas es el 16F877A, programando con PIC Simulator IDE. Actualmente estoy estudiando el PICC porque veo que es muy bueno pero no he llegado a hacer practicas ahun, talvez dento de un par de meses subo un ejemplo con el PICC, saludos,
17/05/2011 #49

Avatar de banistelrroy

una duda tengo ejemplos en labview 8.5 y el driver NI vis 4.3 los podre habrir los archivos si instalo la version de labview 8.6 .....digo esto porque hay ejemplos de la version 7.1 o 5 que no se puede en abrir en la que yo tengo instalada busca algo que no ecuentra y se sierra solo como si algo le faltara....espero me puedan ayudar...gracias a todos por la respuesta que den
24/05/2011 #50

Avatar de GT electronix

banistelrroy dijo: Ver Mensaje
una duda tengo ejemplos en labview 8.5 y el driver NI vis 4.3 los podre habrir los archivos si instalo la version de labview 8.6 .....digo esto porque hay ejemplos de la version 7.1 o 5 que no se puede en abrir en la que yo tengo instalada busca algo que no ecuentra y se sierra solo como si algo le faltara....espero me puedan ayudar...gracias a todos por la respuesta que den
Hola banistelrroy, yo he abierto VIs hechos en Labview7.1 en versiones superiores como la 8.0, 8.1 y 8.6 y 2009 sin ningun problema, ahora si tu VI utiliza modulos especiales como PID o Fuzzy logic, etc, entonces si necesitas instalarlos tambien para que te funcione correctamente.
30/05/2011 #51

Avatar de banistelrroy

ok GT electronix gracias por tu respuesta ya lo instale de todas maneras....
23/10/2011 #52


hola una pregunta tengo este codigo para el pic 18f4550
#include <18F4550.h>
#fuses HSPLL,NOWDT,NOBROWNOUT,NOPROTECT,NOLVP,NODEBUG,USB DIV,PLL5,CPUDIV1,VREGEN,MCLR,NOPBADEN,WRTB
#use delay(clock=48000000) // frec osc
#build (reset=0x800, interrupt=0x808)
#org 0x000, 0x7ff{}
#use rs232 (baud=9600, xmit=pin_C6, rcv=pin_C7, parity=N, stop=1,FORCE_SW)

void main() {
int d;
d=getc();
for(;
{
setup_ccp1(ccp_PWM);
setup_timer_2(T2_DIV_BY_1,39,1);

if (input (PIN_B0)==1 || d==1)
{
set_pwm1_duty(1);
}
else {

if (input (PIN_B1)==1 || d==2)
{
set_pwm1_duty(3);
}
else {
if (input (PIN_B2)==1 || d==3)
{
set_pwm1_duty(4);
}
else { set_pwm1_duty(0);
}
}
}
}
}
lo que tengo duda es como hacer que me compare lo que estoy mandando con labvew,,ya tengo la comunicacion simulada en proteus,,y me manda unos datos en virtual terminal del proteus. pero no me los lee el pic o no se si los estoy enviando como se deve,,pero segun si los estoy enviando bien,,pero como ago que el pic compare si el valor enviado en labvew es = 1 lanse un tren de pulsos,,,si es 2 lanze otro tren de pulsos,,,y si es 3 lanze otro tren de pulsos,,,,me podrian ayudar porfavor??? nota,,,disculpen por la faltas de ortografia
29/10/2011 #53


slander dijo: Ver Mensaje
hola amigo muchas gracias por subir tus `proyectos jejeje sabe ,,grax por las aportsaciones ami tambien me gustaria aportar, ya tengo 3 practicas q en esta semana me gustaria compartirlas jejejej, aprendi un poco rapido jejejeje solo es un poco de dedicacion,, tengo para enviar un dato desde la pc al pic, el cual consiste q cuando envio un 1 enciende y cuando envio el 0 lo apaga, tambien el segundo programa es el giro del motor horario y antiorario pero ese es por el puerto paralelo y el 3 programa es calcular la velocidad de un velocimetro el cual lo muestra en un lcd y en labviet je, estamos en contacto la verdad si necesito ayuda y si tubieras un correo directo para comunicarnos, gracias
talves poner el ejemplod del giro del motor en sentido horario y antihorario
25/11/2011 #54


Ayuda!!
GT electronix hola amigo y primero te felicito por el gran trabajo que realizas en este tema y me parecen muy divertidos e interesantes todos tus proyecto ... bueno al grano jejejeje mira estoy haciendo un proyecto para mi carrera.... tiene que ver con bioingenieria... te lo resumire en pocas palabras tengo que tomar las señales de los musculos humanos EMG amplificarlas ya que estas son demaciadas pequeñas de 10 o 100 milivoltios... luego estas señales las en vio a un canal de un PIC en este caso al 16F877a, éste digitaliza la señal y la envia por el puerto serial, la interfaz que deseo usar es LabView..... trato de enviar las señales pero nada no me sale :( se que me trasmite por que desconecto el pin de transmisión del PIC y cambia a cero, vuelvo a conectar y me muestra una señal el problema es que me muestra una señal de ampitud 15... te enviare las imagenes ..... nota: la primera imagen es una señal ECG en osciloscopio que yo tome, necesito EMG si lo se pero es para probarlo es mas facil con esa señal y la segunda imagen es la que me trasmite el pic en LabView..... te agradezco la ayuda y estaré pendiente a toda respuesta..... gracias!!

Julblack
Imágenes Adjuntas
Tipo de Archivo: jpg ECG.jpg (179,0 KB (Kilobytes), 55 visitas)
Tipo de Archivo: jpg señal_labview.jpg (91,1 KB (Kilobytes), 59 visitas)
Archivos Adjuntos
Tipo de Archivo: rar first.rar (15,4 KB (Kilobytes), 202 visitas)
25/11/2011 #55

Avatar de GT electronix

julblack dijo: Ver Mensaje
GT electronix hola amigo y primero te felicito por el gran trabajo que realizas en este tema y me parecen muy divertidos e interesantes todos tus proyecto ... bueno al grano jejejeje mira estoy haciendo un proyecto para mi carrera.... tiene que ver con bioingenieria... te lo resumire en pocas palabras tengo que tomar las señales de los musculos humanos EMG amplificarlas ya que estas son demaciadas pequeñas de 10 o 100 milivoltios... luego estas señales las en vio a un canal de un PIC en este caso al 16F877a, éste digitaliza la señal y la envia por el puerto serial, la interfaz que deseo usar es LabView..... trato de enviar las señales pero nada no me sale :( se que me trasmite por que desconecto el pin de transmisión del PIC y cambia a cero, vuelvo a conectar y me muestra una señal el problema es que me muestra una señal de ampitud 15... te enviare las imagenes ..... nota: la primera imagen es una señal ECG en osciloscopio que yo tome, necesito EMG si lo se pero es para probarlo es mas facil con esa señal y la segunda imagen es la que me trasmite el pic en LabView..... te agradezco la ayuda y estaré pendiente a toda respuesta..... gracias!!

Julblack
Que tal julblack, te cuento que estos dias estoy un poco ocupado con mi trabajo pero espero responderte pronto, estamos en contacto..
26/11/2011 #56


GT electronix ok de igual te agradezco por responderme y si espero la ayuda gracias!!!!!!
09/12/2011 #57


Amigos vamos ayudenme jejejeje estoy algo desesperado, ya que es mi proyecto de carrera y no se por que sale la señal asi :( help me!!!!
09/12/2011 #58

Avatar de GT electronix

julblack dijo: Ver Mensaje
GT electronix ok de igual te agradezco por responderme y si espero la ayuda gracias!!!!!!
Perdon julblack por la demora, pero realmente he estado bastante ocupado.
Bueno, al tema, viendo tu VI encontre que para hacer la lectura usas el bloque "Bytes at port", antes del READ, a mi me dio problema de esa forma, lo que hice fue definir exactamente cuantos bytes se van a leer creando una constante en vez de usar el bytes at port.
Otro detalle que te queria preguntar es si instalaste el Driver CD de labview.

Bueno espero tu respuesta a ver como te va, hasta pronto.
09/12/2011 #59

Avatar de Rigeliano

Hola GT electronix, yo estoy intentando aprender un poco de Labview pero no se muy bien como hacer algunas cosas, obtuve un programa con comunicación serial para con el pic 16f877A lo probe y anda muy bien bueno eso es creo, lo que quiero es agregarle otros canales del adc del pic y que por ejemplo en uno me sense la temperatura en otro la humedad o cualquier cosa que se me ocurra pero no se como hacerlo en labview para obtener las graficas a la vez lo del pic ya lo tengo solucionado? y otra pregunta el puerto com de la PC funciona bien pero el conversor USB a serie no funciona bien es esto asi o es que algo anda mas con el conversor? Este es el archivo
Gracias por tu respuesta
Archivos Adjuntos
Tipo de Archivo: zip Prueba.zip (35,4 KB (Kilobytes), 303 visitas)
14/12/2011 #60


Hola yo ando trabajando en algo similar recibo y mando datos, la de reicbir ya esta, mi duda es como enviar datos de labview al pic, en ccs con que alguien me facilite como encender un led me basta y sobra
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.