Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/08/2011 #101

Avatar de atricio

mi amigo la verdad me fregaste xq por el momento formatie mi maquina y no tengo el labview instalado talvez si le dices a nuestro amigo que si uso el vi que tel o pase a una compatibillidad y te lo envie por mail seria bueno lamento no poderte ayudar tan pronto
30/08/2011 #102

Avatar de thunder2

Proyecto con PIC y Labview
Hola Atricio, agradezco tu respuesta. Organizare un poco el PC para los archivos y adjuntare para que cualquiera que lo requiera lo adapte a sus necesidades. Creo ya buscar la comba al palo como se diria vulgarmente. Es solamente a la cadena de caracteres que envie el PIC, dividirlos por los datos que tenga la variable o señal del ADC determinada.

Gracias por sus respuestas.
30/08/2011 #103

Avatar de atricio

gracias asi podemos ayudarnos todos
11/10/2011 #104


necesito ayuda para poder visualizar diferentes valores de diferentes sensore que implemente en un pic,,pero no se como mandarlos ala pc,,(labview) en forma rs232 ,,serial....me podrias ayudar con la interfaz?
17/10/2011 #105

Avatar de mecatrodatos

arevlox:

primero que tipo de sensores
segundo que lenguaje de programacion manejas
tercero que tienes hecho
18/10/2011 #106

Avatar de atricio

disculpen una pregunta por favor sabe alguien como usar las visas de labview para realizar la comunicacion
serie para comunicar un micro con labview
18/10/2011 #107


bueno,,estoy programando en CCs ya tengo el sansado,,son 5 sensores,,,temperatura, humedad, RH y lux,,,en si, ya los puedo mandar del pic ala pc por el puerto serie,,,el problema es q no lo puedo sincronizar con labview,,los valores se empiesan a rotar y enves de mostrarme el valor de la temperatura me muestra el de la humedad y asi sucesivamente...y no se muy bien como hacer que los valores se mantengan donde deben
Archivos Adjuntos
Tipo de Archivo: rar Programa.rar (72,1 KB (Kilobytes), 318 visitas)
18/10/2011 #108

Avatar de atricio

mira mi amigo en la U hicimios con un stacked secuence structure en el primero configuramos el puerto y en los demas frames fuimos anadiendo tantas lecturas y escrituras que necesitamos para enviar o visualizar eso en el labview pero en el micro enviamos un numero adicional ademas del dato para que el labview sepa de que case se esta mostrando y se visualice efectivamente lo que se requiere no se si me entiende ahorita no tengo ese programa dejam lo busco y te lo subo para que lo analices y veas si te sirve
19/10/2011 #109


ok,,,si,mas omenos,,te entiendo,,,,mandar una clase de identificador para que labview sepa que es lo q esta recibiendo,,,,ok,,,muchas grasias,,,espero tu respuesta,,,
22/10/2011 #110

Avatar de mecatrodatos

arevlox, ya que mencionas que utilizas CCs te recomiendo este libro

LIBRO LabVIEW,Entorno Grafico de Programacion, LabVIEW 8. 20


atricio, ya te envie a tu correo lo necesario para que empieces con tu proyecto hechale un vistazo.
22/10/2011 #111


ok,,,muchas gracias por su apoyo

Muchas gracias brother, por el libroo,,,Dios te bendiga!!!!!
23/10/2011 #112

Avatar de mecatrodatos

para el amigo andresfelipemt: que formulo una consulta en el Curso programacion de pic en bsic pro qaui esta el apoyo para realizacion del proyecto por puertos.

http://www.4shared.com/document/PPhg...ew_PUERTOS.htm
23/10/2011 #113


como puedo hacer un panel de control, desde labview para activar bombas de agua, y aspersores por medio de un PIC? no se como mandarlos pro la visa write,, aguien me puede alludar?? selos agradeceria muchoo!!!!
24/10/2011 #114


gracias por el manual mecatrodatos
25/10/2011 #115

Avatar de MAXTORCAMPOS

Saludos amigo Mecatrodatos tengo un gran problema con almacenar cadenas en una varaible en PBP, no se como se hace, cuando uso una sola letra va bien pero con dos o mas no lo hace, te adjunto la lineas para que veas lo que necesito

ASI ME FUNCIONA BIEN:
IF DATO = ["J"] THEN PORTB.0 = 1

ASI NO ME FUNCIONA:
IF DATO = ["+CMT: "+584267594819",,"2011/10/24 12:00:21-18" buenos dias"] THEN PORTB.0 = 1

la cadena que necesito tomar en una variable es esto:

+CMT: "+584267594819",,"2011/10/24 12:00:21-18" buenos dias

me puedes ayudar como hacerlo?




Mil gracias
28/10/2011 #116


hola que tal, estoy haciendo un proyecto de una hormiga exploradora por medio de un PIC, la cual cuenta con sensores y un modulo de RF XBee para poner comunicarse con otro modulo de RF XBee y hacer un convertidor de RF-USB.
Y me gustaría saber como hacer una interfaz con LABview para monitorear en tiempo real la lectura de los sensores, y ala ves poder re programar el PIC, por medio de (USB<->XBee1<->XBee2<->PIC). el PIC cuenta con un bootloader,¿y se necesitaria un convertidor de 232 a usb para la comunicación del XBee con la PC? o abría necesidad de un micro 18fx5xx para poder tener comunicacion entre el XBee y la PC?

GRACIAS POR SU AYUDA!!
19/11/2011 #117


alguien sabe como mandar datos desde Labview por el puerto serie, pero que nadamas se un bit, que no sea toda la secuencia, es que estoy trabajando en un proyecto para el control de un invernadero, la parte del monitoreo y el control manual me funciona bien, el problema es el control automatico, para el control manual solo utilice botones OK en labview y listo pero el problema con el control automatico es que como me esta mandando todos los bit en serie no los puedo controlar y el pic no me responde, alguien sabe como puedo mandar solo un bit?
21/12/2011 #118

Avatar de atricio

arevlox dijo: Ver Mensaje
alguien sabe como mandar datos desde Labview por el puerto serie, pero que nadamas se un bit, que no sea toda la secuencia, es que estoy trabajando en un proyecto para el control de un invernadero, la parte del monitoreo y el control manual me funciona bien, el problema es el control automatico, para el control manual solo utilice botones OK en labview y listo pero el problema con el control automatico es que como me esta mandando todos los bit en serie no los puedo controlar y el pic no me responde, alguien sabe como puedo mandar solo un bit?
disculpa parece que nadie te ha contestado especificamente que es lo que deseas hacer no te entiendo que refieres como secuencia manejo un poco labview quizas si me explicas podamos
aprender juntos
28/02/2012 #119


Amigos:

quizas este cerrado este tema, pero tengo el siguiente problema.
con un pic 16F873A estoy leyendo 2 señales analogicas provenientes de 20amplificadores de instrumentacion usados para amplificar la señal de 2 celdas de carga.
La salida del Amplif instr esta conectadas a las patas ADC del PIC y luego usando un MAX232 conecto ese proyectyo a una PC con Labview.

El pic esta configurado para convertir las señales analogicas y enviar la conversion por UART a la pc. El labview levanta esos datos y los traduce a peso.

Simulando todo el proyecto con proteus y labview la conversion es perfecta. no hay perdida de bits en la comunicacion.

ahora cuando utilizo el sistema de celdas+amplif de instru+pic+max232+labview al leer los datos con hyperterminal veo que la señal convertida por el pic oscila entre +- 20 bits. Es decir si la conversion ADC deberia ser 128 bits , con simulacion en proteus y viendo los datos recibidos por hyperterminal recibo los 128+-1 bit. Ahora cuando energizo el sistema pic+max232 la lectura con el hyperterminal de los datos enviados por el pic correspondientes a la conversion tienen un error de +-20 bits.

La complicacion surge cuando al medir la calidad de la señal de 0-5v provenientes de la placa amplificadora de la señal de las celdas, esta medicion es muy estable incluso medida en los bornes previos a las patas ADC del PIC. Pero si tomamos los datos enviados por el pic al puerto seria como si la señal analogica variara en +-5% del valor original lo cual es imposible ya que el peso colocado sobre las pesas esta fijo.

Alguna sugerencia en cuanto al armado de la placa del pic con el 232.

Adicional quiero comentar que en una misma placa estan conectados los bornes para conectar las señales analogicas, esta alojado el MAX232, el pic. Es recomendable esta configuracion?
Estoy seguro que es ruido pero de que forma podria mejorarlo??
29/02/2012 #120

Avatar de atricio

puedes conectar un capacitor 104 en los terminales de alimentacion del pic puede estar entorpeciendo el trabajo del micro adicionalmente puedes tener mal estructurada la tierra para todos los circuitos primero por ahi siempre vas a tener ruido pero seria necesario que hagas un lazo para hacer un promedio y una compenzacion ya sea en el micro o en labview
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.