Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/05/2009 #1


El puerto serie me comunica las letras y no los numeros
Como ya les conte, estoy aprendiendo esto de los pic

Estuve "Programando" en niple, y arme un pequeño programa que cuando apreto el boton que esta conectado a Ra0 se escribe en el virtual terminal del proteus "UNO" y si apreto el Ra1 se escribe "DOS" y asi con 4 botones. (Todo esto con el pic 16f627 con Usart)

Mi problema es cuando intento en vez de escribir un texto, escribir una variable o un valor fijo (o sea un numero), no pasa nada. no aparece nada en el terminal virtual, ni se inmuta.

Alguien sabe que esta mal? el terminal virtual imita un puerto serie no?

Saludos Gonzalo
25/05/2009 #2

Avatar de Meta

Prueba con el HyperTerminal de windows o Telnet.
26/05/2009 #3


Si quieres ver los valores tienes que ponerlo la terminal en modo hex por que normamente esta en modo ASCII que es la forma que se puede ver los simbolos predeterminados en su tabla de valores.
26/05/2009 #4


Como pruebo con el hyperterminal de windows si no tengo el circuito montado?

Como hago para poner el terminal en modo hex cristian? te aseguro que busque pero no encontre... o no supe buscar :(

Saludos
27/05/2009 #5


Mira yo he usado mejor que el hyperterminal el Advanced Serial Port Monitor. El problema que es una trial de un mes. En ese mes eso sí yo he conseguido ya saber mejor que era lo que pasaba. Eran la configuración de los bits de configuración que entraban en conflicto con los #fuses dando a lugar a una falta de sincronía.
27/05/2009 #6


Pero ese programa no es para leer y escribir en el terminal fisico de la pc? Por que yo no lo arme, solo la simulacion tengo.

Saludos
28/05/2009 #7


Lo que me dicen de los hiperterminal seria usar el "portcim" (Creo que se llama asi, el deb 9 del proteus) y configurar el programa hiperterminal?

Saludos
28/05/2009 #8


Hola encontre el hyperterminal de windows, Creo que lo configure, pero no me funciono usando el db9 del proteus, necesito ponerle un max232 a la simulacion? Necesito conectar algun otro pin que no sea el de recepcion?

Saludos y muchas gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.