Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/11/2010 #1


Ruido (frecuencias) En PICs
Bueno la verda es algo q a mas de uno le a tocado y es el ruido (o frecuencias parasitas) que interfieren en un programa de los pics, y dentro de lo proyectos q hecho hasta ahora este es el primero con ese problema , resulta que que tengo un proyecto de la universidad que me pidieron montar en una empresa de plasticos por mi casa,,, y realice un contador de paquetes bueno el programa funciona a las mis maravillas, pero en el lugar donde esta hay, 1 mucho ruido, donde coloque la placa hay 2 transformadores grandes de los cuales sospecho me interfieran,, en ese orden de ideas lo que realice fue armar de nuevo mi diseño y añadirle mas filtros a mi fuente pero nada ocurre lo mismo el pic parece como si se detuviera despues de un tiempo de trabajo ya q no hace nada, tambien he probado cuando no hay casi ruido y solo esta ea maquina funcionando, que hacer con esas frecuencias parasitas o que muy probablemente generan los transformadores q hay ahi...

bueno realizo mejor la pregunta ya q no he obtenido respuesta alguna,, aparte de condensadores en la fuente y en la entrada de los sensores q mas coloco para evitar ruido o frecuenncias indeseadas..

gracias adjunto imagen
02/11/2010 #2


Por eso hacen las pruebas radioelectricas. No dices el micro ni frecuencia de trabajo.
Es importante la colocación de condensadores en todas las entradas (en el reset tambien) los de descoplo cerca de la pata positiva. Pistas sin angulos rectos....
Son tantas cosas.
Postea circuito y placa a ver que se puede hacer.
03/11/2010 #3


el pic que utilizo es PIC18F2550, a 12Mhz solo utilizo 2 de las 3 Int externas de este pic, y el nible alto para el lcd,, ahi viene mi pregunta dices q coloques los capacitores a todas las in, inicialmente le coloque a las dos q utilizo como lo muestra la imagen del primer mensaje. e igualmente me faltaria colocarle al Reset ya q solo lo tengo con una resistencia de 4k7.
Lo de los agulos rectos,, yo he tenido eso en cuenta pero en las placas de sonido generalmente,,,
03/11/2010 #4

Avatar de pepechip

Hola
Mira si los pines que has dejado al aire actuan sobre algun tipo de interrupcion que tengas activada y hace que el programa se bloquee.
03/11/2010 #5
Excluido


Nomas de puras curiosidades, intenta alimentar el pic con baterias.
03/11/2010 #6


pepechib, pues para los sensores utilizo RB0, RB1 como int externas y las activo y desactivo por programa solo cuando las utilizo ahh,, yo tuve en cuenta lo de las prioridades por lo q por ese lado estoy bien, encuanto a la otra interrupcion qu es INT2 por RB2, la utilizo como salida digital para el LCD rw, una pregunta para todos,, como yo visualizo ese conteo en un lcd el cual lo tengo con un cable a 4 metros de distancia que es donde se ve,,, mi pregunta es siendo nada mas datos habra problemas con el ruido o frecuencias por eso, eso lo pense cuando lo realice pero al ver de que el voltaje llegaba bien y el contraste se vei bien vi que por ahi no era el problema,, el lcd esta a 4 bits utilizo E, RS,RW y alimentacion todo lo anterior no es mas que datos los que viajan por ese cable. lo demas esta en placa
03/11/2010 #7


Uffff!! El cable ha de ser de buena calidad y apantallado y conectado el negativo a masa. Te entra por ahí toda la sucidad. Conecte uno a 2 metros y me toco hacer las de Cain (por no decir las de fogonazo, )para que anduvise medio decente.
Si, coloca un c desacoplo al reset.
La fuente no suele dar problemas si viene de los 24 AC de maniobra y está decentemente calculada.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.