Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

17/04/2012 #41

Avatar de Meta

El diodo laser chupa corriente. Mejor usarlo con fuente diferente al PIC. Así no te quita recursos o simplemente pon una buena fuente que tenga muchos A para que tire sin arrastrar.
17/04/2012 #42


1. prueba con fuente de pc : puse el didod y el condensador y no hace la secuencia se lo quito y funciona alas mil maravillas
2. prueba con el adaptador : se uqeda quieto no hace la intermitencia.....

el motor es de 3v de lo saque de un carrito de jugar.... mi pregunta es esta por que cuando conecto el motor directamente al adaptador me funciona correctamente "fuerza y velicidad" pero en circuito no y los y el micro manda el pulso pero no hace la intermitencia que debe hacerla?
17/04/2012 #43


mi pregunta es esta por que cuando conecto el motor directamente al adaptador me funciona correctamente "fuerza y velicidad" pero en circuito no y los y el micro manda el pulso pero no hace la intermitencia que debe hacerla?
podria poner el codigo para simularlo y ver de que intermitencia hablas?
17/04/2012 #44


Inicio

movlw .8
movwf num1
movlw b'11111011'
movwf portb
call retardo_5s
movlw b'11101000'
movwf portb
call motor
call motor
call retardo_1s
goto mas

mas
movlw b'11111010'
movwf portb
call retardo_1s
movlw b'11101001'
movwf portb
call retardo_1s
call motor
decfsz num1
goto mas
goto menos23

menos23

movlw b'11101010'
movwf portb
call retardo_2s
call retardo_2s
movlw b'11101000'
movwf portb
call motor
call motor
goto inicio

motor
movlw b'00001100'
movwf portb
call retardo_2ms
call retardo_1ms
movlw b'00001000'
movwf portb
return

include retardos.inc



end
17/04/2012 #45


uy.... es ensamblador.... ese no lo domino... aparte de que creo que le falta el retardos.inc, no?

yo queria simularlo...

bueno pues a mi ya no se me ocurre que mas puede estar fallando, y ya puse el esquema que segun yo deberia funcionar... sorry!
17/04/2012 #46


mmm que mal ... que raro por que sera que pasa eso...... ademas quito el motor y empieza hacer la secuencia normal
el programa es sencillo solo de encendr y apagar los laser.. pero se quedan prendidos, quito el motor y funciona bien..
pero con la fuente de pc funciona exlennte
17/04/2012 #47


mi pregunta es esta por que cuando conecto el motor directamente al adaptador me funciona correctamente "fuerza y velicidad" pero en circuito no y los y el micro manda el pulso pero no hace la intermitencia que debe hacerla?
Opps... los motores son componentes inductivos que afectan al funcionamiento de los microcontroladores y algunos integrados, como podria ser el caso del l293D, los capacitores que te sugerimos de 100nF y el diodo en antipralelo podria servir para reducir el efecto, en algunos casos se tienen que aislar por completo los circuitos del motor para que funcionen....

en tu caso yo creo que pueden ser cinco cosas, falta de corriente de las fuentes, mal filtrado, un ruido producido por el motor, una mala conexion,o el codigo....
17/04/2012 #48


mmm codigo esta bien conexion bien . ruidos no .... por que de lo contrario cuando lo alimento con la fuente del pc no funcionara y funciona correctamente el motor y la intermitencia del los laser..

el problema es con el adpatador ...
17/04/2012 #49


las fuentes de PC estan diseñadas para proporcionar un voltaje y corriente para controlar todo un monton de procesadores y componentes que tiene un PC (ver fuentes SMPS) en condiciones extremas, incluso la carcasa es metalica por una razon...

los adaptadodores esta diseñados para alimentar un dispositivo que tiene normalmente un circuito de regulacion....

ahora puedes buscar una fuente SMPS de un DVD o un minicomponente o impresora... y seguramente tambien te va a funciona sin problemas...

haz la prueba de poner un cable mas largo al motor y separalo del circuito y pon el adaptador como fuente...
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.