Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/12/2011 #1


Ruido en Señal IR
Tengo un pequeñisimo problema que no he podido solucionar...

He decodificado la señal infrarroja para encender un minisplit... si, han leido bien, un minisplit, porque no tiene retroalimentación de ninguna manera, asi es que solo se puede encender o apagar con e control remoto, entonces, lo que hice fue decodificar la señal de on y off y los datos los metí a un micro PIC18F4550. Todo está bien, hasta el punto en que no puedo hacer que encienda ni que apague...

Cheque la señal que grabe al pic con un receptor y me di cuenta de que existe un poco de ruido cada vez que el pulso se va a cero... anexo la imagen para explicar mejor...

señal ruido.JPG

(NO se si se pueda ver la imagen...)...

Lo que yo pienso que pasa es que al llegar a cero, se empieza a meter ruido pues el receptor siempre está en un valor 1 (5v)... y como no tiene señal alguna en el momento en que la señal infrarroja "envia" un cero... el receptor se vuelve loco... hice la misma prueba con el control y la señal es perfecta...

mi duda es... como puedo montar esa señal para que el valor lógico en tiempo bajo no sea cero volts.
09/12/2011 #2
Moderador

Avatar de Chico3001

Postea tu circuito, solo asi podemos ayudarte....
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.