Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/03/2011 #1


ayuda a saber si pic funciona o esta roto
buenas tardes hace un tiempo consulte que pic comprar y me recomendaron entre mis opciones un 16f628a la verdad hasta el momento todo de lujo así que muchas gracias, pero ahora me encuentro con un problema al momento de leer el pic desde la pc o grabarlo todo bien la pc reconoce lo que esta escrito en el pic y el pic se graba correctamente pero cuando lo coloco en mi protoboard este no hace nada, tome los valores de todas las patas y todas esta a un voltio y la verdad no se por que sucedes esto, como dato utilizo el oscilador interno y un regulador lm317t a 4.8V, siempre lo utilice con resistencias de entre 5K y 10K para los demas pines, la verdad no se por que es que no me funciona, no se si ya lo habre roto o que jej, espero me puedan dar una respuesta, disculpen las molestias y desde ya muchas gracias
02/03/2011 #2

Avatar de fdesergio

Donde seleccionas el uso del oscilador interno?? seguro lo haces bien, sucede que se usa con un oscilador pero esta programado para trabajar con otro, contanos, chauuuuuuuu
02/03/2011 #3


si, cuando utilizo mikro c lo selecciono en una parte que dice el programa y hasta ahora me funcionaba y cuando uso picbasic pro lo selecciono en el icprog selecciono intrc i/o que tambien me funcionaba, todo lo que hago es como lo hacia pero tal vez antes me funcionaba de casualidad o algo no se
02/03/2011 #4
Moderador

Avatar de Chico3001

Casi con seguridad es un problema en el codigo o en la configuracion ya que el programador lo reconoce y reporta que queda bien grabado

Cuando tengo dudas de este tipo le cargo un programa de prueba que lo unico que hace es parpadear un led ("hola mundo") y asi determino que el pic esta funcionando correctamente

Intenta con el ejemplo de esta web:

http://www.oz1bxm.dk/PIC/628LED.htm
02/03/2011 #5


muchas gracias chico3001 con esto ya me di cuenta que el pic a muerto, hice lo que me dijiste pero no funciona asi que creo que me quede sin juguetito :( mucahs gracias por las respuestas

lo solucioneeeeeeeeeeee no se por que pero derrepente dejo de funcionar el oscilador interno, acabo de conseguir las cosas para usar oscilador externo y funciona de maravilla todavía no entiendo por que no funciona con el oscilador interno pero por lo menos ahora funciona por eso quería compartir esto con los demás por que capas que a alguien le suceda lo mismo bueno saludos y suertes
02/03/2011 #6
Moderador

Avatar de Chico3001

Normalmente el oscilador interno se configura desde los fusibles de programacion a la hora de descargarle el programa, desafortunadamente no estoy muy familiarizado con los fusibles para este micro pero casi con seguridad te puedo decir que estan configurados para usar un oscilador externo...

Revisa el datasheet del micro...

Edit:

tienes esta linea en tu codigo???

__config _INTRC_OSC_NOCLKOUT & _LVP_OFF & _WDT_OFF & _PWRTE_ON & _BODEN_ON
02/03/2011 #7


no en mi codigo no tengo ninguna linea como esa en realidad yo nunca configure eso de los fuses por que el mismo programa mikro c y picbasic tienen la opcion para agregarlo ellos automaticamente a los proyectos se selecciona el tipo de pic, el tipo de reloj y la velocidad es mas cuando agrego esa linea en los programas me da error de sintaxis al momento de compilar introduciendolo como lenguaje C , como lenguaje basic o como asm en esos programas me da ese error
02/03/2011 #8
Moderador

Avatar de Chico3001

mmm que raro... casi estoy seguro que es un problema de configuracion de software..
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.