Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/07/2012 #1


Sensor de proximidad
Alguien sabe porqué me pasa ésto, después de tanto probar con lo que verdaderamente tenía que hacer, con pics de algunos modelos y series y en vista de que no me funcionaba el proyecto se me ocurré hacer una programación que se suponía era para un led intermitente, ustedes son 4 líneas de programación y acabó la historia y al rato de probar pasó ésto porqué será alguien sabe, o será que me acabó de inventar algo

09/07/2012 #2
Moderador

Avatar de Chico3001

Si subieras mas informacion podriamos intentar ayudarte.. de lo contrario solo podemos adivinar...
09/07/2012 #3


Chico3001 dijo: Ver Mensaje
Si subieras mas informacion podriamos intentar ayudarte.. de lo contrario solo podemos adivinar...
Pues que mas subo?, el led va al puertob.0 y la "programación" era en pbp y era
inicio:
high portb.0
pause1000
low portb.0
pause 1000
goto inicio
09/07/2012 #4
Moderador

Avatar de Chico3001

Que PIC es?
tiene oscilador interno o esta configurado para usar oscilador externo?
Intentaste cambiando de lugar el PIc en el Proto?
09/07/2012 #5


Alcanzo a ver que solo estas alimentando al pic, pero el MCLR no esta conectado y el oscilador como esta funcionando?
09/07/2012 #6

Avatar de Justiciero24

A lo que puedo adivinar es que quizas dejaste algun puerto mal configurado y esto te esta metiendo ruidos, y otra cosa es que no esta el capacitor para evitar que se reinicie el pic.

saludos,
11/07/2012 #7


Saben estuve averiguando por todo lado que pudo haber pasado y bueno la respuesta del Justiciero24 me volvieron a decir, la del puerto mal configurado pero me dijeron que ese puede ser daño interno, otra que me dijeron es que el proto a veces puede comportarse como un capacitor por su estructura, y la otra que me dijeron fue por estática, ustedes que opinan de eso.
11/07/2012 #8


El MCLR no está conectado a nada, no tienes condensadores de filtro en la alimentación, con lo que imagino que estás induciendo ruído, y al tener esas patillas al aire tendrás resets aleatorios y funcionamientos inestables. Pon un condensador de 100k (o nF, nanoFaradios) entre VCC y VSS (positivo y masa) y la patilla del MCLR con una resistencia de pull-up de 4k7 a VCC. Con eso te aseguras de que la parte hardware no te de problemas, otra cosa es el programa en sí. Y mi opinión es esa, que es porque induces ruído en el conjunto del circuíto y no tienes absolutamente nada para paliarlo. Pruebalo, que total son 2 minutos y cuenta qué tal. Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.