Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/05/2010 #21

Avatar de seaarg

Respuesta: serial 9600 sin xtal funciona en asm y no en c
Carlos, ezavalla:

Setup_oscillator(OSC_4Mhz);

Interesante probar con esto. Lo hare. El fastio ya lo estoy usando (nunca me gusto
que sea dinamico, prefiero tener el control de eso).

Tambien voy a ver el parametro
UART1 por las dudas de que al decirle los pines le este indicando que sea por soft.

Apenitas pueda hacer las pruebas les comento.
18/08/2010 #22

Avatar de seaarg

Respuesta: serial 9600 sin xtal funciona en asm y no en c
Bueno, ya daba este tema por descartado pero queria compartir aqui cual es la solucion al problema y que quede para futuras busquedas en el foro.

Resulta que en la configuracion del main.h de CCS, la directiva del rs232 la utilizaba declarando los pines rx y tx (usaba los que en el datasheet son de la uart). Se ve que al hacer esto utiliza rutinas por software en vez de usar el hard del pic. ya que cuando puse esta declaracion:

#use rs232(uart1,baud=9600,bits=8,ERRORS)

Empezo a funcionar sin problemas con el oscilador interno y a 9600 bauds.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.