Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/12/2009 #1


Todo lo que sale por TX entra por el mismo RX... cómo evitarlo?
Hola a todos!

He estado experimentando con conversores USB-Serial con los conocidos Chips FTDI.

Estoy también, usando varios programas de Serial-Terminal, viendo cuál me gusta más.
Todos funcionan perfectamente, y mi COM virtual es el COM2.

El único problema que tengo, es que todo lo que envío, lo recibo de vuelta automáticamente. Es como si todo lo que está siendo enviado por TX se metiera directamente al RX, siendo que ambas patas las tengo libres ahora. Hasta los LEDs RX y TX se prenden mientras envío algo, o sea que este problema incluso pasa por el hardware.... y me ocurre con todos los programas.

Qué está pasando? Es normal? Se puede evitar?

Muchas gracias!
Saludos!
26/12/2009 #2


Respuesta: Todo lo que sale por TX entra por el mismo RX... cómo evitarlo?
Que quieres deicr con libres?

No hay un corto circuito entre los pines de TX y RX ?

Definitivamente no es normal.

Postea el circuito utilizado.
26/12/2009 #3

Avatar de Meta

Respuesta: Todo lo que sale por TX entra por el mismo RX... cómo evitarlo?
Conecta bien los cables...
26/12/2009 #4


Respuesta: Todo lo que sale por TX entra por el mismo RX... cómo evitarlo?
Con "libres" me refiero a que no tienen nada conectado. Por lo cual, tampoco están cortcircuitados...

Ahora hay más detalles que contar:

1) Esto ocurre con un conversor USB-Serial mediante FTDI, adaptado especialmente para montarle un ZigBee encima.
Tengo otro conversor a serial con FTDI que NO está hecho para conectarle un ZigBee encima, y NO ocurre el problema qe digo.

2) Esto denuevo SI está ocurriendo con un típico cable conversor USB a Serial, de esos que se compran hechos, con un conector DB9 en su otro extremo.
Con este hay un detalle: lo he tenido que instalar dos veces (el driver), porque lo he tenido que usar en 2 USB diferentes, y el driver se tiene que instalar una vez por cada USB que se use. Esto me parece más conocido.

Más que estos datos, no tengo.
Todos los cables o adaptadores FTDI que etoy ocupando, son comprados recientemente, y son circuitos que están limpios y nuevitos. Nada de pelusas que puedan estar haciendo cortocircuito...

Creo que intentaré desinstalando TODO tipo de USB a Serial que tenga, y tener ese tema más ordenado... aunque ya ví que este problema parece pasar por hardware, pero no estoy 100% seguro.

Alguna otra idea?
Gracias

Yah, me APESTAN los problemas aleatorios. Ahora ocurre lo siguiente:

el cable típico USB a Serial ahora muestra un comportamiento normal.

El Adaptador USB - ZigBee es el que todavía sigue tonto, incluso sin tener el módulo ZigBee conectado encima, por lo cual supongo que me pondré en contacto con el fabricante.

Gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.