Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?
21/11/2011 #1

Avatar de Hiske

Ayuda urgente con 89s51
hola que tal, tengo un problema con un micro at89s51 y un arreglo de relevadores.

los que pasa es lo siguiente:

el programa del micro me entrega 5 volts de salida que van al arreglo de relevadores, el problema es que no los activa, medi con el multimetro sin estar conenctado los relevadores me entrega los 5 volts correctamnete pero al conectar los relevadores no los activa y me reduce el voltaje a o.7. (imagino que es por la bobina de los relevadores) me comentaron que puedo utilizar buffers para volver a elevar el voltaje. que me recomiendan hacer para evitar la perdida en las salidas y asi pueda activar los relevadores( los reles son ras0510 a 5 volts).

les dejo las imagenes de los circuitos para que me entiendan mejor y espero me puedan ayudar es un proyecto muy importante y solo tengo 3 dias para resolver este problema.




21/11/2011 #2
Moderador

Avatar de Chico3001

Sin el programa es muy dificil que te podamos ayudar...
21/11/2011 #3

Avatar de Hiske

mm es que el programa es lo de menos, se trata de que en los puertos p0.0 hasta p0.2 cuando entren 5 volts(1 logico), se ejecute un codigo que active una secuencia en los puertos p2.0,p2.2,p2.4 y p2.6 de tal manera que en esos puertos salgan 5 volts. De hecho, el programa ya lo he realizado, ya lo he probado tanto en simulciòn como en directamente ejecutandolo en el microcontrolador, obteniendo los resultado que necesitamos. El problema viene cuando de esos puertos o pines donde enviamos 5 volts al enviarlos al header de coneccion correspondiente a los reelevadores estos no funcionan.

Por ejemplo, al ejecutar el programa, en el puerto p0.0 tengo los 5 volts corespondientes, pero al conectar el sistema del relevador corespondiente a ese pin el voltaje se atenua y de 5 volts pasa a ser cerca de 1.7 volts ya conectado el relevador, cabe mencionar que el sistema de relevadores cuenta con su propia alimentacion pero quiero pensar que al energetizarse la bobina del relevador este absorbe toda la energia de el pin del micro y no le es suficiente para activarlo.

me dijieron que necesitaba un bufer para que esos 5 volts de salida del micro no se atenuen con la bobina del relevador y pueda activarlos.
22/11/2011 #4

Avatar de cosmefulanito04

Fijate en las hojas de datos del 89s51/52, vas a ver que los puertos manejan muy poca corriente, algo así como 60uA y la corriente que le estas pidiendo en la base de esos transistores supera ampliamente la corriente que pueden entregar los puertos.

Solución fácil, cambia los transistores por un uln2003 o similar, solución un poco más molesta usar configuración darlington en c/u de los puertos.

Otra cosa, el puerto 0 del 89s51/52 suele ser sin pull-up, fijate si no necesitas agregarle esas resistencias.
22/11/2011 #5
Moderador

Avatar de Chico3001

Ya entendi... no habia leido completamente el tema...

Intenta poniendole su propia fuente a los relevadores para descartar problemas de ruido, tambien intenta eliminando R6, R8, R10 y R12 haber si asi jala..
22/11/2011 #6

Avatar de Hiske

pero el uln2003 invierte la señal de salida cierto??? es decir si de mi microcontrolador envio por el puerto p2.0 5 un 1 logico el uln a la salida me entregaria 0 logico no es asi?? en ese caso tendria que invertir de nuevo el voltaje para el relevador o como activaria el relevador con 0 logico?
xk igualmente me recomendarn usar un CD40106 que se supone es bufer pero no se como aplicarlo.
22/11/2011 #7

Avatar de cosmefulanito04

El uln trabaja como si fuera un transistor (buffer colector abierto), cuando a la entrada le das tensión el transistor empieza a conducir y te sirve para habilitar el Rele.

Te recomendaría que en vez de usar el Puerto 0 por el tema de los pull-up's uses el puerto 1 si lo tenés disponible.
22/11/2011 #8

Avatar de Hiske

Chico3001 dijo: Ver Mensaje
Ya entendi... no habia leido completamente el tema...

Intenta poniendole su propia fuente a los relevadores para descartar problemas de ruido, tambien intenta eliminando R6, R8, R10 y R12 haber si asi jala..
ya prove eliminando esas resistencias y no funciono, de hecho si alimento directamente los relevadores se activan pero no me cierran el cto como debieran, ademas pues estoy manejando el micro con una fuente de 5 vols regulados y el sistema de relevadores igual con otra fuente independiente.

---------- Actualizado después de 2 minutos ----------

cosmefulanito04 dijo: Ver Mensaje
El uln trabaja como si fuera un transistor (buffer colector abierto), cuando a la entrada le das tensión el transistor empieza a conducir y te sirve para habilitar el Rele.

Te recomendaría que en vez de usar el Puerto 0 por el tema de los pull-up's uses el puerto 1 si lo tenés disponible.
creo que ya entendi, al activar el transistor este conducira la coriente pero no tomando los 5 volts del micro sino la coriente de la fuente cierto? vamos como si fuese otro relevador cerrando un circuito
22/11/2011 #9

Avatar de cosmefulanito04

Hiske dijo: Ver Mensaje
....
xk igualmente me recomendarn usar un CD40106 que se supone es bufer pero no se como aplicarlo.
Nuevamente.... tenés problemas de corriente, ¿cuánta corriente pide tu Rele y cuánta corriente puede darte el CD40106?

creo que ya entendi, al activar el transistor este conducira la coriente pero no tomando los 5 volts del micro sino la coriente de la fuente cierto? vamos como si fuese otro relevador cerrando un circuito
No, tomando los 5V de tu puerto que para algo lo usas!!

Editado:

Definitivamente te conviene usar los puertos 0's del uC que son los que más corriente dan + el uln, de lo contrario con los otros puertos ni con el uln llegás a suministrar la corriente necesaria.

El puerto 0 puede entregarte:

- 800uA con Vout=2,4v (teniendo una Vcc=5v)
- 300uA con Vout=0,75*Vcc (teniendo una Vcc=5v)
- 80uA con Vout=0,9*Vcc (teniendo una Vcc=5v)
En cambio los otros puertos:

- 60uA con Vout=2,4v (teniendo una Vcc=5v)
- 25uA con Vout=0,75*Vcc (teniendo una Vcc=5v)
- 10uA con Vout=0,9*Vcc (teniendo una Vcc=5v)
Esto es lo malo de los 89s5X...
22/11/2011 #10

Avatar de Hiske

ok una pregunta, como es la configuracion darlington???
por lo demas pues hasta mañana podre probar con las sugerencias bro xk ya es noche y no hay donde conseguir el uln a esta hora en mexico XD

---------- Actualizado después de 8 minutos ----------

cosmefulanito04 dijo: Ver Mensaje
Nuevamente.... tenés problemas de corriente, ¿cuánta corriente pide tu Rele y cuánta corriente puede darte el CD40106?



No, tomando los 5V de tu puerto que para algo lo usas!!

Editado:

Definitivamente te conviene usar los puertos 0's del uC que son los que más corriente dan + el uln, de lo contrario con los otros puertos ni con el uln llegás a suministrar la corriente necesaria.

El puerto 0 puede entregarte:



En cambio los otros puertos:



Esto es lo malo de los 89s5X...
ok en ese caso me convendria colocar las salidas hacia los relevadores en los puertos p0, se supone que me entregarian 800uA, un v de salida de 2.4v alimentado a 5 v cierto, pero los relevadores que estoy utilizando son unos RAS-0510 de 5v, creo que entonces si combino el Vout con el uln en p0 se activarian corectamente, muchas gracias por tu sugerencie, ese dato de los puertos no lo habia considerado para nada :P
22/11/2011 #11

Avatar de cosmefulanito04

Tal vez te mal interprete esta pregunta que hiciste:

al activar el transistor este conducira la coriente pero no tomando los 5 volts del micro sino la coriente de la fuente cierto?
Los puertos usalos para controlar el uln y el uln que controle el rele. El uln a la entrada puede pedirte entre 100 a 300uA (pensando en que tu rele consume hasta 100mA max.) y a la salida el uln puede manejar hasta 500mA.

Como última alternativa si no querés usar los uln (creo que es lo mejor ya que tenés varios reles y ahorras espacio con un solo IC), podrías usar un mosfet por ej. 2n7000 que se bancan 200mA y los podés manejar con 5v sin problemas.

Ya te dí todas las opciones, ahora está en vos en usar la que mejor te conviene.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.