Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/10/2011 #1

Avatar de IMASDPIC

voltaje maximo capaz de entregar salida pwm
hola que tal
Buscando por la red pero no encontrado respuesta
lo maximo que e conseguido con una salida pwm 16f876 han sido 2 volt poco
mas
saben si es posible sacar 5 volt para activar la entrada clock de un l293(driver motor pasos)
busqué en el foro y probé ejemplos en asm que hay para modular anchura de pulsos, pero
no consegui lo que queria, a lo mucho que encontre fue variar en el tiempo la anchura de
un pulso, pero si yo lo que quiero es generar una onda cuadrada entre 0/5 volt
y variar la frecuencia de la onda de 0 a X
creen que es mejor hacerlo con pwm o con algun timer o contador que haga flip flop a alguna
salida?
lo bueno del pwm es que deja activada la salida y puedes trabajar con el pic por otro lado no?
de la otra forma necesita estar haciendo un bucle continuamente entre contadores y temporizaciones..corregirme si me equivoco...
saben de algun buen ejemplo?

muchas gracias por la atencion
un saludo

este es el codigo
19/10/2011 #2
Moderador general

Avatar de Fogonazo

IMASDPIC dijo: Ver Mensaje
hola que tal
Buscando por la red pero no encontrado respuesta
lo maximo que e conseguido con una salida pwm 16f876 han sido 2 volt poco
mas ...........
¿ Y como y con que mediste esos 2 V ?

El 16F876, como todos los integrados de lógica entregan en su salida un nivel alto de (Casi) Vcc (5V) y un nivel bajo de (Casi) 0V
19/10/2011 #3

Avatar de arrivaellobo

Si lo mediste con un polímetro, lo que realmente indicaba era el valor "promedio" de la salida PWM. Visualízalo con un osciloscopio y comprobarás que la salida varía de 0 a 5V, como dice Fogonazo.

Un saludo
19/10/2011 #4

Avatar de DJ DRACO

además el pwm no tiene límite de tensiones...es una onda...se puede hacer de cualquier frecuencia y tensión...
19/10/2011 #5

Avatar de IMASDPIC

Hola que tal pues lo medi con el osciloscopio y con un tester fluke

Ademas de hecho conecté un optoacoplador a la salida del pwm con la intencion de que ya que
no me pasaba de lo 2´5v con un optoacoplador al otro lado si conseguiria los 5 v
y que paso?
pues que ni siquera era capaz de activar el optoacoplador porque viendo el osciloscopio cuando a la salida pwm conectaba el optoacoplador esta salida bajaba a menos de 1volt
asi que por eso os preguntaba lo de si es capz de entregar los 5 o es que yo tengo O MAL HECHO EL PROGRAMA o es que mi pic funciona mal
que creeis que puede pasar ???
en principio voy a probar otro pic por si las moscas porque creo que el programa 4pwm esta bien
19/10/2011 #6

Avatar de DJ DRACO

El programa puede ser bueno, el PIC tambien...pero puede que la fente no tenga suficiente corriente para alimentar todo el circuito...

buscalo por el lado de la fuente
19/10/2011 #7

Avatar de IMASDPIC

+ pruebas
hola que tal
bueno no se si alguien le habra hechado un vistazo al codigo que deje mas arriba pwm4

pero he cambiado a otro pic por si de caso

y nada de nada hace lo mismo me entrega de 0´3volt a 2´1 volt
comprobado y recomprobado con el osciloscopio

solo me queda pensar que es culpa del codigo porque no se si sera
pero el programa va aumentando los volt y de repente al llegar a 2`1 volt corta y empieza a disminuir

alguien sabe de algun prog probado que saque una onda cuadrada por pwm con 5volt
asi le hecho una ojeada

gracias

hola DJ DRACO para curarme en salud siempre uso fuentes de alimentacion de ordenador
que tienen suficiente y son estables
19/10/2011 #8

Avatar de fdesergio

Si llevas el PWM cercano al 100% te debe dar los 5Vdc , el valor de tension medida en la salida PWM es igual a %PWM x 5V, asi si tienes el PWM en digamos 80% tendras en la salida en promedio 4Vdc, chauuuuu
19/10/2011 #9

Avatar de IMASDPIC

bueno vamos a ver el problema que yo tengo esta en el codigo ya lo he revisado y me parece que va con lo que dice fdesergio
tengo un programa que encotre por la red que me da primero 0,3 volt luego 2,5 y despus 5volt
tengo que revisarlo pero puede ser que sea porque yo este usando 8 bit de resolucion y no 10??
ya le hecho un vistazo y lo subire el prog por si a alguien le hace falta
un saludo
20/10/2011 #10

Avatar de IMASDPIC

hola que tal ;
Despues de buscar y buscar y buscar al fin encontre mi problema
para caerse de culo
resulta que tenia conectado el osciloscopio a la rc1 y no a la rc2
por eso me daba mal lo que no entiendo es si yo estava programando la rc2 porque en la rc1
me salia la mitad del voltaje que en rc2 e incrementava y decrementava
un saludo
p.s hay que fijarse mas jejej
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.