Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/08/2015 #1


74190 no inicia el conteo.
¡Buenas a todos!
Ante todo decir que el título, no sabía ponerlo más claro Lo que me pasa es un tanto extraño.

Intentaré explicarlo todo de la mejor forma, dejando diagramas y si alguien lo pide, incluso fotos.

Actualmente estoy trabajando con una fuente de +12V DC que, según el polímetro, entrega 14 sin ningún problema. Otros circuitos me han funcionado sin problema, pero el 74190 no hay manera y explico el comportamiento que tiene:

Una vez alimento el CI (a través de un 7805) la salida me proporciona un 0111. Pensé que podría ser debido a que de primeras no tiene un número predeterminado, así que coloqué a 0 todas las entradas (conecté a tierra el 11, 1, 15, 10 y 9), y mientras está LOAD a tierra están todos apagados, pero en el momento en que vuelvo a ponerlo a 1 (lo conecto de nuevo a +5V) vuelve al resultado inicial: un 0111 en la salida. Según tengo entendido, debería permanecer lo que he cargado para empezar a contar desde ahí (aunque ya me corregiréis vosotros que sois unos máquinas )

No solo con eso, cada vez que "simulo" un toque de reloj (simulo porque no dispongo de uno) , parpadea la salida A, es decir, se pone a 1111 mientras el pulso esté en high (1, +5V). Para simular el pulso he puesto una resistencia de 470Ω a tierra y cuando quiero dar el pulso, lo uno a +5V y lo quito, mediante un pulsador.

Ese es el comportamiento que tiene si le pongo la patilla 5 a 5V o a 0V. Vamos, que no hace nada de lo que teóricamente debe de hacer

Este mismo problema lo tuve con varios contadores binarios de otra serie, de los que desistí por aburrimiento, pero con los 74190 quiero echarlos a andar....

Esta mañana compré 3 74190 y el comportamiento es EXACTAMENTE igual para los tres. Vamos, que no creo que sea que el integrado está mal, sino que yo lo he montado mal

Por último, también tengo varios 7805 y el voltaje que da, sin carga y medido con el polímetro, son 5V justos.

El montaje, en el simulador(proteus), funciona bien... os lo dejo por aquí maestros.


De antemano muchísimas gracias
13/08/2015 #2

Avatar de pandacba

Algo esta mal, fijate en el archivo adjunto y utilza el buscador ya que es un tema tratado ya en el foro, supongo que leiste la hoja de datos y has cotejado con otros circuitos
Por ejemplo si pones en tu buscador favorito contadro de 0-9 con 74190 y te fijas en imágenes veras que hay montones de aplicaciones que te pueden servir de orientación
13/08/2015 #3


pandacba dijo: Ver Mensaje
Algo esta mal, fijate en el archivo adjunto y utilza el buscador ya que es un tema tratado ya en el foro, supongo que leiste la hoja de datos y has cotejado con otros circuitos
Por ejemplo si pones en tu buscador favorito contadro de 0-9 con 74190 y te fijas en imágenes veras que hay montones de aplicaciones que te pueden servir de orientación
¡Gracias panda!
Si he buscado hasta en inglés... he visto muuuchos esquemas, incluso en el simulador funciona, perfectamente. El problema viene al llevarlo a la práctica, o estoy simulando mal los pulsos de reloj o algo pasa.... ¿cómo sería una conexión correcta del reloj sin disponer de un 555, es decir, con la fuente de 5V y un interruptor por ejemplo?

De nuevo muchísimas gracias
13/08/2015 #4

Avatar de pandacba

con una llave inversora, una entrada a los 5V la otra a 0V y la salida al clock del CI
13/08/2015 #5


pandacba dijo: Ver Mensaje
con una llave inversora, una entrada a los 5V la otra a 0V y la salida al clock del CI
Así lo he conectado y sigo en las mismas... ¡nada de nada!

Hay una cuestión que me extraña en las últimas mediciones. Cuando mido la tensión que sale del 7805 al aire, me da 5V. Justos. Pero cuando le conecto el integrado, esta tensión baja hasta 4,3V, lo cual me parece que según el datasheet sería insuficiente. Pero entonces... ¿Por qué enciende? ¿Podría ser el foco de mi problema? ¿Cómo podría solucionarlo? He estado mirando por el foro y no encuentro nada...

Un saludo y de nuevo muchas gracias
13/08/2015 #6

Avatar de pandacba

De que foco hablas??? y a ese nivel puede pasar cualquier cosa, es baja la tensión...
Que has puesto que consuma tanto como para que caiga la tensión tanto???
13/08/2015 #7

Avatar de miguelus

Buenas noches Electrogeno

Lo de la caída de tensión en el Regulador puede estar causado por que entre en oscilación, pon un Condensador de 1µF o de 100nF justo entre el Pin de salida y el Pin central (GND) del Regulador.

Asegúrate de que la caída tensión no está causada por un elevado consumo en alguna parte del circuito.

Te dejo un esquema de lo que pretendes que haga el 74LS190.



Las entradas D0...D3 las puedes poner a GND o a VCC, dependiendo de si quieres que inecie en "0000" o en "1111".

R1 junto con C1 aseguran que en el momento de poner el circuito en tensión, el Pin CP esté en "0", de esta forma los Contadores internos se cargarán con el valor seleccionado en D0...D3

R2 junto con C2, ´forman un (presunto) antirrebotes del Pulsador de cuenta.

Ten en cuenta que este Contador cuenta cuando el pulso aplicado en la entrada de Reloj pasa de "0" a "1" o sea, en el flanco de subida.

No olvides poner un Condensador de 100nF entre los Pines 8 y 16 lo más cerca posible del 74190.

Sal U2
Imágenes Adjuntas
Tipo de Archivo: jpg 74190.JPG (82,4 KB (Kilobytes), 42 visitas)
13/08/2015 #8


miguelus dijo: Ver Mensaje
Buenas noches Electrogeno

Lo de la caída de tensión en el Regulador puede estar causado por que entre en oscilación, pon un Condensador de 1µF o de 100nF justo entre el Pin de salida y el Pin central (GND) del Regulador.

Asegúrate de que la caída tensión no está causada por un elevado consumo en alguna parte del circuito.

Te dejo un esquema de lo que pretendes que haga el 74LS190.



Las entradas D0...D3 las puedes poner a GND o a VCC, dependiendo de si quieres que inecie en "0000" o en "1111".

R1 junto con C1 aseguran que en el momento de poner el circuito en tensión, el Pin CP esté en "0", de esta forma los Contadores internos se cargarán con el valor seleccionado en D0...D3

R2 junto con C2, ´forman un (presunto) antirrebotes del Pulsador de cuenta.

Ten en cuenta que este Contador cuenta cuando el pulso aplicado en la entrada de Reloj pasa de "0" a "1" o sea, en el flanco de subida.

No olvides poner un Condensador de 100nF entre los Pines 8 y 16 lo más cerca posible del 74190.

Sal U2
¡Muchas gracias a ambos!

La verdad es que siento que al final no haya sido nada de lo que me comentáis.... Aunque verdaderamente, miguelus, me ha ayudado todo lo que me cuentas para comprender mucho mejor cómo funciona.

El tema es que ya funciona. Me extrañaba, como a vosotros, esa caída de tensión... así que no pude evitar dirigirme hacia el cargador usb más cercano que tenía, cortarlo y usarlo como fuente de 5V (saltándome el 7805) y alimentar el circuito. Ninguna caída de tensión y el circuito funciona perfectamente. Conclusión=La fuente estaba mal.

Voy a modificar el título del tema (si se puede) y a recopilar la solución en el primer post.

La verdad es que me ha gustado el buen rollo y las ganas de ayudar, así que muy posiblemente me quede por el foro aportando lo poco que pueda

PD: Miguelus, ¿ese condensador entre el 8 y el 16 para qué es exactamente?

¡Muchas gracias de nuevo chicos!
13/08/2015 #9

Avatar de pandacba

En todo circuto TTL se debe poner un capacitor de 0.1uF esos pines son la alimentación del CI, se hace para evitar que se cuele ruido por la alimlentación, cada CI deabe llevar uno
13/08/2015 #10


pandacba dijo: Ver Mensaje
En todo circuto TTL se debe poner un capacitor de 0.1uF esos pines son la alimentación del CI, se hace para evitar que se cuele ruido por la alimlentación, cada CI deabe llevar uno
Nunca te acostarás sin saber algo más


¡Muchas gracias!
13/08/2015 #11

Avatar de miguelus

Electrogeno dijo: Ver Mensaje
Nunca te acostarás sin saber algo más


¡Muchas gracias!
Buenas noches.

pandacba ya te ha contestado, y añado, el Condensador entre los Pines de alimentación también sirve para evitar que el ruido de conmutación se cuele en la línea alimentación y perjudique a otros Integrados.

Sal U2
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.