Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/06/2011 #21


Hola CGOROSCO

Pues es muy sencillo.
Qué Simulador Utilizas ?.

Conecta 2 contadores 74LS192 en cascada. Las entradas de los 74LS47 se conectan a las salidas Q’s de los contadores y las salidas de estos a unas resistencias de digamos 250 Ohms y las otras terminales de las resistencias a los Display’s de 7 segmentos.

Para hacer el oscilador con el 555:

http://www.forosdeelectronica.com/f1...er-555-a-4356/

El PIN 3 del 555 se conecta a la entrada Clock del 74LS192 que cuenta las unidades.

Con un Botón normalmente abierto puedes restablecer el contador conectándolo a las entradas llamadas MR, creo que es el PIN 14. la otra terminal del Botón se conecta Al Vcc(5V).

saludos
a sus ordenes
07/06/2011 #22


OYE AMIGO GRACIAS, GRACIAS POR TU RESPUESTA SABES SI ESTOY UTILIZANDO livewire y pcWizard y gracias a tus recomendaciones lo he hecho funcionar !!! gracias.
24/10/2011 #23


EinSoldiatGott dijo: Ver Mensaje
Mire este es el diagrama.



Saludos
que onda. como veras soy nuevo y tu diagrama me fue muy utili ,me puedes decir como le hiciste para saber,como realizar las conexiones para que llegara hasta el 60 y de ahi voviera acomenzar porfavor me ayudarias aun mas se mi respondes gracias
23/04/2013 #24


EinSoldiatGott dijo: Ver Mensaje
Mire este es el diagrama.

http://www.forosdeelectronica.com/up...ero%20copy.jpg

Saludos
como puedo hacer que se pare en el 60 y no se resetee
23/04/2013 #25


Hola cdyck

Es relativamente sencillo lograr eso.
Hay que detectar cuando el contador llegue a 60 y en ese instante ya no dejar pasar pulsos al clock de los contadores.

Si el contador es binario natural cuando llegue a: 111100 es cuando se interrumpen los pulsos.
Si el contador es decimal cuando llegue a 0110 0000 es cuando se interrumpen los pulsos.

saludos
a sus ordenes
24/04/2013 #26

Avatar de miguelus

Buenas tades cdyck

Aquí te dejo un diseño que realiza lo que pretendes, bueno en realidad son dos.
Uno esta hecho con los 74LS90 y otro con los 74LS192
Ambos cuentan hasta "60" y se detienen, por medio de un pulsador de Reset se ponen a "0" y empiezan a contar de nuevo.
El diseño está ralizado con Proteus, está también el PDF.

Sal U2
Archivos Adjuntos
Tipo de Archivo: rar Contador 0...60.rar (38,7 KB (Kilobytes), 76 visitas)
22/06/2017 #27


Contador MOD 60

Buenas, amigos. ¿Qué tal?
Estoy haciendo un circuito MOD 60 y lo estoy montando en protoboard.
Pero resulta que tengo los integrado 7447 que son para displays de 7 segmentos y ánodo común.
Los displays que tengo son cátodo común, entonces la única opción que me quedó, fue agregarles unas compuertas NOT a las salidas f,g,a,b,c,d,e del 7447 para invertir los pulsos y de esa manera lograr encender los displays.

En proteus funciona super bien, ya en físico no sé qué suceda, amigos.
Gracias por su ayuda.

Estos son los circuitos.
Simulado en Proteus y montado en protoboard.

Se logra ver en los displays como que figura el numero del conteo, pero se enciende el resto con menor intensidad.
Imágenes Adjuntas
Tipo de Archivo: jpg 1111111111111111111-1.jpg (82,3 KB (Kilobytes), 15 visitas)
Tipo de Archivo: jpg 20170621_232512.jpg (96,8 KB (Kilobytes), 9 visitas)
Tipo de Archivo: jpg 20170621_232806.jpg (170,5 KB (Kilobytes), 7 visitas)
22/06/2017 #28
Moderador general

Avatar de DOSMETROS

Fijate en el datashiit de las compuertas NOT que estás utilizando , cual es su tensión de salida para nivel lógico [0] . . . no es 0 V
22/06/2017 #29


Las salidas en bajo estan entre 0 a 0.8v aproximadamente.

En la lucha por hacerlos funcionar he desconectado los contadores y decodificadores.
Y la gran sorpresa que me he llevado es que los 7 segmentos se quedan encendidos!
Lo unico que pude razonar es que al estar siempre un [0] en las entradas de las negaciones, siempre saldrá un [1] y por eso siempre estan encendidos...por lo tanto no se como solucionar el no encontrar 7448, ni displays ánodo común :/
22/06/2017 #30

Avatar de pandacba

Tal vez puedas obtener el 74247....
Necesariamente tienen que ser TTL?
22/06/2017 #31
Moderador general

Avatar de DOSMETROS

Probá poner uno o dos díodos en serie con la salida de alguna de las NOT
22/06/2017 #32

Avatar de Gudino Roberto duberlin

Hola, supongo que habrás utilizado una resistencia por cada segmento. Desconectando el display, chequea que tensión obtienes en la salida del inversor, según un 0 o 1 en la entrada.
22/06/2017 #33


Pandacba: En caso de usar el 74247, quedaria en la misma situacion ya que es para ánodo común.

Dosmetros: El diodo basicamente rectificaria las salidas del NOT? deberia poner un diodo a cada salida not?...¿porque al not, y no al deco?

Gudino: No usé resistencia para cada segmento, solo hay una en común, en GND de el 7 segmentos..Esto podria afectar?
En la entrada de la NOT, tengo 0.1v y a las salida tengo 4v
22/06/2017 #34

Avatar de pandacba

Quise decir 74248.....
En CMOS podes utilizar 4026 o 4033
También 1 4518 y dos 4511
22/06/2017 #35
Moderador general

Avatar de DOSMETROS

Eduarj77 dijo: Ver Mensaje
Dosmetros: El diodo basicamente rectificaria las salidas del NOT? deberia poner un diodo a cada salida not?...¿porque al not, y no al deco?
La compuerta NOT , no tiene 0 V a la salida , la idea es que pruebes con uno o dos díodos en una de las salidas a ver si eso soluciona el problema , cada díodo produce una caida de tensión de 0,6 V . . . después verás que hacer.

Iría una resistencia de 220 Ohms en cada salida , no una común en el cátodo.
22/06/2017 #36

Avatar de Gudino Roberto duberlin

DOSMETROS dijo: Ver Mensaje
La compuerta NOT , no tiene 0 V a la salida , la idea es que pruebes con uno o dos díodos en una de las salidas a ver si eso soluciona el problema , cada díodo produce una caida de tensión de 0,6 V . . . después verás que hacer.

Iría una resistencia de 220 Ohms en cada salida , no una común en el cátodo.
Las compuertas lógicas tienen que ofrecer 0v. o muy cercano, cuando el nivel es bajo, sino no sería reconocido dicho valor por otro elemento lógico. El problema está en que usó una resistencia común cómo mencionas. Eso explica todo.
22/06/2017 #37


Después de un viaje de 5hrs aproximadamente fui en busqueda del display ánodo común, en dicha tienda si había..
Ya lo monte y en efecto funciona correctamente.
Cuando tenga tiempo probaré lo que me recomendaron, cuando lo haga y logre funcione publicaré diagramas, montaje en protoboard y todo lo necesario para que alguien mas se ahorre esas 5hrs de viaje!.. estoy muy seguro que con sus consejos funcionará.
23/06/2017 #38


Ya se que lo solucionaste con el cambio de Display, Peo tu problema se hubiera resuelto si hubieras leido la hoja de datos de cualquier familia TTL, Solo proporcionan 400uA (source) y con eso oviamente no prendes el LED. Un driver diferente por ejemplo el TBD62783APG te soluciona el problema ... o 7 transistores PNP
Archivos Adjuntos
Tipo de Archivo: pdf TBD62783AFG 8-Channel Source Drivers 500mA.pdf (550,9 KB (Kilobytes), 0 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.