Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

01/03/2013 #61


Buenas tardes,
estoy intentando pasar a la práctica un proyecto diseñado en ISIS que consiste en un contador simple de 2 dígitos.
Para comenzar a probar, conecté en la protoboard un solo dígito (display de 7 segmentos cátodo común), dos integrados (4029 y 4511) y las resistencias de 330 ohms (entre el 4511 y el display) y lo activo con un pulsador para avanzar los números.

Los problemas que surgieron fueron varios:
1) El contador pasa de a 1 o de a varios números.
2) Necesito transistores para aumentar la corriente que entran a los displays pero no se de que tipo usar y si conectarlos tipo emisor común o colector común.

Supongo que el punto 1) debe ser un problema de "ruido" porque lo pruebo con una señal de salida de un 555 y funciona bien.

Gracias desde ya!

Me olvidaba, todo el sistema está alimentado por 5V.
01/03/2013 #62

Avatar de Gudino Roberto duberlin

Amigo, sube el esquema que utilizas.
El 1er. problema NO es ruido, sino problema tipico del rebote mecanico de un interruptor.
En el 2do. punto no es necesario utilizar transistores, pues el 4511 esta preparado para accionar directamente un segmento.
El problema puede suceder que utilizas una unica resistencia en comun.
01/03/2013 #63


Gudino Roberto,

Ahí adjunto el archivo de lo que monté en el protoboard (el archivo fue hecho en Proteus ISIS).
Te agradezco si me explicas un poco más lo del rebote mecánico y cómo solucionarlo.

Por otro lado te comento que supuse que necesito transistores, pero realmente no se lo que sucede. El problema es que todos los números aparecen bien, salvo el 8 que comienza bien pero luego se apaga la linea del medio, pero seguido el 9 funciona con esa linea.
La única forma que logré que ese la linea del medio apareciera en el momento del 8 es desconectando salidas del 4511 (ejemplo Qa:pin6 y Qb:pin11).

Gracias por la rápida respuesta.
Archivos Adjuntos
Tipo de Archivo: rar Contador simple1.rar (14,2 KB (Kilobytes), 18 visitas)
01/03/2013 #64

Avatar de Gudino Roberto duberlin

Amigo chequea que las salidas del contador, se correspondan a las entradas BCD del 4511. Respecto al rebote, puedes buscar en la red, multiples formas de evitarlo.
01/03/2013 #65


Ya revise todas. Además los números avanzan bien. Parece tal cual que no le de la potencia.
Respecto a lo otro, gracias! Casi que lo tengo solucionado.
01/03/2013 #66

Avatar de miguelus

Buenas noches santi21

El problema que tienes con el 8, lo más probables es que tengas un error en alguna conexión, revísalo.

He hecho un pequeña reforma a tu diseño, los rebotes estarán minimizados, aunque esto Proteus no lo contempla.

Sal U2
Archivos Adjuntos
Tipo de Archivo: rar Contador simple1.rar (15,2 KB (Kilobytes), 10 visitas)
25/05/2013 #67

Avatar de covra

Problema contador 4511 y 4518
Buenos dias

LLevo varios dias montando un circuito que mida tiempos de respuestas a traves de pulsadores.
Tiene un modulo de control por pic, un simon says, 555, cronometros.. cosas asi.
El caso es que tengo todos los bloques funcionando correctamente en Proteus, pero cuando he montado el crono (basicamente un contador hecho con 4518 y 4511 ) me da los siguientes problemas:

- Los 4511 no "generan" bien los numeros en los displays (catodo comun), es decir , en vez de numeros me salen caracteres "raros"

- El circuito cuenta de manera erratica, conecte o desconecte el 555, es decir, lo deje al aire o lo conecte a su salida

- Ni reset ni el hold me funcionan correctamente, es decir, o no me resetea, o directamente, no hace nada


He comprobado que no haya cortos ni que fallen pistas.

Utilizo una fuente regulable que tenia por el taller (5V aprox).

Los dos unicos cables que quedan al aire son los que interconexionan este bloque con el siguiente. He probado a ponerlos a masa y al aire (segun esquema) (En la foto el cable correspondiente a MR_OUT no está, pero lo solde segun esquema del Proteus)

Alguien puede darme alguna pista para saber por donde seguir? Gracias!!
Imágenes Adjuntas
Tipo de Archivo: jpg crono_v3_p2_foro.jpg (63,4 KB (Kilobytes), 30 visitas)
Tipo de Archivo: jpg cronoPCB2_v3_part2.jpg (87,4 KB (Kilobytes), 12 visitas)
Tipo de Archivo: jpg crono2_v3_p2_foro.jpg (85,6 KB (Kilobytes), 11 visitas)
Tipo de Archivo: jpg crono3_v3_p2_foro.jpg (61,9 KB (Kilobytes), 12 visitas)
25/05/2013 #68


Hola covra

Lo Que Puede estar pasando con las figuras en los Display’s es que exista algún(os) alambres conectados erróneamente entre el PCB y los Display’s.
Aquí te faltan, no porque sea la causa de los caracteres extraños, unas resistencias limitadoras para cada segmento.

El conteo errático puede ser causa del ruido que producen los botone al conmutar. Aquí podrías utilizar un circuito Antirebote para eliminar ese efecto.

Espero haberte ayudado.

saludos
a sus ordenes
26/05/2013 #69

Avatar de covra

bueno, he conseguido solucionar algo.... jeje, como siempre error humano. ..
los leds d los displays estaban en orden erroneo, por eso los numeros "raros"...

en cuanto al resto de errores, creo que es por el ruido de la fuente que es un poco viejuna... le metere un 7805 y un par de condensadores por aqui y por alla a ver que pasa...
26/05/2013 #70

Avatar de SSTC

tendrias que usar unas resistencias en el display ante de que se te quemen los led internos y por ultimo conectacte bien el 555
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.