Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/07/2009 #1


Duda con dado digital: los LEDs se apagan con el paso del tiempo
Hola compañeros. Llevo un tiempo entrando en el foro, normalmente buscando cosas en Google que me llevan a aquí, y la verdad que está muy bien, se ve que hay mucha gente interesada en la electrónica y en ayudar en lo posible. Ayer decidí pasar a formar parte de esta comunidad pero mi primer mensaje no va a ser un aporte, sino una duda.

Hace poco diseñé un circuito bastante sencillo, un dado digital de 7 LEDs basado en un contador diseñado con biestables D y puertas lógicas. La señal de reloj la genera un 555 con un ciclo de trabajo del 51%. El diseño lo hice en Multisim y funcionaba perfectamente así que pasé a montarlo en protoboard antes de soldarlo. Aquí ya empecé a tener algunos problemas que no terminaba de entender. El circuito simulado funcionaba con una alimentación de 6.4V (4 pilas AA) pero en la protoboard, con esa alimentación, los LEDs apenas brillaban, excepto el correspondiente al punto central del dado (que es el único LED que está solo, los demás están conectados en parejas). Supuse que no les llegaba suficiente corriente y que esto sería debido a que las pilas no entregaban suficiente corriente al circuito por lo que lo alimenté a 9V. Ahora los LEDs lucían como debían pero el integrado correspondiente a los inversores (un 74LS04) se calentaba demasiado. Decidí por tanto usar un regulador de voltaje 7805 con la pila de 9V pero volvía a tener el problema de que los LEDs no brillaban lo suficiente. Así que lo dejé sin regulador, total funcionaba perfectamente aunque el integrado ese se calentase. Pero cual fue mi sorpresa que dejando el circuito un rato encendido, los LEDs empezaban a disminuir su intensidad, hasta llegar al punto de no brillar nada.

He revisado el circuito mil y una veces y no se me ocurre qué puede pasar. Espero que me podáis echar una mano. Os dejo el esquemático del circuito por si sirve de ayuda. ¡Gracias!
02/07/2009 #2


Hola Alvipe, te recomiendo que antes de montar un circuito revises la hoja de características de cada uno de los componentes que lo forman. De esta forma, verás que para el 74LS173N, según el fabricante, no debe ser alimentado a más de 5.25V. De igual forma sucede con los demás CI, excepto para el 555, que su tensión máxima es de 16V. También es importante conocer la tensión de codo de cada LED (cosa que también depende del color) ya que puede ser que al estar dos en serie, sea tal la caída de tensión que no se pueda generar la corriente que hace que luzcan.

También es importante que no dejes trabajando a los CI con esas tensiones tan altas, que de ahí esas temperaturas que cogen, y que si las sumamos con las con los calores que tenemos en España, pos poco te van a durar 8-)

Procura realizar los esquemas algo más claros para que sean fácilmente entendibles por las personas que no lo han hecho.

Un saludo.
02/07/2009 #3
Excluido


Re: Duda con dado digital: los LEDs se apagan con el paso del tiempo
Alvipe dijo:
. . . El circuito simulado funcionaba con una alimentación de 6.4V (4 pilas AA) pero en la protoboard, con esa alimentación, los LEDs apenas brillaban . . .
. . . Supuse que no les llegaba suficiente corriente y que esto sería debido a que las pilas no entregaban suficiente corriente al circuito por lo que lo alimenté a 9V . . .
Los integrados TTL funcionan a 5V; como te pasaste, dañaste los C.I.
02/07/2009 #4
Moderador

Avatar de elaficionado

Hola.
Cambia las resistencias de 33 ohm por 180 ohm, ya que con la resistencia de 33 ohm estás demandando demasiada corriente del intergrado, por lo que éste baja su voltaje de salida. Como dices que solo el punto medio enciende bien, en el gráfico que publicas se ve que ese LED tiene una resistencia de 180ohm.
Como ya te han dicho los TTL usan sólo 5V.

Chao.
elaficionado.
03/07/2009 #5


Gracias por vuestros consejos, probaré lo que me dices de las resistencias elaficionado. sephirot, la verdad que el esquemático si que es bastante lioso, sí Me siento un poco ridículo, estudio ITI en Electrónica y tener estos errores de novato...
03/07/2009 #6


Hola Alvipe, no tienes porque sentirte ridículo, sólo te falta un poco de práctica y tener más cuidado en los montajes. Yo he terminado la ITI en Electrónica y veo a gente que ni siquiera tiene el afán que tienes tu de realizar un circuito y montarlo, aunque esté mal.

Así que no te desanimes.

No es que tenga nada en contra del Multisim, ¿pero has probado otros programas de simulación como el Proteus?

Un saludo.
03/07/2009 #7
Excluido


Alvipe, en el link http://www.kpsec.freeuk.com/projects/dice.htm encontraras un circuito alternativo; alli esta explicado su construccion y se utilizan integrados CMOS. Aca les dejo una instantanea del circuito.
Imágenes Adjuntas
Tipo de Archivo: gif dado_electronico_356.gif (57,7 KB (Kilobytes), 218 visitas)
14/07/2009 #8


Saludos compañeros. Gracias a todos por las respuestas, no he respondido antes porque he andado liado estos días que he empezado a estudiar las asignaturas que me han quedado para septiembre (la dura vida del estudiante de Ingeniería ), además de que he andado trasteando con un Arduino Duemilanove que adquirí recientemente.

@elaficionado: probé lo que dijiste de las resistencias con unos integrados que tenía de recambio pero no funcionó, aunque sospecho que pueda ser porque el 74173 de recambio estaba también fastidiado. Creo que probaré el circuito que ha puesto man05drake que aparte de ser más sencillo a nivel de integrados, nunca he usado un circuito contador, siempre los he diseñado a partir de biestables.

@sephirot: usé Multisim para este circuito porque me resulta bastante fácil e intuitivo de manejar, además de que es muy versátil ya que permite diseño analógico y digital y las simulaciones y medidas son muy visuales. Más que nada que el otro programa de diseño que manejo es el OrCAD PSpice, que por supuesto es bastante más profesional, permite hacer simulaciones y medidas detalladísimas y para diseño del layout es genial, pero nunca lo he usado para diseño de circuitos digitales (no se ni siquiera si se puede, supongo que sí). Le echaré un vistazo al Proteus, lo conocía de oídas, pero nunca lo he utilizado.

¡Gracias a todos!
14/07/2009 #9

Avatar de elosciloscopio

no será que se funden?
14/07/2009 #10


elosciloscopio dijo:
no será que se funden?
Jeje, qué va, qué va. No creas que no lo pensé, aunque me parecía muy raro, pero los he probado por separado y funcionan a la perfección.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.