Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

14/06/2009 #1


Errores con ca3161 y display 7 seg.
Buenas a todos,

me estoy volviendo un poco tarumba de tanto leer y tanto probar y no se ya que hacer, estoy tratando de mostrar un valor en un display de 7 segmentos de anodo comun. Conexion Pic(16f84)--> Ca3161 --> Display 7 segmentos
La cuestion es que me muestra valores muy raros, solo muestra bien el 0, he probado todos los esquemas que he visto, lo he configurado de mil maneras, incluso probando sin pic, conectando a vcc las patas del bcd y tampoco funcionan, dando valores en bcd de 0-9.

He probado tambien con el 7447 y no hay forma.

Tambien he simulado con el workbench y no me muestra valores correctos.

A ver si me podeis ayudar.

Gracias.
14/06/2009 #2

Avatar de DJ DRACO

te digo una cosita?

el CA3161 funciona conectandolo con el CA3162.

por otra parte existen otros integrados que hacen todo el laburito, de hasta 3 digitos y 1/2 hasta 4digitos y 1/2.

ICL7106
ICL7135
ICM7217
MC14433
MC14553
14/06/2009 #3

Avatar de DJ DRACO

o de ultima utiliza una combinacion de CD4929 y CD4511 y listo.
14/06/2009 #4


Perdona Dj Draco pero no he entendido bien lo que tengo que hacer, aparte aunque al ca3161 se le envie la señal con el 3162, metiendole el dato yo mismo tambien deberia ir bien.

Entonces que integrado me recomiendas para conectar al pic y este a su vez al display 7seg. anodo comun. EL cd4511 ?, tiene pinta de que voy a tener el mismo problema que con el 3161 ?

Tambien probe con el 74ls47 y tampoco funciono.

Ayudame.....

Gracias!.
14/06/2009 #5

Avatar de Dr. Zoidberg

jgarcias2 dijo:
Perdona Dj Draco pero no he entendido bien lo que tengo que hacer, aparte aunque al ca3161 se le envie la señal con el 3162, metiendole el dato yo mismo tambien deberia ir bien.

Entonces que integrado me recomiendas para conectar al pic y este a su vez al display 7seg. anodo comun. EL cd4511 ?, tiene pinta de que voy a tener el mismo problema que con el 3161 ?

Tambien probe con el 74ls47 y tampoco funciono.
Creo que deberías pensar un poco....

Si has probado la mayoría de los drivers de 7-segmentos, y ninguno te funciona...entonces el problema lo tenés en la configuración del PIC o en el programa o en la conexión al driver 7-seg, o en todo a la vez.
Como acá no hay adivinos ni magos (que yo sepa ), lo mejor sería que en vez de revolear comentarios, postearas todos los esquemáticos que has usado para las conexiones PIC-driver y también el programa que has codificado, por que de otra forma, es imposible ayudarte...está claro?

Saludos!
15/06/2009 #6


Este es el esquema que simulo en workbench y no me funciona,

Gracias a todos por intentar ayudarme, por que la verdad estoy muy frustrado con estos decodificadores.
15/06/2009 #7

Avatar de Dr. Zoidberg

jgarcias2 dijo:
Este es el esquema que simulo en workbench y no me funciona,

Gracias a todos por intentar ayudarme, por que la verdad estoy muy frustrado con estos decodificadores.
Cual esquema?

Y por favor, sube un archivo de imagen (JPEG o GIF) o un PDF, por que no todos acá usan el workbench y ni siquiera podrán abrir lo que subas.

Saludos!
15/06/2009 #8


Ahi va el circuito


Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg dibujo_147.jpg (31,0 KB (Kilobytes), 73 visitas)
15/06/2009 #9


ese es el unico valor junto al cero que muestra bien
15/06/2009 #10


Me he podido cargar el integrado al meterle 5v directamente en las patillas BCD ?

Como puedo saber si va bien, por que manda valores no legibles al display ... entonces no se si estara mal, por que el display si que esta bien conectado ...

Ayuda porfa....
Gracias a todos.
15/06/2009 #11

Avatar de Dr. Zoidberg

jgarcias2 dijo:
Me he podido cargar el integrado al meterle 5v directamente en las patillas BCD ?

Como puedo saber si va bien, por que manda valores no legibles al display ... entonces no se si estara mal, por que el display si que esta bien conectado ...

Ayuda porfa....
Gracias a todos.
Mirá flaco:
1- Esta pidiendo ayuda por todas partes sobre el CA3161, pero el dibujo que mostrás usa un 7447.
2- Decís que el display está bien conectado, pero ni siquiera indicás cual es el display que estas usando para buscar la hoja de datos...que dicho sea de paso, vos deberías haber buscado y subido al foro para que tengamos alguna referencia sólida.
3- Este tipo de problemas se resuelve de una sola forma: con las hojas de datos en una mano y un lápiz en la otra, verificando que el esquematico sea correcto, pero como no sabemos cual driver estas usando ni cual display...
4- Te lo dije antes: ACA NO HAY MAGOS NI ADIVINOS, y sin tu ayuda no podemos saber que demonios es lo que te sucede a 1000 km o más de distancia.

Así que hasta luego, y que estés bien. Yo acá termino el diálogo.

Saludos!
15/06/2009 #12
Moderador

Avatar de Chico3001

Solo te pudiste cargar el CI si conectaste la alimentacion invertida o le sacaste mas corriente de la que soporta, desafortunadamente la unica manera de probarlo es conectandolo en el circuito que posteas, que dicho sea de paso no sabemos si tienes bien hecho o no

Asi que la solucion simple... si piensas que esta dañado solo apartalo para que lo puedas probar despues, ve a la tienda y compra otros 5 nuevos... asi sabes que el error no es el chip y es tu circuto.. y ademas tienes material para poder hechar a perder comodamente... eso es un procedimiento normal al diseñar en electronica... todos sabemos que en algun momento quemaremos un chip y necesitamos tener repuestos a la mano
16/06/2009 #13

Avatar de DJ DRACO

Vamos de cero y sin tantas palabras:

1) tener un ésquema de circuito que sepas que funcione. Esto indica que debes tener los Datasheet (hojas de datos)
2) simularlo en algun programa. Los programas son ideales NO reales! ! !
3) conseguir la fuente de alimentación correcta y en lo posible regulada.
4) no mezclar distintos tipos de integrados (debido a que no todos trabajan sobre la misma lógica TTL, CMOS, PID; etc, etc)
5) si se pregunta algo en el foro, se respalda con circuitos, imágenes, etc, etc.

asi todos te podemos ayudar.

Yo no recomiendo integrados, porque a cada uno le puede gustar uno distinto. solo te digo que hagas los circuitos lo más simple posible, y basado en algo real.

en tu dibujo, al display le faltan las resistencias limitadoras de corriente.

t dejo un esquemita de un contador UP/DOWN, BINARIO/DECIMAL, AUTO/MANUAL.

saludos.
Imágenes Adjuntas
Tipo de Archivo: gif display_7_segmentos_119.gif (2,3 KB (Kilobytes), 42 visitas)
Tipo de Archivo: gif contador_completo_134.gif (18,1 KB (Kilobytes), 46 visitas)
21/06/2009 #14

Avatar de DJ DRACO

Remarco la importancia de las resistencias limitadoras de corriente.

hay un cálculo muy sencillo para eso.

los display de 7 segmentos se componen de led's en su interior.

la caida de voltaje de un diodo led es de maximo 2 volts y con una corriente máxima de 20mAh.

los integrados CMOS te tiran a su salida el mismo voltaje de alimentación, por ende, si lo alimentas con 9 volts el calculo es el siguiente:

9Volts = I x R + caida entonces 9[V] = 0,02[A] x R + 2[V] entonces R = (9[V] - 2[V]) / 0,02[A] = 350 Ohms, mejor si le metes de 560.

la potencia que debe disipar ese resistor es simplemente: IxIxR = 0,02 x 0,02 x 560 = 0,225[W] con resistores de 1/4[W] vas a andar bien.
22/06/2009 #15


ok, gracias a todos.. ya esta funcionando, cambie el ci y parece que ahora va bien.

Muchas gracias a todos
16/10/2011 #16

Avatar de oFRGOo

hola bueno yo quise hacer lo mismo con el CA3162 y el CA3161E, lo quise simular en workbench pero solo encontre los ADC genericos bueno una vez que lo conecte sde los muestro , pero mi duda es se puede acoplar a una fuente de 12V regulable? mi inconveniente es que no quiero regular el voltimtro o es necesario regularlo para q mida? tengo un esquema q no es mio y que de eso me guio no se como esta quiero sus opiniones ps y si hay algun truquito o un tips me avisen pz gracias..

16/10/2011 #17

Avatar de pandacba

Simularlo? cual es el sentido?, un simulador es solo eso simula y no siempre uno puede fiarse de uns simulación ya que es tan solo una aproximación a la realidad.....

Cuando etos CI eran muy populares habia un problema que no aparecera en ningún simulador y era que si uno ajustaba el Cero, al apagarlo y encenderlo de nuevo necesitaba reajustar el Cero nuevamente, no obstante se empleaba mucho.

Se teejieron mil conjeturas como por ejeomplo que estaba preparado para rechazar los 60hz de la red americana y no la de 50hz

Yo tube uno en mis manos y el problema tal cual, uno de los capcitore tiene que ser de muy buena calidad, con los capacitores que se conseguian normalmente era imposible, pero cuando ingresaron los primeros MKT de la mano de Iskra, el cero se mantuvo perfecto.

A veces la simulación es una mania, y has coss como estas que no tiene sentido simularlas


Una cosa es simular un circuito nuevo es decir una combinacion de componentes para obtener algo y no un producto de aplicación especìfico como el presente, que cuando se lanazan al mercado estan recontraarchiprobados

En tales casos la simulacione es una verdadera perdida de tiempo ya que las cosas a tener en cuenta como la mencionada la simulaciòn no lo reportara.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.