Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/05/2008 #1


Mantener 1 lógico por 2 o 3 segundos
amplificadorfiqué la señal del tono de un celular para utilizarla en un proyecto, lo hice con un LM424 un opamp, este no es el problema sino la señal de salida... me genera una onda cuadrada una serie de pulsos...

la salida va conectada a un 2n2222 y este a un relé de 5volts y en paralelo un diodo 1n4001 el problema es que como la señal es cuadrada NO me produce un 1 lógico estable y como consecuencia mi relé no se queda estable sino que se desconecta y conecta(por así decirlo)

pensé en flip-flops pero, no sé como hacer para que este 1 lógico se quede estable por 2 o 3 segundos y despues regrese a 0, sin tener que mandar otro pulso, lo intenté con un 555 en su forma monoestable, pero el problema fue que el 555 necesita solamente un pulso y la señal de salida es una serie de pulsos y al parecer no me los detecta el 555

todo esto es para poder simular el push buton de un CPU... un profesor me comentó utilizar un optoacoplador pero imagino que sería el mismo problemita ya que no es una señal constante sino una onda cuadrada...

si alguien me pudiera ayudar le agradecería mucho

gracias
28/05/2008 #2


Puede usar 74123

es un monoestable no redisparable

cuando hay un flanco de subida, genera un pulso cuya duracion se controla por R y C

mientras está el pulso en la salida, no coge mas flancos a la entrada, por esto es no redisparable
28/05/2008 #3


gracias bluetoothman creo que es lo que necesito, aunque tengo una duda... cuales son las unidades para realizar la operacion? ohms y uf? para obtener segundos?

gracias
29/05/2008 #4


Hola,

eso es fácil averiguarlo, piensa que si lo haces en función de un condensador de X uF, esto será equivalente a X*10^(-6) F, suponiendo que quieras obtener un tiempo de 3.7s

t=0.37*R*C
t=3.7*(R)(X)*10^(-1)*10^(-6)=3.7*(R)(X)*10^(-7)

por lo tanto usando una resistencia del orden de 10^7 ohms (orden 10 Mohms):

t=3.7(X)*10^7*10^(-7)

supongamos que utilizas un condensador de 0.1uF=1*10^(-1)*10^(-6) F

t=3.7*10^7*0.1*10^(-6)

t=3.7 seg.

Saludos.
30/05/2008 #5


gracias digitalis, por el momento no he podido ir a comprar el integrado :( espero hoy viernes por la tarde comprarle y armar el circuito, ya les estaré diciendo si funciona...

tengo otra duda, que sucede si el pulso de salida es de menos duracion que el tren de pulsos de entrada?
30/05/2008 #6


ahí el truco es jugar con la frecuencia de salida del pulso, debes medirla con el osciloscopio o frecuencímetro y realizar las operaciones de antes para obtener el tiempo en función de esta medida.

saludos.
02/06/2008 #7


puse el pin 8 y 16 a vcc un condensador de ceramica de .1uf y entre 14 y 15 una resistencia de 13 ohms pin 1 a gnd pin 3 a vcc pin 2 al cambio...

segun al resultado de digitalis la salida de Q debía durar unicamente un poco mas de 3.7 y regresar a su anterior estado...

pero no sucede esto

en que podría estar mal?
02/06/2008 #8


ojo.. dije del orden de MOhms.. aproximadamente unos 10MOhms..

y recuerda que es un cálculo aproximado.

saludos
02/06/2008 #9


ups... si disculpa me faltó la M... la resistencia es de 13Mohms eran la 1.30am y ya no estaba en mis 5 sentidos... ops:

aun asi no me funciona :(
02/06/2008 #10

Avatar de pepechip

te dejo otro esquema por si quieres implementarlo.
La resistencia de 10K la conectas directamente a la salida de audio del movil.
yo lo realice sustituyendo el transistor por un optoacoplador, ya que la salida de audio del movil tiene suficiente nivel como para encender un diodo led.
Imágenes Adjuntas
Tipo de Archivo: jpg temporzadormovil_155.jpg (13,2 KB (Kilobytes), 376 visitas)
02/06/2008 #11


gracias pepechip pero el sonido que produce este celular es muy bajo, 2mV, pero ese no es mi problema ya hice la parte de amplificación, ahorita mi problemita es mantener el pulso por lo menos 2 segundos ya que el tren de pulsos no me lo permite el rele de activa y desactiva, el 74123 es buena opcion pero por alguna razon no me funciona :(

saludos
02/06/2008 #12

Avatar de pepechip

¿has provado poner un led directamente en la salida de audio?
02/06/2008 #13


pepechip dijo:
¿has provado poner un led directamente en la salida de audio?
la salida es de 2mV del audio, ya lo hice, pero como dije antes mi problema ya no es ese... tan solo me falta estabilizar el pulso :(
07/06/2008 #14


Perdona LokoMX, he estado ausente unos días.

Repitamos los cálculos pq quizás he fallado.. vamos a partir de que necesitamos un 2 segundos de tiempo

t=0.37*R*C

Vamos a hacerlo en función de un valor de capacidad dado, pq estos son más difíciles de conseguir que los resistores.

Supongamos que tenemos un condensador de 10uF

t=2
2=0.37*R*10*10^(-6)

R=2/0.37*10*10^(-6)

R=(aprox)=540kOhms

prueba de esta manera.

Saludos.
08/09/2012 #15


Buenas,

A ver si alguien puede responderme porque ya no sé qué hacer...

He seguido los consejos de este hilo y he usado el integrado 74121, el cuál he conectado de la siguiente forma:



Este circuito está en internet y en el programa Multisim FUNCIONA. Sin embargo, lo he montado en una "protoboard" y NO funciona!!

He revisado las conexiones mil y una veces, y no consigo que en la salida "Q" me dé ningún valor cuando conecto el voltímetro entre Q y MASA. ¿Podría estar mal el chip? No lo entiendo.

Muchas gracias!!

PD. He probado con diferentes valores de resistencia y condensador para que aumente el tiempo de salida, pero nada, cero patatero.
08/09/2012 #16


Hola Phosky

Hay más de una forma de utilizar el 74121, el que Tú presentas no lo he visto por ningún lado.
Entra a Google e indaga por: Circuitos con 74121 o tambien por: Diseños con 74121.

saludos
a sus ordenes
09/09/2012 #17


MrCarlos dijo: Ver Mensaje
Hola Phosky

Hay más de una forma de utilizar el 74121, el que Tú presentas no lo he visto por ningún lado.
Entra a Google e indaga por: Circuitos con 74121 o tambien por: Diseños con 74121.

saludos
a sus ordenes
Buenas,

Pues buscando "circuitos con 74121", el primer resultado que me da es el de mi circuito (http://proton.ucting.udg.mx/dpto/mae...ion/index.html) .

La verdad es que no sé de qué otra forma podría hacer que al entrarle un impulso de 5V de pocos ms lo transforme en un pulso de 4 segundos a la salida si no es con ese circuito
09/09/2012 #18


Hola Phosky

Si analizas la tabla de verdad del 74121, que viene en sus hojas de datos, verás que no hay una combinación así:
A1(3) = 0
A2(2) = 0
B(5) Pulsos de transición positiva.
Con esa acción cambie Q(6) a 1 por un tiempo determinado por R1 y C1.

Has un experimento en tu simulador MULTISIM: desconecta una de las terminales del capacitor y aplícale pulsos a B(5) con el botón. Creo que seguirá funcionando aun sin el capacitor.

O prueba con un nuevo 74121.

saludos
a sus ordenes
09/09/2012 #19


Buenas!

Ante todo muchas gracias por responder.

He probado lo que dices y nada, me da error cuando quito el condensador, o cuando muevo alguna patilla y la pongo en otro lado...

Así es como lo tengo puesto ahora en el Miltisim y en la protoboard, y funciona en el primero pero no en el segundo:



Lo he puesto más sencillo (2 pilas de 6V) y nada, cuando lo monto no funciona, pero en el programa sí
09/09/2012 #20
Moderador

Avatar de elaficionado

Hola.

Los 74XXX funcionan con 5V, no con 6V.
Usa esto.



Chao.
elaficionado.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.