Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/05/2011 #21


saludos

MR CARLOS

Tengo que realizar una matriz de leds 5x7 con una eprom que despliegue todo el abecedario con barrido pero no se ni como hacer el circuito
no te pido que me lo des hecho pero si me gustaria que me orientaras en ello, pues no se como se
programa la eprom
18/05/2011 #22


Hola luis14

Qué simulador tienes ? (Dime Cual Utilizas).
En él ve haciendo la matriz de LED’s 5X7.
Debe haber 5 líneas verticales y 7 líneas horizontales.
A las líneas verticales las vamos a llamar por el prefijo X y a las horizontales por el prefijo Y.
Así que habrá X0, X1, X2, X3, X4 De Izquierda a derecha llamadas columnas. Desde la columna 0 hasta la 4.
Además: Y0, Y1, Y2, Y3, Y4, Y5, Y6, de abajo hacia arriba Llamadas Fila. Desde la Fila 0 hasta la 6.

Cuando la tengas la adjuntas; procura que el archivo que adjuntes esté en el formato del Software simulador que utilizas. Puedes agregar, también, una imagen Jpg, BMP Etc.

Una cosa que no comprendo bien es lo que mencionas en tu mensaje: “con barrido”, qué quieres decir con esto?

saludos
a sus ordenes
PD: Lo olvide, en cada cruce Columna-Fila conecta un LED orientados hacia el mismo lado.
18/05/2011 #23


Saludos Mr Calrlos

Muchas gracias por responder
El simulador que uso es el proteus, la duda que tengo es como y con que software se crea el programa para meterlo en la eprom jamas e programado una, te adjunto una imagen con las instrucciones que me distes de filas y columnas

mr carlos la imagen es muy grande no te la puedo adjuntar pero te la puedo mandara tu correo
18/05/2011 #24


Hola luiz14

Comprime la imagen con WINZIP o WINRAR y adjunta el archivo .ZIP.
Una imagen del circuito me llevaría mas tiempo pues tengo que hacer lo que viene en la imagen en mi simulador.
En cambio si adjuntas el archivo que se genera en tu simulador me llevaría menos tiempo el hacerlo

Este archivo que se genera de tu simulador lo debes comprimir con WINZIP o WINRAR para que lo puedas adjuntar.

saludos
a sus ordenes
02/05/2015 #25


Matriz de leds 5x7 con eeprom
Buenos días.

He tenido problemas con un circuito que me pasaron, estoy intentando hacer que se muestre un mensaje (codificado por columnas) en una matriz de leds de 5x7 con una memoria eeprom, pero el circuito que me dieron no funciona ni en la simulación de proteus, ni de forma física en un proto. De hecho, en forma física el 28C64 se calienta muy rápidamente, lo que indica que hay algún tipo de corto en el circuito.

¿Alguien podría decirme que tengo que corregir en las conexiones sin tener que comprar nuevos elementos? Adjunto el circuito de proteus y el mensaje que quiero mostrar en un archivo .hex
Archivos Adjuntos
Tipo de Archivo: zip circuito.zip (90,3 KB (Kilobytes), 33 visitas)
02/05/2015 #26


Hola Rick028

Así como se ve tu circuito es como te lo pasaron ??
Porque veo que la memoria 27C64 tiene permanentemente conectada a tierra la dirección A3.
Además las direcciones A10, A11 y A12, si no las utilizas debes conectaras a Tierra(Masa, GND).
La entrada PGM negada no hay que dejarla sin conexión así como la entrada VPP.

Ahora bien: Tal vez el archivo mensaje.hex que adjuntaste esté definido para no seguir una secuencia ascendente de direcciones de la memoria.

Que mensaje se debe ver en esa matriz ??

saludos
a sus ordenes
03/05/2015 #27


Sí, así me lo pasaron. Pero estoy seguro que debe tener algunos errores ya que no me funciona.
El mensaje son mis datos, la primera palabra es mi nombre Ricardo

Ok, ¿A dónde debería conectar A3, PGM y VPP?
03/05/2015 #28


Hola Rick028

Hay muchas cosas por mejorar en el circuito que te pasaron.
La memoria 27C64 No puede dar suficiente corriente para encender los LED’s de la Matriz.
Por tal motivo se calienta cuando pruebas ese circuito en la realidad.
A la Matriz que se mira en el diseño hay que aplicarle un nivel alto en las columnas mientras que por las filas se le aplica un nivel bajo a los puntos que quieres que enciendan.

He estado analizando el archivo HEX que adjuntaste y al parecer no tiene la información correcta para que se vea en la matriz de LED’s la palabra Ricardo.

A3 se conectaría al BIT 3 del contador localizado en la parte superior del esquema.
Puesto que no utilizas la entrada PGM negada, debes conectarla al Vcc.
Puesto que no utilizas la entrada VPP debes conectarla a Tierra(Masa, GND).

saludos
a sus ordenes
03/05/2015 #29


Gracias MrCarlos

Modifique las conexiones y por lo que puedo ver el pin 3 del 74138 no está recibiendo ninguna señal, hice algunas pruebas pero no puedo encontrar cuál es el problema.

¿De qué forma está mal hecho el archivo .hex? Utilize el programa que encontré en este post del foro:

forosdeelectronica.com/f25/controlar-matriz-leds-8x8-memoria-eeprom-28c64-62182/#post634942

Para generarlo, por ejemplo la letra R sería 80 B7 B3 B5 CE
Imágenes Adjuntas
Tipo de Archivo: jpg matriz.jpg (164,0 KB (Kilobytes), 37 visitas)
03/05/2015 #30


Hola Rick028

Creo que el programa que encontraste en el siguiente enlace no te sirve para desarrollar tu proyecto.
(http://www.forosdeelectronica.com/f25/controlar-matriz-leds-8x8-memoria-eeprom-28c64-62182/#post634942)

Además: cando inicia la simulación la dirección de la memoria NO es 000, por el modo como tienes configurados los dos contadores 74191 y el 74LS90.

Ahora bien:
En la dirección 0000 se debe habilitar la primer columna de puntos en la Matriz Con un nivel Alto, la columna de tu izquierda.
En esa dirección todos los BIT’s de la memoria xxxx deben tener un nivel bajo para que enciendan todos los puntos de esa columna.
Luego se habilita, con un nivel alto, la siguiente columna a tu derecha.
Entonces en la dirección 1000 solo los BIT’s D6 y D3 deben contener un nivel bajo para que solo encienda el punto superior y el cuarto contando de arriba hacia abajo.

De dónde sacase ese circuito que presentas en tu mensaje #25 ??

saludos
a sus ordenes
Imágenes Adjuntas
Tipo de Archivo: jpg matriz.jpg (274,0 KB (Kilobytes), 20 visitas)
03/05/2015 #31


MrCarlos dijo: Ver Mensaje
De dónde sacase ese circuito que presentas en tu mensaje #25 ??
De mi maestro, nos dio varias opciones para escoger y yo escogí el circuito para programar por columnas, los demás escogieron circuitos distintos.

Y ya arreglé el 7490, pero no estoy muy seguro de como reparar los 74191 para que empiecen desde 0000, siempre inicia en 0010, no importa lo que modifique.
Imágenes Adjuntas
Tipo de Archivo: png 7490.png (12,1 KB (Kilobytes), 17 visitas)
04/05/2015 #32


Hola Rick028

Creo que el direccionamiento de la Memoria puede ser como se mira en los archivos que te adjunto.
Nota que por las columnas tienes que desplazar un nivel alto de tu izquierda hacia tu derecha.
Por las filas se aplica un nivel bajo a los puntos que quieras que enciendan.

Analiza el archivo Ram Only.pdsprj que te adjunto en el .zip.
Con el LOGICTOGGLE puedes hacer avanzar al contador, o puedes utilizar el Clock seleccionándolo con el conmutador SPDT.

Casi se ve la palabra Ricardo pero algunas letras no están bien definidas.

Espero haberte ayudado.

saludos
a sus ordenes
Archivos Adjuntos
Tipo de Archivo: pdf Ram Only.PDF (217,9 KB (Kilobytes), 11 visitas)
Tipo de Archivo: zip Ram Only.zip (19,3 KB (Kilobytes), 8 visitas)
04/05/2015 #33


Gracias MrCarlos

Funciona en la simulación, lo probaré más tarde en físico y reportaré si funciona.
07/05/2015 #34


Lo siento por el doble post, pero estoy teniendo unos cuantos problemas al conectar la matriz.

El circuito es el mismo, excepto que para encender la matriz se necesita unos transistores 2N2222a, conozco los pines y se cuales corresponden a las filas y columnas, pero no estoy muy seguro de como conectar los 7 transistores.

La matriz es de ánodo común y tengo entendido que los transistores van con el emisor a tierra, pero si los conecto a tierra, la matriz no muestra nada, y si conecto el emisor a Vcc simplemente se encienden todas las columnas, y cada vez que el reloj envía un pulso una se apaga y enciende, una después de la otra de izquierda a derecha. Si pongo 5 resistencias de 220 Ohm afuera del 7404 ocurre algo similar excepto que se atenúan los leds y de vez en cuando se enciende algo que parece una letra.

Realmente no entiendo cuál es el problema.
Imágenes Adjuntas
Tipo de Archivo: jpg P1020830.jpg (270,1 KB (Kilobytes), 17 visitas)
Tipo de Archivo: jpg 2n2222a.jpg (20,5 KB (Kilobytes), 8 visitas)
08/05/2015 #35


Hola Rick028

Por qué necesita los transistores ??
Supongo que porque la memoria (27C64) no puede proporcionar la suficiente corriente para encender los LED’s
Pero el 7404 que tienes para manejar las columnas si puede proporcionar esa corriente??

Las matrices de LED’s no son de ánodo común o cátodo común sino columnas de ánodo común y filas de cátodo común.
Puede haber también columnas de cátodo común y filas de ánodo común.

Qué corriente requiere un LED, en esa matriz, para encender plenamente ??
Y cuando circula esa corriente, que caída de voltaje hay en sus terminales ??
Conoces las características eléctricas de la matriz de LED’s que se mira en la imagen que adjuntaste ??

saludos
a sus ordenes
08/05/2015 #36


Pues este es el datasheet de la matriz de leds que tengo:

http://www.puntoflotante.net/gmm12057.pdf

Al parecer, es de columna de ánodo, pero no estoy muy seguro de como leer los voltajes y las corrientes en la tabla.

Tampoco estoy muy seguro si el 7404 puede proporcionar la suficiente corriente, sólo lo agregué porque era parte del esquema para las columnas.
09/05/2015 #37


Hola Rick028

Revisando las hojas de datos (GMM-12057 ASB) de la matriz de puntos veo que es:
columnas de cátodo común y filas de ánodo común.
Diferente de las que trae el ISIS de Proteus:
columnas de ánodo común y filas de cátodo común.

Entonces debes aplicar a las columnas un nivel bajo (0) para habilitarlas.
Por las filas debes aplicar un nivel alto (1) a los puntos que quieras que enciendan.

saludos
a sus ordenes
Imágenes Adjuntas
Tipo de Archivo: jpg GMM-12057 ASB.jpg (40,8 KB (Kilobytes), 16 visitas)
09/05/2015 #38


Gracias MrCarlos

Funcionó perfectamente, quité el 7404 y las resistencias, pero tuve que invertir las salidas del 74138 que iban a las columnas de la matriz, en lugar de que el pin 15 del 74138 fuera al pin 13 de la matriz, fue al 6. Lo mismo con los otros 4 pines.

Aun así, ya funcionó.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.