Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/06/2007 #1


Problema con circuito para atacar la base de un tiristor
Hola, escribo porque me ha surgido un problema durante la prueba de un circuito que diseñe:
- Un microncontrolador (AT89C52) proporciona la señal para excitar la base del tiristor que trabajará en corte y saturación.
- Hay un temporizador 555 que trabaja en modo astable.
- También he añadido un buffer 74245 a la salida del puerto que utilizo en el microcontrolador. Utilizo un puerto entero, es decir 8 bits.
- Utilizo un puerta lógica AND 7408 de dos entradas, una es la salida del 74245 y la otra la salida del 555. De este modo consigo trenes de pulsos para atacar la base del tiristor.
- El tisitor está polarizado con una resistencia de 1 K entre la base y la salida del 7408.

La cuestion es la señal que debe excitar al tiristor se me hace inestable. Si desconecto las puertas lógicas, las salidas del 74245 son las esperadas, pero al conectar las puertas 7408, las salidas del 74245 se me hacen inestables.

¿A que se puede deber este problema? Yo he pensado ya todo y no doy con la solución.

Espero que alguien em pueda ayudar. Gracias
07/06/2007 #2


A ver amigo, en este foro tenemos una cantidad de recursos disponibles para facilitar tanto, preguntas, como respuesta y ayudas. ¿Qué tal si las utilizas?

Recuerda: Mientras más datos mejor.

Por favor, "PUBLICA EL DIAGRAMA del cirtcuito que estás armando y, como se trata de un micro, anéxale el programa "COMENTADO" de lo que pretendes que él circuito haga, bajo las órdenes del micro".

Con eso, seguro que mucha gente te podrá dar una mano.

Saludos: mcrven
07/06/2007 #3


Ok, de acuerdo, es que no sabia si añadir el circuito y el programa seria decuado. Aqui los dejo. Se trata de un programa muy simple que cuando detecta el paso por cero, realiza una serie de temporizaciones y activa unas salidas del puerto 2 y desactiva otras. Es un controlador de fase trifásico.
Con transformadores de impulsos hago el circuito de disparo que debe atacar a los tiristores del convertidor AC/AC
Archivos Adjuntos
Tipo de Archivo: zip proyecto_677.zip (23,4 KB (Kilobytes), 66 visitas)
07/06/2007 #4


amigo olemishue, de un vistazo al circuito, creo haber intuido el problema.

Tienes, según veo, dos circuitos trifásicos dirigidos a, según dices, disparar los thyristores correspondientes a cada fase de cada uno de esos circuitos.

Pude ver un circuito para la detección del Pase-por-Cero. Pero es solo para una de las fases y eso no puede controlar las tres.

Cada fase debe contar con un detector del pase-por-cero. O sea cada thyristor debe activarse en forma sincronizada con su propia posición dentro de la topología del circuito trifásico.

Saludos: mcrven
07/06/2007 #5


Por otra parte y, después de haber visto el programa que, ciertamente, es muy sencillo.

Te comento que este tipo de programa debe controlar tiempos muy restringidos, por lo cual, la temporización que el mismo debe producir, debe ser considerada como: "Relojería Suiza". todos los retardos inducidos por el micro, deben ser sumados cuidadosamente, afin de evitar las interferencias con el circuito que se quiere controlar.

No es tan simple como parece, pero tampoco es difícil, mucho menos imposible. Esos aparatos ya existen y, la mayoría, son completamente analógicos.

Adelante pues... Que lo peor es no hacer nada.

Saludos: mcrven
07/06/2007 #6


El problema no lo tengo con la exactitud de las temporizaciones.

Si desconecto del circuito las puertas lógicas y pongo la sonda del osciloscopio en cada patilla de salida del 74245, las señales son las que esperaban y los retardos se producen en el tiempo esperado. Tampoco pretendo que sea 100% exacto, dentro de lo que cabe creo que eso esta ya bien.

El problema llega al conectar las puertas lógicas. Con la sonda del osciloscopio en el mismo lugar que antes (salida del 74245) las salidas se me hacen inestables, es decir, se ponen todas a nivel bajo o nivel alto o van variando de forma aleatoria. Es como si "algo" intefieriese en las salidas del microcontrolador.

En un princcipio pense que puede ser por temas de compatibilidad de puertas, pero las puertas AND son 74HC08 y el buffer es un 74HC245 asi que no creo que eso sea el problema ya que son de la misma familia.

Gracias por la ayuda, un saludo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.