Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/04/2009 #1


Problema con osciladores aestables (puertas logicas)
Buenas compañeros, nuevamente me pongo en contacto con vosotros aver si me podéis hechar una mano con una duda que tengo y no sé como resolver.

Recientemente me he puesto a repasar temas de electrónica digital y me he quedado bloqueado al llegar a los osciladores aestables realizados con puertas logicas, me explico, estoy intentando montar esto, pero no me funciona y no se ver donde está el problema



Estas puertas están dentro de un SN74LS04, monto el integrado en el entrenador y lo alimento con +5v, hago todo el montaje tal como está en el esquema, pero no se que más he de hacer para que esto empiece a generar la oscilación

He probado a alimentar la entrada de A con un 1 (+5v) y como era de esperar en la salida de B tengo un 1, pero tengo una señal de salida continua es decir no genera ningún tipo de oscilación este circuito ( es como si no se enterase de los demás componentes (resistencia condensador), ¿alguien me puede acalarar que estoy haciendo mal o como debo de conectarlo exactamente?.

Para más dudas conecté un led a la salida para ver si en teoría parpadeaba, como era de esperar siempre está encendido si le meto un 1 a A, también he visualizado la salida con el Osciloscopio y lo mismo siempre tengo las +5V, si por el contrario le meto un 0a A pues en la salida lo mismo un 0.

Por cierto he hecho montajes parecidos con el 555 y perfecto funcionaron pero al intentar realizarlo con puertas lógicas sencillas no hay forma

Gracias de antemano ya que llevo algunos días bloquedao con este tema y no quiero seguir estudiando otras cosas si no consigo hacer funcionar esto
13/04/2009 #2

Avatar de Eduardo

Cuando la salida es 1 te queda el electrolitico polarizado al reves. Sacalo y usa uno no polarizado.
13/04/2009 #3


prueba con resistencias de 100k y 200k
15/04/2009 #4


Hola de nuevo, gracias por las respuestas, os explico

he probado con las resistencias de 100K, 200K y nada lo mismo, también he probrado con condensadores de diferentes valores no electrolíticos y lo mismo nada de nada,

el problema es que el integrado (74LS04) una vez hecho el montaje, mirando la tensión con el osciloscopio en la entrada de A tengo unos 1,22V (1) a la salida 0, a la entrada de B 0 y a la salida unos 4,65V (1) hasta aqui todo correcto, el problema es que para que el condensador empiece a cargar en teoría en la entrada de A tiene que haber un 0, aunque fuerce la entrada por un momento a 0 en cuanto la vuelvo a dejar normal vuelve a ese 1 y hay se queda, es como si el circuito ni se enterase de las resistencias y el condensador,

¿mi pregunta es. Este circuito explica de una forma bastante sencilla como funciona un pequeño oscilador pero realmente ¿esto a la practica funcionaría?, por más vueltas que le doy al esquema no veo donde está el fallo,

después de los datos que he dado aver si a alguien más se le ocurre donde puede estar el fallo
15/04/2009 #5

Avatar de Eduardo

Momento... vos estas usando un 74 LS 04. Esos tienen internamente una resistencia de pullup --> Yendo a masa con una R de 30k (10k+20k) tal vez no llegues a 0.8V (como pareceria que esta pasando)
Proba con valores mas chicos de R, digamos 2k2 y 4k7.
16/04/2009 #6


UEEEEEEEE! por fin esta vivo!

jejejeej gracias Eduardo eres un crack, he probado con los valores de resistencias que me has dado y también he tenido que poner una resistencia pull down de 10K en la entrada de A con esto el Led que he puesto a la salida ha empezado a parpadear y visualizando la salida con el Oscilo veo la señal oscilando, en la entrada de A veo el ciclo de carga y descarga del condensador, y en la salida de B la señal cuadrada

Resumiendo resistencia R=2k2Ω R2=4k7Ω C=10µF electrolitico (si se aumenta la capacidad aumenta el tiempo de carga-descarga y con ello el led parpadea más lentamente) y resistencia Pull down de 10KΩ para hacer que la entrada de A baje hasta 0 y empiece el ciclo

Por cierto Eduardo habías comentado que este integardo lleva internamente una resistencia de Pullup, he estado mirando el datasheet del componente y no he visualidazo este dato por ningún sitio, ¿me podrías comentar donde lo has visto?
16/04/2009 #7

Avatar de Eduardo

No lo habia visto, me acordaba que tenian asi las entradas.

Pero si usas el "Buscador de hojas de datos" de mas abajo con 74LS04, en el 3er item ya te aparece el circuito interno en la previsualizacion.
Fijate que la base del transistor Schottky no esta en el aire sino con una R de 20k a Vcc.
16/04/2009 #8
Moderador

Avatar de elaficionado

Hola.
Si puedes usa el 4049, o cualquier puerta Cmos, NOR (4001), o NAND (4011), en modo inversor.

Chao.
elaficionado.
Imágenes Adjuntas
Tipo de Archivo: gif osc_370.gif (45,1 KB (Kilobytes), 121 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.