Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/10/2011 #1


Problemas con Flip-Flop D 4013
Buenas, estamos haciendo un semaforo y usamos unos flip flop D como biestable, puenteando el D con el Q|, el problema es que no funciona, tiene un comportamiento errático, que soluciones puede haber? puede ser algún problema de masas? lo estamos alimentando con 9v en el caso de que no hubiera solución, es factible sustituirlo por un 555? solo necesitamos que cuando le de un pulso cambie de estado, hay alguna otra alternativa?
Estamos un poco cortos de tiempo, porque es un proyecto casi terminado para entregar dentro de 4 dias. Gracias.
27/10/2011 #2


que soluciones puede haber?
Dependiendo del problema, solo una que funcione mejor...

puede ser algún problema de masas?
podria ser, pero no lo creo...

es factible sustituirlo por un 555?
no pudes sustituir un flipflop con un 555, porque sirven para diferentes propositos...
tienes que rediseñar tu circuito

hay alguna otra alternativa?
pon semaforo en el buscador...

o Sube el esquema que estas utilizando...
27/10/2011 #3


Aca te paso el esquema en livewire, si queres te puedo pasar los circuitos en eagle, el tema es que simulando funciona perfecto, pero en la practica no
Archivos Adjuntos
Tipo de Archivo: zip Modificacion flip flop(falta terminar).lvw copia.zip (6,2 KB (Kilobytes), 91 visitas)
27/10/2011 #4


pon a tierra el set y el reset del IC13a y el set del IC13b


verifica que el 555 este pulsando correctamente...

ese tipo de circuitos el livewire los simula muy bien asi que intenta ver tambien posibles errores que hayas cometido en la conexcion real...
y no uso el eagle... pero siquieres subirlo por si alguien quiere darle un mirada....
27/10/2011 #5


es que el contador con el display funciona perfecto , el tema esta que los flip flop no cambian, lo sacamos del circuito y los conectamos en una protoboard e hicimos algunas pruebas y funciona todo bien, excepto cuando conectamos el D con el Q| que se comporta raro, cuando le doy clock el Q se pone a cero, cuando lo desconecto, en Q y Q| hay 4v en cada una! y cuando vuelvo a conectar el clock, vuelve a ponerse a cero la misma pata...
27/10/2011 #6


pusiste el set y el reset a tierra como te comente... en el livewire los dejaste al aire....
27/10/2011 #7


sisi es verdad, pero en la protoboard los conectamos a - y nada... ahora prove con conectar un cable a menos y tocarlo con la mano, y parece que se comportara mejor...
27/10/2011 #8


el led conque resistencia lo pusiste, si intentas ponerlo con un transistor...
27/10/2011 #9


en la protoboard, quitamos el led porque en estado bajo nos daba 2v asi que usamos el tester, con el negativo conectado a tierra, como si fuera una punta logica.
27/10/2011 #10


quitamos el led porque en estado bajo nos daba 2v asi que usamos el tester, con el negativo conectado a tierra
yo no confiaria en el tester si me dice que 2v, o es un poco mas de 0v o un poco menos de 5v o 9v..
27/10/2011 #11


poco menos de 5v seria estado bajo? porque ya te digo cuando desconecto el clock nos aparece casi 5v en Q y Q| ...
27/10/2011 #12


no entiendo, que me quieres decir....

cuando en Q hay poquitito menos de 5v, en Q| deberia estar en poquitito mas de 0v
27/10/2011 #13


no no, yo tengo como estado alto 9v y bajo menos de 1v pero hay veces que tengo 4,6v en Q y al mismo tiempo en Q|, es normal esto?
27/10/2011 #14


es normal esto?
segun te entiendo , pues no, no es normal....
27/10/2011 #15


en teoria el circuito no debería quemar los flip flop vedad? y se supone que como estoy intentando de conectarlo debería funcionar bien si? entonces esto me supera...
27/10/2011 #16


en teoria el circuito no debería quemar los flip flop vedad?
el circuito no.... una mala conexion si.....

conectarlo debería funcionar bien si?
si intentas que funcione el flipflop pero con un led y su respectiva resistencia limitadora, y en el clock lo mandas a positivo y luego a negativo.... me explico?

osea independiente del resto del circuito
27/10/2011 #17


Bueno hice todas las pruebas posibles con el flip flor y responde bien a todo excepto cuando puenteo D y Q| se supone que un pulso del clock cambia el estado, ahora viene lo extraño, si conecto el cable a positivo o negativo y le doy un pulso al clock, no pasa nada, PERO si toco el clock con el cable SIN conectar el otro extremo, cambia de estado, todas las veces funciona bien así! que esta pasando??
27/10/2011 #18


Prueba esto... y ve que pasa...



como es posible que no se deje..

cada que pulses el switch debe cambiar el estado del led
Imágenes Adjuntas
Tipo de Archivo: jpg Dibujo.JPG (11,8 KB (Kilobytes), 114 visitas)
27/10/2011 #19


opa! ahora si parece que funciona bien, me podes explicar que hace la resistencia? estaba mirando algo de filtrar ruidos, muchísimas gracias!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.