Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

05/10/2008 #1


Con un reloj digital. (74ls47)
Hola todos, les comento que he estoy haciendo un reloj digital, ya arme todo el circuito, pero en vista de que no me funciono comencé a hacerlo por partes, primero hice el astable del 555 q luego conecte a un 7490 el cual me vota el BCD correctamente, al conectar estas salidas a la 7447 el display no visualiza los codigos como debería así que comencé a analizar las salidas del 7447 (empezando por la salida g pin #14) con una resistencia y un led y encontré en el datasheet que la salida f, debería mandar un 1 lógico (q hace q el display de anodo no prenda) en los codigos binarios 0,1 y 7. lo que me sucede es que efectivamente la salida g se apaga en 0 y 1, pero en 7 permanece encendida.

¿a que se deberá eso? agradezco de antemano la ayuda q me puedan proporcionar

Se que hay muchos temas relacionados con este tipo de contadores pero no encuentro ninguno q tenga el mismo problema q yo

aqui esta el datasheet de la 7447

http://ltrussart.ep.profweb.qc.ca/la...iques/7447.pdf
06/10/2008 #2

Avatar de Ferny

Imagino que te refieres a la salida G en vez de la F ¿no? (o sea, la barrita central del 8)

Si la entrada BCD es correcta y no tiene ruido, prueba con otro 7447 por si el que tienes estuviera dañado. Yo los he usado y también los 7448 y el circuito no tiene mucho misterio...

De todas formas, ante la duda postea tu circuito para analizarlo

Saludos
06/10/2008 #3


gracias por la corrección

y donde lo posteaste? es q soy nuevo en el foro
06/10/2008 #4

Avatar de Ferny

No, no lo posteé aquí, lo probé en protoboard y luego directamente lo soldé.

Pero vamos... los pines LT, BI/RBO y RB puestos a VCC, le metes el código BCD por A-B-C-D y miras la salida con un led y una resistencia... no hay más.

Suerte
06/10/2008 #5


luego de armar y desarmar varias veces mi 7490 dejo de enviar los pulsos BCD bien, asi que la cambie por otra, y de nuevo me sirvió, me puse a mirar el voltaje de mi fuente y me di cuenta que estaba variando mucho y la cambie por otra, no se si exista una forma de probar la 7447 porque solo tengo las necesarias y el sitio donde se consiguen me queda muy lejos
06/10/2008 #6


Tengo una inquietud bastante curiosa, las salidas 1 y desde el 4 al 9 del 7447 se visualizan bien en el display pero 0, 1 y 2 salen erróneas, en el caso del 0, el error esta en que el pin g del display prende mientras el f queda apagado formando algo asi
_
_|
|_|

pense que la 7447 estaba dañada pero al conectar un led con una resistencia a la salida f del 7447 el led prende mientras que el pin f del display continua apagado.

Como puede ser esto posible si son el mismo nodo? en los demas numeros el pin f del display prende bn

el 7447 esta conectado en configuracion BCD (pin 1 y 12)
07/10/2008 #7

Avatar de Ferny

Postea un esquema de cómo estás conectando el 7447 a tu display, porque es posible que ahí esté el problema...

Otra cosa que puedes hacer es probar una por una las entradas del display. Le pones 5V en el pin de ánodo común, y luego con una resistencia de 1K vas puenteando cada una de las salidas a masa, así se iluminan y puedes ver a qué segmento corresponde cada pin del display (quizá los estás conectando mal ahora y es por eso que no funciona)

Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.