Haz una pregunta
  Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/02/2016 #1


salida filtro pasa alto
Saludos.
Escribo ya que estoy haciendo el siguiente circuito (Adjunto 1).

La salida del optoacoplador queda "sucia", por lo que puse un filtro pasa alto con frecuencia de corte 1[Khz] a la salida de este. Una vez que pasa por el filtro y luego por el amplificador operacional, la señal "sube" en aproximada mente 2[V]. No entiendo por que pasa esto (el capacitor?, el op amp?). Estuve leyendo que hay que poner un condenzador de acoplo (busque en el foro y veo que este deja la señal a +V y -V), necesito dejarla entre 0 y +V.
Mi pregunta es...¿Por qué pasa esto?, y como puedo eliminar este efecto. (La idea es que le circuito despues alimentara un totem de transistores, y finalmento esto a un mosfet (adjunto3).
De antemano muchas gracias.
Adjunto la forma de onda que me entrega a la salida del circuito adjunto 1 (Adjunto2)
De antemano muchas Gracias.
Cactus.
16/02/2016 #2

Avatar de chclau

A ver que te parece este circuito

Adjunto tambien el esquema LT-Spice comprimido

16/02/2016 #3


Saludos...
Se ve bien...pero hay que ponerle el filtro...ya que a la salida del opto, la señal sale "sucia" (en la simulacion sale bien, pero al probarlo en la realidad no funciona tanto. Por eso el filtro, y luego el amplificador).
Igual voy a pensarlo y comento.
Muchas gracias.
Yyyy...Lo de la subida de DC, por que pasa...He estado pensandolo pero no comprendo.
Muchas Gracias.
Cactus.

yyyy...
El resistor de 50K, cual es su funcion..??...con eso la onda sale mas "limpia".
Muchas gracias.

Para ser mas acertivo. No es sucia la palabra, sino que con componentes myt lentos...

[Edita tus comentarios en lugar de crear nuevos]

Estimado.
Saludos.
Probé el circuito, pero estas son las formas de onda que me entrega:
(Adjunto4---> Salida del transistor y entrada al mosfet)
(Adjunto5---> Salida del Mosfet).
Lo frecuencia es de 100[Khz]

De antemano muchas gracias.
Cactus.

Ahora si los adjuntos.
Imágenes Adjuntas
Tipo de Archivo: jpg adjunto4.jpg (42,4 KB (Kilobytes), 12 visitas)
Tipo de Archivo: jpg adjunto5.jpg (40,0 KB (Kilobytes), 8 visitas)
16/02/2016 #4

Avatar de Nuyel

Me puedes ilustrar la posición de las puntas de prueba? no entiendo bien de donde sacas esas medidas.

De que el voltaje se corra, depende del modelo del amplificador operacional, además, en esa simulación lo estas alimentando con una fuente simple, tras pasar el filtro se tiene un voltaje negativo y el punto 0V queda en la constante, el amplificador sin embargo, no tiene una alimentación negativa y no va a poder sacar voltajes negativos, así que el voltaje sera el mínimo que pueda proveer y al parecer es casi de 2V para tus condiciones. Si necesitas un voltaje mas cercano al cero debes usar operacionales con salida Rail-to-Rail, o alimentar con voltaje negativo el amplificador para que pueda incrementar el rango de excursion.
16/02/2016 #5


Saludos.
Si.
Las formas de onda, son (Adjunto4--> en R6), y (adjunto5--> en la R de carga), la onda azul es la entrada al opto, y la roja donde indicaba anteriormente).
Lo que hice para dejar la señal a 0 fue esto (Adjunto6), y hasta esta etapa funciona bien (la onda queda amplificada y filtrada correctamente), pero aun no se la alimento al mosfet. Adjunto la forma de onda mas tarde (no la tengo ahora).

Ahora con respecto al circuito de chclau, La fuente de 12 y 48 ¿tienen la misma tierra? ( ¿no hay problemas con esto? y ¿esta de 48 puede ser mayor?).

Finalmente. Simule el circuito totem (de adjunto 3), y me da lo siguiente en en la R de carga (Adjunto7) (aun no lo armo). A que se debe que la onda no se vea "Limpia, pulcra" (no se como ponerlo),¿a los transistores que no son suficientemente rápidos?. (la onda azul es la entrada y la verde la forma de onda en la carga)

Muchas gracias por las respuestas.
Cactus
Imágenes Adjuntas
Tipo de Archivo: jpg adjunto6.jpg (108,1 KB (Kilobytes), 8 visitas)
Tipo de Archivo: jpg adjunto7.jpg (96,3 KB (Kilobytes), 3 visitas)
16/02/2016 #6


100oh. Me parece mucha carga y totalmente innecesaria. Como estas midiendo que mencionas tener mucho ruido? Si trabajarás en conmutación, yo utilizaría un montaje de emisor común en el optó. Con una resistencia de 1k... No debería existir ruido a menos que la señal de entrada venga sucia. Generalmente la excursion de los opamp es 1 v menor que la diferencia de tensión aplicada. Se me ocurre que uses un opamp como el lm311 que no tiene problemas de ruido y su salida es un bjt a colector y emisor abierto. Polarizandolo con fuente simple obtendrás una tensión de 0.3v aproximadamente(no ando con el datasheet pa decirte cuanto será).
16/02/2016 #7
Moderador general

Avatar de Fogonazo

¿ Existe algún impedimento en emplear un optoacoplador digital ?

Algo como el TLP2200
16/02/2016 #8


Saludos.
No hay ningun problema en usar el TPL2200, solo que tendria que pedirlo y esperar que llegue (no vivo en una ciudad muy grande ni con muchas tiendas), lo mirare y respondo algo mas elaborado.
Lo de los 100 [ohm], es por que ese es el circuito que ponen el el datasheet para switcheo rapido, probare con unas mas pequeñas (viendo el data), y comento el resultado.
Comentare a medida que avance.
Con respecto a lo de las fuentes de alimentación (la de 12 y 48),¿ hay peoblemas en usar ambas?, ¿las tierras deben ir juntas?.
Y lo de la simulación del totem, ¿es por los componentes?
Muchas gracias por las respuestas.
Cactus.
16/02/2016 #9

Avatar de Nuyel

Pues un comparador con histéresis (schmitt trigger) podría corregir el ruido, este tiene la peculiaridad de que la salida solo cambia cuando el valor sobre pasa cierto umbral, no es un punto medio, sino una diferencia mayor entre el estado alto y el bajo, incluso si la señal fluctúa dentro del umbral, no cambia hasta que pase al siguiente.

La compuerta AND 4081 tiene entradas Schmitt Trigger, podrías probar usarla como filtro.
17/02/2016 #10

Avatar de chclau

Se pueden usar fuentes de distinta tension con tierra comun, no hay ningun problema con eso. Siempre que conectes la tierra de uno con la tierra de otro, otro tipo de conexiones no siempre se pueden hacer, pero conectar las dos tierras juntas si se puede hacer siempre.
17/02/2016 #11
Moderador general

Avatar de Fogonazo

Este esquema emplea un operacional "Terrenal" aunque no muy común, de este lado de la Cordillera se consigue.

6N136


Imágenes Adjuntas
Tipo de Archivo: jpg Opto rapido.jpg (51,2 KB (Kilobytes), 35 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Circuitos lógicos combinacionales y secuenciales

Compuertas, flips flops, registros, PLDs, codificadores, contadores, multiplexores, ...

Cerrar
Foros de Electrónica » Diseño digital » Circuitos lógicos combinacionales y secuenciales

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.