Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/04/2011 #281

Avatar de Meta

He estado probando su ejemplo, no funciona, al menos a mí si pulso teclas en el Virtual Terminal.
30/04/2011 #282


Hola META, tambien e mirado lo que ha puesto el compañero,lo unico que he podido habrir
es el ASM, pero como es en basic tampoco me aclaro mucho.
Y TU ADELANTE CON LO NUESTRO , saludos pepe
30/04/2011 #283


Meta que no te funciono, el circuito en Proteus o en sistema en Visual basic?

El Circuito de proteus cuando lo inicias automaticamente enciende el LED indicando que ya esta n funcionaminto, en el Bisual basic tienes que abri el archivo por defecto tiene el nombre de proyecto1.vbp y de igual forma cuando le das play te indica la hora del sistema y la fecha y te muestra en una textbox que el sistema esta iniciado.

El virtual terminal en proteus es solo para visualizar la letras que estan llegando de Visual Basic al pic por otra parte tiens que usar Configure Virtual Serial Port Driver utilizar com1 y com2 donde com1 es utilizado en proteus y com2 en visual basic.

Otra forma es de iniciar Visual basic y muetra el inicio del sistema y la hora y luego iniciar proteus este encendiendo el led y luego lo apaga y enviando un comando al visual basic lo recibe y muetra en una caja de texto "comunicacion establecida + la hora"


te envio el archivo nuevamente donde incluye en word codido de visual basic y el programa del pic.
Archivos Adjuntos
Tipo de Archivo: rar PIC VISUAL BASIC.rar (71,4 KB (Kilobytes), 116 visitas)
30/04/2011 #284

Avatar de Meta

Se ve carácter raro.

Asegúrate que el COMPIN es de 9600 de baudios, lo tenías a 2400. El PIC tambiñen debe ser de 9600 baudios. Lo he probado y funciona con carácteres raros o ese es lo que meustra en el Virtual Terminal.
01/05/2011 #285

Avatar de Meta

Hola willyfv:

He estado mirando el código fuente que me diste.
Código:
; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00020    IF SERIAL="S" THEN SONIDOS
    CMPEQ?BCL    _SERIAL, 053h, _SONIDOS

; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00021    IF SERIAL ="L" THEN LEDS
    CMPEQ?BCL    _SERIAL, 04Ch, _LEDS

; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00022    IF SERIAL ="R" THEN RELES
    CMPEQ?BCL    _SERIAL, 052h, _RELES

; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00023    IF SERIAL ="P" THEN APAGAR
    CMPEQ?BCL    _SERIAL, 050h, _APAGAR
Son letras que no me di cuenta.

Para los to@s. Pincha dos veces el componente del RS232 llamado COMPIM y deja los baudios a 9600 como muestra esta foto de abajo. Me lo han enviado a 2400 baudios, por eso no les funciona. Ahora me funciona.



He modificado el programa que puedes descargar y funciona. He comprobado que los tres primeros controla cada Led, el cuarto botón los apaga todos.

En cuanto a Depepee, dame las letras.
Archivos Adjuntos
Tipo de Archivo: zip Depepees_puerto_serie0.0.11.zip (5,9 KB (Kilobytes), 72 visitas)
01/05/2011 #286


En cuanto a Depepee, dame las letras.
Hola META no se que me qieres decir con esto.saludos pepe
01/05/2011 #287


Hola meta, si son solo letras no seporque a ti te funciona al 9600 y a mi me fuciona a la perfeccion a 2400
01/05/2011 #288

Avatar de Meta

¿Le funciona la aplicación?
04/05/2011 #289


Hola META,¿Como estamos con lo nuestro,?saludos pepe
04/05/2011 #290

Avatar de Meta

Hola:

Te estaba esperando todo este tiempo para que me dieras una respuesta si te funciona como willyfv. Pon el COMPIM desde el proteus a 9600 baudios y prueba.

Letras que envía al PIC son el A, B, C y D. Puedes descargarlo.

El ejemplo que me envió willyfv funiona muy bien cuando los puse a 9600 baudios los dos, tanto C# como el COMPIM del proteus.

Saludo.
Archivos Adjuntos
Tipo de Archivo: zip Depepees_puerto_serie 0.0.12.zip (5,9 KB (Kilobytes), 55 visitas)
04/05/2011 #291


Hola Meta,Este ultimo que pusiste a willyfv ni tan siquiera lo he abierto,no sabia que tenia que ver con lo nuestro ahora lo pongo en marcha com el pic y te digo algo,saludos pepe
04/05/2011 #292

Avatar de Meta

LA versión 0.0.11 es para willyfv. La 0.0.12 es para ti.

Descargar

Saludo.
04/05/2011 #293


Hola META,mientras me arreglan mi ordenador me he echo de otro, es un portatil y dispone de solo una salida DB9,lo que me pasa es que cuando habro la aplicacion me sale un letrero en el que me dice error IO
el COM2 no existe.saludos pepe
05/05/2011 #294

Avatar de Meta

Arggggggggggggg. Puse el COM2. Lo siento. Es el COM1. Toma este otro que si es el COM1.
Archivos Adjuntos
Tipo de Archivo: zip Depepees_puerto_serie_0.0.13.zip (5,8 KB (Kilobytes), 42 visitas)
05/05/2011 #295


Hola META,este ultimo lo habia probado con el "trasto"ahora lo he probado con el portatil y con un tercer ordenador el asunto es que los pulsadores funcionan bien pero lo que son las luces,nada ni pestañean el
pic siempre lo chequeo co hyperterminal y con el PIC RS232-V2.15 BETA,y funciona ha la perfeccion.saludos
pepe
05/05/2011 #296

Avatar de Meta

¿Las luces del PIc o de los textBox?
05/05/2011 #297


Hola meta el pic funciona bien tengo conectados 2 reles y por supuesto cada vez que se efectua un cambio
manda A ò a y B ò b eso lo tengo mas que probado pero las luces del texbox no hacen nada,saludos pepe
07/05/2011 #298

Avatar de Meta

Ah. Es lo que tengo que revisar. Ahora estoy muy ocupadísimo reparando portátiles a la gente.
07/05/2011 #299


http://www.fileupyours.com/view/3038...%20USB%20board.

Hola meta echale un vistazo ha esto,es un kit de algo parecido ha lo que estamos haciendo,tiene 5 entrada
esta echo en visual basic haber si se puede sacar algo,saludos pepe

http://www.fileupyours.com/view/3038...SB%20board.zip

Meta te he puesto esta sengunda porque la primera he probado y no bajaba esta segunda si saludos pepe
18/05/2011 #300

Avatar de Meta

No baja nada de nada.

File Not Found

The file you have requested could not be accessed because the file could not be found.

Requested File: K8055_VM110 USB board.zip


http://www.robotsperu.org/foros/visualbasic-vp8392.html





Muy bueno, hay que verlo a fondo.

Estoy viendo los vídeos y tarda mucho, parece muy bueno al menos los primeros minutos.


Si te animas, acaba de instalar otra ves los Visual Studio Express ya que se fastidió Windows 7 y tuve que formatear todo otra vez.

Voy a intentar copiar lo que hace el vídeo a ver si me sale.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.