Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/09/2013 #1


No detección de USB Device con alimentación autónoma
Hola,

En un placa embebida cuyo núcleo es un AM3354 (ARM Cortex A8), tenemos un problema con la detección de dispositivos USB , sólo en el caso de no recibir la alimentación a través del VBUS, es decir, cuando son alimentados por una fuente externa. Estoy buscando info pero no encuentro problemas similares, alguien ha tenido una experencia análoga.

Un saludo,
16/09/2013 #2
Moderador general

Avatar de DOSMETROS

No habrá un tema de falta de masa-negativo USB
16/09/2013 #3

Avatar de chclau

Otra posibilidad es que tu puerto USB ARM sea del tipo OTG y al detectar tensión en la pata de alimentación piensa que el otro dispositivo es un host y entra en modo device. Averiguá un poco sobre eso.
17/09/2013 #4


Ok, la cosa es que determinados dispositivos que se alimentan del bus tampoco los reconoce, es un poco extraño. Gracias por la ayuda.

Un saludo
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.