Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

05/08/2006 #1


duda con ULN2803
hola a todos

quiero controlar un motor a 12v DC mediante el puerto paralelo, para esto quiero usar un circuito integrado ULN2803 que al detectar un 1 logico en una entrada , en su respectiva salida da 12v.

lo que quiero saber es q si este circuito puede activarse dandole unicamente 2.6v de voltaje
ya q mi puerto funciona a 3.3v y despues de pasar por un circuito obtengo 2.6v de voltaje

gracias
19/08/2006 #2


Hola, es posible que ese voltaje si sea suficiente para actival el ULN, en dado caso que no funcione agregale un buffer como el 74ls245 para subirlo a 5V.
19/08/2006 #3


Con el uln2803, o el uln2803a es mas que suficiente para elevar tus tensiones de salida de la computadora (puerto paralelo) de 5V hasta 6 V yo lo he probado, tienes que armar bien el circuito y el valor de pila que le conectes entre las patas del mismo es el que te eleva, lo he probado con pilas de acido plomo de 6 v 4 Ah y se quema el integrado para 12 V, pero para 6 jala muy bien, ah otra cosa lo unico que hace el uln2803a es que son 8 transistores darlington que te ayudan para dicho proposito, revisa muy bien la temperatura del chip ya que se calienta con facilidad
Imágenes Adjuntas
Tipo de Archivo: gif esto_es_explicar_no_jal........_209.gif (3,3 KB (Kilobytes), 1138 visitas)
21/05/2012 #4


cuantos leds se pueden conectar al ULN2803
21/05/2012 #5


Saca cuentas soporta 500mA por canal...
22/05/2012 #6


gracias x la información necesitaba ese dato
22/05/2012 #7

Avatar de reyvilla

Hola aprovechando un poco el post que no lo encontré antes, yo tengo una duda también, con respecto a este componente, la cosa viene dada porque me paso algo bien particular con el integrado y un microcontrolador, es un sistema sencillo el cual activo una salida y verifico su estado cada cierto tiempo, lo hago así porque el código esta divido en varias etapas y una me permite activar la salida y otra me permite apagar la salida y otra es para verificar cada cierto tiempo el estado de la salida. La cuestion es que con el ULN2803 no logro que el microcontrolador lo detecte la salida cuando esta activa ya que hay una caída de tensión, osea en ves de haber 5V hay 2.5V, me imagino que es normal, pero realice unas pruebas con otro integrado que diría es el gemelo del ULN2803, es el integrado L603C, tiene la misma cantidad de pines y aguanta la misma corriente e internamente tiene las misma características, existen unas diferencias ínfimas, pero no es mucho, ahora con el L603C, logre medir 5V cuando activo la salida lo cual el microcontrolador si me detecta como que esta activa. Habra alguna manera de poder lograr lo mismo pero con el ULN2803C, de verda me tiene desconcertado, y esto me interesa muchisimo ya que el L603C, no es tan común como el ULN2803C, desde ya muchas gracias a quienes puedan ayudarme en esto, les dejo las hojas de datos para quienes quieran checar las similitudes y diferencias...saludoss



http://pdf1.alldatasheet.com/datashe...I/ULN2803.html

http://pdf1.alldatasheet.com/datashe...ICS/L603C.html

PD: Revisando la pagina de ST, me encontré con que el L603C ya es obsoleto, por lo cual con mas razón me interesa solventar este inconveniente que creo puede ser útil para todos como dato...saludoss
22/05/2012 #8


y que estas manejando con eso motores, luces??'

a mi no me parece raro el que el uln2803 te mida 2.5 lo raro es que el L603 te de 5v


bueno y porque no pones un transistor en la salida?
23/05/2012 #9

Avatar de reyvilla

És para activar unos reles de 12?
23/05/2012 #10


segun lo que me imagino que quieres hacer.. yo lo que te propongo es esto....



obiamente el led seria el rele, y con su respectivo diodo, y en el puerto de entrada del transistor utilizar la resistencia interna pullup o ponerla externa....

y te preguntaba de la carga porque cuando se miden motores varia mucho la medicion... pero no es este tu caso...
Imágenes Adjuntas
Tipo de Archivo: jpg Dibujo.JPG (61,8 KB (Kilobytes), 121 visitas)
23/05/2012 #11

Avatar de reyvilla

Te entiendo la idea, pero la cosa es que el sistema ya esta echo de forma directa son 32 salidas y es con un microcontrolador 16F877, no es tanto para la salida del ULN es mas la salida del microcontrolador la mismas que activa al ULN, la que necesito saber si esta activa o no
23/05/2012 #12


creo que voy entendiendo... y ahora si se me hace sospechoso si te marca 2.5v en la salida del micro yo pense que en la salida del uln (y si no es asi ya no entendi nada ) en teoria la corriente en la base del uln es de 1.8mA... ni cosquillas le deberia hacer al micro... yo creo que probablemente tenga un problema ese ULN2803...
23/05/2012 #13

Avatar de reyvilla

Bueno lo probé con varios y me daba lo mismo entre 2.3V y 2.5V
23/05/2012 #14


Pues entonces es el micro, acabo se hacer la prueba alimentando el pin1 del uln con 5v y si me da 5V no entiendo porque deberia de haber caida de voltaje, tienes una resistencia en la salida del micro??
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.