Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/11/2007 #1


Error en el Tx del RS232 de la PC
Hola.
Tengo un problema que es posible que se relacione con otro, ya que son "parecidos" de alguna manera.

Hace poco hice una placa para el control de motores paso a paso. Nada del otro mundo: 4 puentes H (son 2 motores), un PIC16F877A, una conexión RS232 para la PC, y un par de cosas más que no vienen al caso.

Probada en el colegio, la placa funciona bien. Puedo controlar la velocidad de los motores, su sentido de giro, etc., todo desde el Hyperterminal de XP.

El problema es cuando lo pruebo en la pc de mi casa.
Cuando está todo conectado y configurado, le doy al reset de mi placa y me aparece el mensaje de arranque de la misma (un "Hola!"), con lo cual, la conexión funciona.

Pero cuando intento enviar los caracteres para el manejo de los motores (D, I, A, etc), la placa no responde a nada que le envíe, es como si no escribiera nada.

Como datos adicionales, mi pc tiene win xp (supongo que es la causa de todo ¬¬! pero no encontré solución, así que no estoy seguro) y uso el com1 para el conexionado.


Al principio dije que este problema se relacionaba con otro. Bueno, el otro problema "parecido" es la conexión con un programador de PIC. Probado en el colegio funciona bien (en el IC Prog, Hardware Check, responde a todos los cambios en los checks boxs), pero en mi pc, el check bx de "Enable VCC" no me da pelota, o sea, el led que tendría que apagar y prender queda siempre prendido.


Leí por varios sitios y hasta este foro situaciones parecidas, de que XP bloquea los puertos, pero probé con varios programas de los que se hablan, diferentes métodos, etc, pero nada.

La otra solución que le veo es la conexión por medio de linux (slackware en mi caso), pero intente entender algo de minicom, y ya que es bastante amplio, termine por resignarme a esa idea por el momento.


Espero respuesta, y mil perdones por escribir tanto, es que sino, se pierden datos.

Desde ya, Gracias ;D
20/11/2007 #2


Hola denuevo.

Al ver que hacía lo que hacía seguía sin funcionar, arreglé una pc vieja que tenía (con win 98) y probé correr las placas ahí.

Al parecer, el programador de pic funciona. O sea, con el hardware check se comprueba que sí, pero no lo he usado todavía por un tema de que, aunque programa el pic, no tengo manera de hacer correr el hard para ver su funcionalidad.

Por otro lado, la placa controladora de los motores paso a paso hace lo mismo que con la pc con XP, es decir, al tocar reset en la placa, la pc recibe el mensaje de arranque que tiene configurado para enviar por RS-232.
Pero si le envío una "D", o una "I" (o en hexa desde el Com Port Toolkit), la placa no hace nada de nada.

Realmente me está matando la intriga de cuál es la causa del problema.

Primero pensé que era Windows XP.
Pasé a Win98 y se solucionó lo del programador de pic.
Pero siguió igual la controladora de los motores, lo cual no creo que sea casualidad.

Algo que noté fue que al tocar el "reset" de la controladora de motores varias veces seguidas, el mensaje de "Hola!" a veces llegaba incompleto ("Hol", o "la!").

Ahora voy a probar haciendo un programa en C, pero no creo que valla a funcionar, aunque esté correctamente programado. Ya que si no lo hice andar con el hyperterminal o el com port, tampoco va a correr mi programa.

También voy a probar levantando una Virtual Machine en XP, simulando win98, a ver si cambia algo.


Cualquier dato que puedan darme será muy apreciado, ya que anda bastante corto de tiempo, y no con muchas ideas para resolverlo.

Gracias.
20/11/2007 #3


a mi me paso que era cuestiones de sincronia, tuve que probar diferentes delays hasta encontrar el adecuado; utilizo WXP
21/11/2007 #4


mabauti dijo:
a mi me paso que era cuestiones de sincronia, tuve que probar diferentes delays hasta encontrar el adecuado; utilizo WXP
A que te refieres con delay? A los bits de stop?
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.