Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

06/11/2012 #41


Ambos... Tengo el circuito ARMADO y al correr el vi de la interfaz me dice que esta desconectado.
Tengo también el driver de este link que también leí que es necesario pero nada.
El administrador de dispositivos de windows me dice que el mejor software para el driver ya esta instalado cuando le doy actualizar.
11/11/2012 #42


djbeatter dijo: Ver Mensaje
Ambos... Tengo el circuito ARMADO y al correr el vi de la interfaz me dice que esta desconectado.
Tengo también el driver de este link que también leí que es necesario pero nada.
El administrador de dispositivos de windows me dice que el mejor software para el driver ya esta instalado cuando le doy actualizar.
amigo ya checaste que la conecxion este bien te reomiendo que chekes en especial el capacitor del VUSB te lo digo porq ami me dio el mismo problema y eso era lo que fayaba, tambien checa tu pin numero 1 del pic es decir el reset checa en el ccs q este configura como hadware y no como software

ami tambien me dio el mismo problema y batalle mucho pero al final solo era el capacitor y que el reset taba configurado como sofware por lo q no ocupa la resistencia aterrizada a 5v checate eso y mas que nada la conexion en el proto,, un saludo

---------- Actualizado después de 3 minutos ----------

mnicolau dijo: Ver Mensaje
En esta ocasión vamos a realizar una interfaz de control y adquisición de datos mediante puerto USB (modo "BULK Transfer") utilizando un PIC 18F2550 (puede usarse cualquier otro con función USB). A través de esta interfaz pueden realizar instrumentación virtual que les permita llevar a cabo el control de procesos externos mediante una PC, registro de datos, etc.

No voy a explicar en detalle cómo funciona la comunicación USB en modo BULK ya que hay mucho información en la web sobre el tema. Este modo se utiliza para la transmisión masiva de información, sin pérdida de datos y sin la necesidad de emular un puerto serie, como hace el modo CDC.

La idea es que puedan tener como ejemplo las distintas posibilidades de entradas y salidas (analógicas y digitales), para luego utilizar tantas como deseen en cada caso en particular. El proyecto que les voy a mostrar a modo de ejemplo presenta:
  • 2 Entradas digitales.
  • 1 Entrada analógica (10 bits).
  • 2 Salidas digitales
  • 1 Salida analógica (PWM + DAC R-C)

El esquema del mismo está incluido en el archivo adjunto y fue realizado en Proteus. Para utilizar mayor cantidad de I/O, sólo es necesario adaptar el firmware siguiendo el ejemplo dado y luego el software de acuerdo a las operaciones a realizar deseadas.

En el adjunto pueden encontrar lo siguiente:
  • Esquema básico del proyecto presentado
  • Driver
  • Firmware
  • Software LabVIEW
  • Software Visual Studio 2010 (C#)

El firmware está escrito en lenguaje C, mediante PICC (CCS) y para el software de control voy a dar 2 ejemplos, uno escrito en C# (Visual Studio 2010) y otro en LabVIEW. Ambos utilizan la dll “mpusbapi” para el control de las funciones del puerto (para LabVIEW se creó un Subvi específico para tal fin) y llevan a cabo las mismas tareas de leer las entradas (digital y analógica); y activar las salidas digitales, además de asignarle un valor al PWM de la salida analógica. Por otro lado, es requerido un driver para que el sistema operativo reconozca la interfaz, el cual también es provisto.

Vista del software de LabVIEW:

http://www.forosdeelectronica.com/at...1&d=1339036263

Vista del software de Visual Studio:

http://www.forosdeelectronica.com/at...1&d=1339036317

BulkUSB_MN (SubVI LabVIEW):

http://www.forosdeelectronica.com/at...1&d=1339036253

Interfaz ejemplo mostrada en este proyecto:

http://www.forosdeelectronica.com/at...1&d=1339036319

Les debo para la próxima el video del funcionamiento (no tengo la cam), todo lo posteado está probado y funcionando correctamente. Espero realicen sus propios proyectos de instrumentación virtual y comenten los resultados.

Saludos!


amigo la verdad te felicito por tu esfuerzo tu proyecto me sirvio de mucha ayuda para relizar mi DAQ ahora el problema es el siguiente realize una libreria como la tuya, USB_BULK_MN pero aun no funciona igual de bien como la tuya la verdad espeor un poco de ayuda de tu parte, tendras algun correo para poderte enviar mi libreria y chekes en que puede estar fayando, aclaro la libreria jala bien pero cuando desconecto el dispositivo ya no la reconoce ocupo detener el programa en labview y resetear el pic y veo que la tuya funciona perfectamente

saludos desde zacatecas mexico
12/11/2012 #43


No me queda claro de lo del pin1, estoy grabando el pic tal y como viene el la programación de ccs,y para lo del reset tengo un push botton para reseater, y pues el capacitor esta como debe... Seguiré intentando y luego explico...
12/11/2012 #44

Avatar de COSMICO

Hola amigo mnicolau.
Muy buen trabajo, se ve de perla.
Tengo un problemilla para simularlo. Mi sistema operativo es XP, y tengo proteus 7.10
Cuando intento simularlo, me pide los driver, pero no me acepta los que alli hay.
Tiene alguna idea de por que?
"los driver los busco en la carpeta drivers de tu aplicacion..
14/11/2012 #45

Avatar de mnicolau

Hola gente, yo también he tenido varios problemas con la simulación, armen el circuito y verán que funciona correctamente la comunicación, está más que probado ya (lo pueden ver en las imágenes del 1º post).

PD: coincido con Gumen, es fundamental el capacitor de 470nF desde el pin "Vusb" a GND.

Saludos
14/11/2012 #46

Avatar de COSMICO

Mi problema, era la version de proteus, instale el 7.6 sp0 y funciono bien.
Los driver de la version 7.10, fallaban.
15/11/2012 #47


oigan no logro instalar el driver, alguien q m diga paso a paso.. Lo k toy aciendo es grabar en el pic el firmware d la interfaz, he copiado a windows,system32 los archivsdl driver y he seleccionad manualment instalar el driver y nada... Auxilio
15/11/2012 #48

Avatar de COSMICO

NO NO no.
Lo que tienes que hacer, es conectar la interfaz fisicamente al laptop a pc, lo que tengas.
Cuando lo reconosca, aparecera una pantalla que pide instalar los drivers; te dara opcion de conectar a internet para buscalos, le marcas no en el momento, siguiente, buscar manualmente, y te diriges a la carpeta donde estan los driver, pinchas sobre la carpeta drivers, le das aceptar y despues siguiente al asistente, y listo el los instalara..
15/11/2012 #49

Avatar de mnicolau

COSMICO dijo: Ver Mensaje
Mi problema, era la version de proteus, instale el 7.6 sp0 y funciono bien.
Los driver de la version 7.10, fallaban.
Gracias por el dato, no conocía ese problema

Saludos
16/11/2012 #50


Ya probé eso y nada. Seguiré probando, por el momento no me funciona aun.
Aunque no logro conseguir el oscilador de cuarzo a 48MHz ni a 20MHz, solo a 4MHz, de hecho la interfaz la modifique a esa pausa.
19/11/2012 #51

Avatar de dinoelectro

djbeatter dijo: Ver Mensaje
Ya probé eso y nada. Seguiré probando, por el momento no me funciona aun.
Aunque no logro conseguir el oscilador de cuarzo a 48MHz ni a 20MHz, solo a 4MHz, de hecho la interfaz la modifique a esa pausa.

puede trabar con 4,8,12,16 o 20MHz.. cristal de 48Mhz no vas a conseguir en ninguna parte

el PLL para 4 es 1
el PLL para 8 es 2
el PLL para 12 es 3
el PLL para 16 es 4
el PLL para 20 es 5
20/11/2012 #52


ya logre solucionar mi problema con al librería una pregunta amigo, ¿con cuantas entradas análogas al mismo tiempo has probado tu programa? porque conmigo la verdad al leer 5 entradas se hace medio lento dependiendo de la computadora.
21/11/2012 #53

Avatar de mnicolau

Estás simulando la interfaz? Si es así está claro que va a andar cada vez más lento mientras más elementos agregues.

Saludos
21/11/2012 #54


No amigo ya lo tengo hasta en tarjeta, pero al momento de leer una entrada anda bien, pero al conectarle ya 5 entradas y graficarlas se hace algo lento, ¿a que crees que se deba o es algo natural? oye otra duda más. ¿se podrá poner un filtro en labview? ya que mi señal entra con un poco de ruido y la ocupo muy fina, Gracias.
26/11/2012 #55

Avatar de gerardots

buen dia acabo de encontrar tu tema y me interesa desarrollarlo, pero tengo un problema, mi version de labview es 8.5 no me puedes guerdar el vi en esta version. Te lo agradezco de antemano. Saludos
28/11/2012 #56

Avatar de mnicolau

Buen día Gerardo, te adjunto para la versión 8.5.

GNM, subí el programa así lo reviso.

Saludos
Archivos Adjuntos
Tipo de Archivo: rar Control Interfaz USB - Modo BULK (8.5).rar (67,2 KB (Kilobytes), 198 visitas)
28/11/2012 #57

Avatar de gerardots

Te lo agradesco mnicolau realizare pruebas y cualquier cosa comento, saludos desde mexico!.
02/12/2012 #58


mnicolau dijo: Ver Mensaje
Buen día Gerardo, te adjunto para la versión 8.5.

GNM, subí el programa así lo reviso.

Saludos
Saludos mnicolau gracias ya resolvi el problema que tenia y pues solo era la computadora que traia un procesador muy chafa pero al ponerla en una normal jalo perfectamente.... te comento que estoy aciendo un brazo robotico con labview mediante comunicacion bulk... la idea es esta controlar 5 o 6 servos con PWM mediante software, gracias a la libreria de dinoelectrico eh podido tener avances y ya puedo controlas 8 salidas pwm desde labview el problema es la frecuencia los calculos tienen que ser exactos porque los servos son muy delicados tu no te sabes las formulas para calcular PWM por software mediante ccs?? o que conoscas algun metodo para complementar lo anterior??

Pic18f2550
cristal a 20Mhz
pero con el PLL a 48Mhz

Frecuencia deseada 50hz por cada PWM


GRACIAS
04/12/2012 #59


GNM dijo: Ver Mensaje
Saludos mnicolau gracias ya resolvi el problema que tenia y pues solo era la computadora que traia un procesador muy chafa pero al ponerla en una normal jalo perfectamente....

Pic18f2550
cristal a 20Mhz
pero con el PLL a 48Mhz

Frecuencia deseada 50hz por cada PWM


GRACIAS
¿Que tal GNM?.. Oie podrias adjuntar tu archivo, es que no he podido añadirle mas salidas analogicas.. Un saludo y de antemano gracias
24/12/2012 #60


hola muy buen proyecto,quisiera saver si me puedes ayudar lo que pasa es que tengo un problema ala hora de ejecutar la simulacion en el labview me dice interfaz no encontrada no se si puedas ayudarme con eso.gracias de antemano.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.