Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

03/08/2015 #41


Gracias por responder Locodelafonola, esta es la interfaz que construí, espero me puedan colaborar.



03/08/2015 #42

Avatar de locodelafonola

hola night
Niht dijo: Ver Mensaje
Gracias por responder Locodelafonola, esta es la interfaz que construí, espero me puedan colaborar.

http://nsae02.casimages.net/img/2015...2550484047.jpg

http://nsae02.casimages.net/img/2015...2553503063.jpg
Bueno por lo que puedo ver ., esta mal conectado o sea faltan contactos
esto es una interfaz bidireccional ., ¿¿¿¿¿ que es bidireccional ?????
es una adaptador de USB a 485 (seria de la computadora a la linea 485 o conexion canon)
pero tambien es un conversor de 485 a USB
lo que puede estar pasando es que no se cumple el protocolo de recepcion
y una aclaracion a todos ., EN DMX el protocolo 512 (tenga o no tenga RDM) !!!!! TRANSMITE y RECIBE ¡¡¡¡ es bidireccional
lo que vamos a hacer es que copies este esquema (conexiones)
guiate por la numeracion de las patillas de los CI
aparte al 76175 le faltan los capaciotores ceramicos de desacoplo entre positivo (5v y GND) pin8 del 76175 ., que se muestra en el esquematico
otra cosa que deberas hacer es seguir el circuito en la placa roja y fijarte que no valla a conectarce nada de como esta el esquema
como por ejemplo el pin 17 (3,3v) va un capacitor ceramico a gnd y ese pin no se conecta a nada
veo tambien que hay mas conponentes SMD en el lado de USB (mini)
en ese esquema si te fijas hay una bobina , L1
bueno esa bobina yo no la consegui y no la coloque (pero no he tenido problemas hasta ahora ) aca te subo un esquema igual pero mas claro
prestale atencion ala coneccion del USB ., y todo lo que no este alli se lo sacas o corta pistas de la placa
tambien veo que al 76175 le pusiste una recistencia (no va ninguna ) bajas el nivel de la señal., va solo a su salida ente D+ y D- (120 Ω)
bueno espero que te alla guiado un poco y te muestro la fotos de la mia
NOTA: en la mia hay dos resistencias serca del la canon ., bueno es porque yo programe mi FTDI ., y tiene señalizacon de RDM ¡¡¡¡¡¡ ojo no es igual su funcionamiento ¡¡¡¡¡ pero lo era en su principo
05/08/2015 #43


Gracias locodelafonola me pondré manos a la obra y haré las correcciones pertinentes, ya estaré comentándoles como me fue.
05/08/2015 #44

Avatar de locodelafonola

hola
Niht dijo: Ver Mensaje
Gracias locodelafonola me pondré manos a la obra y haré las correcciones pertinentes, ya estaré comentándoles como me fue.
sip .,seria importante que contaras como te fue (y mostrarlo )., porque ese modulo le trae dolores de cabeza a todos (no solo a vos)
18/08/2015 #45


Buenos días compañeros del foro, hasta este fin de semana pude hacer la pruebas después de hacer los cambios sugeridos por locodelafonola.
Removí todos los componentes SMD de la tarjeta solo deje los condensadores del circuido el del pin 3v3out y el del v+ del usb en el 76175 puse los condensadores de desacoplo y la resistencia de salida de 120 ohm.
Ahora paso a contar jejeje la interfaz "funciona" ¡pero! sigo con los cortes esta vez con una diferencia, ya no se bloquea la interfaz el programa y el puerto COM siguen trabajando solo se corta la comunicación por unos segundos y retoma de nuevo. En la acción tengo unos par led haciendo unas secuencias y de un momento a otro se apagan duran cuatro a cinco segundos y vuelven a hacer las secuencias como si nada y así de vez en cuando. ¿que mas podría hacer?

locodelafonola hablo de haber programado su FTDI "no sabia que se hiciera eso" estuve investigando y descargue el FT_PROG quise cambiar la descripción de producto, le di programar y según el programa todo estaba bien pero al reconectar el dispositivo no tiene los cambios, ¡no guarda los cambios que uno haga! es como si la eeprom estuviera bloqueada.
18/08/2015 #46

Avatar de locodelafonola

hola
Niht dijo: Ver Mensaje
Buenos días compañeros del foro, hasta este fin de semana pude hacer la pruebas después de hacer los cambios sugeridos por locodelafonola.
Removí todos los componentes SMD de la tarjeta solo deje los condensadores del circuido el del pin 3v3out y el del v+ del usb en el 76175 puse los condensadores de desacoplo y la resistencia de salida de 120 ohm.
Ahora paso a contar jejeje la interfaz "funciona" ¡pero! sigo con los cortes esta vez con una diferencia, ya no se bloquea la interfaz el programa y el puerto COM siguen trabajando solo se corta la comunicación por unos segundos y retoma de nuevo. En la acción tengo unos par led haciendo unas secuencias y de un momento a otro se apagan duran cuatro a cinco segundos y vuelven a hacer las secuencias como si nada y así de vez en cuando. ¿que mas podría hacer?

locodelafonola hablo de haber programado su FTDI "no sabia que se hiciera eso" estuve investigando y descargue el FT_PROG quise cambiar la descripción de producto, le di programar y según el programa todo estaba bien pero al reconectar el dispositivo no tiene los cambios, ¡no guarda los cambios que uno haga! es como si la eeprom estuviera bloqueada.
!!!!! ojo ¡¡¡¡ con eso porque vas a inutilizar el chip., yo porque utilizo librerias con RDM
bueno eso que hace es que., da la espera de la trama., como lo configuraste ahora es mas rapido
lo que podemos probar ahora es el driver ., desintala el que tenes ., limpia los archivos que queden (con CCleaner ) luego de que reinicies carga este driver que te subo y despues vemos que hace
NOTA : reconfiguraste la entrada y habilitacion del 76175 como esta en el esquema ., ojo que los pin 2 y 3 no van a gnd ., van al pin 13 del ftdi
Archivos Adjuntos
Tipo de Archivo: rar CDM20828_Setup.rar (1,82 MB (Megabytes), 59 visitas)
18/08/2015 #47


Locodelafonola hice las pruebas con el driver que me diste y volvimos al problema de bloqueo general, hay que reconectar la interfaz para que el programa la vuelva a detectar y trabaje. creo que descartamos esa opción.
18/08/2015 #48

Avatar de locodelafonola

bueno vamos por partes
Niht dijo: Ver Mensaje
Locodelafonola hice las pruebas con el driver que me diste y volvimos al problema de bloqueo general, hay que reconectar la interfaz para que el programa la vuelva a detectar y trabaje. creo que descartamos esa opción.
por empezar cuando miras los programas instalados(instalar y desintalar programas en W7)., tambien los ves en el CCleaner ., opcion herramientas
te aparese los driver y la interfaz ., como aqui
lo otro que me tenes que decir ., es que programa estas usando ., y cuales la configracion dentro del programa
tampoco me comentaste si el 76175 ., lo configuraste como yo te dije y segun el esquema
Imágenes Adjuntas
Tipo de Archivo: jpg capture_08182015_190019.jpg (49,0 KB (Kilobytes), 285 visitas)
19/08/2015 #49


Buenas tardes locodelafonola, revise en programas y características y me aparece tal como dices los dos instalados, yo uso para probar el freestyler y el DMX512 Light Control, en freestyler lo configuro como la enttec open dmx y en FTDI device aparece la F232R USB UART asi lo tengo, el DMX512 Light Control solo la detecta y ya no trae configuracion. En cuanto al 76175 esta como lo indicaste pines 2 y 3 al 13 del ftdi.
19/08/2015 #50

Avatar de locodelafonola

hola
Niht dijo: Ver Mensaje
Buenas tardes locodelafonola, revise en programas y características y me aparece tal como dices los dos instalados, yo uso para probar el freestyler y el DMX512 Light Control, en freestyler lo configuro como la enttec open dmx y en FTDI device aparece la F232R USB UART asi lo tengo, el DMX512 Light Control solo la detecta y ya no trae configuracion. En cuanto al 76175 esta como lo indicaste pines 2 y 3 al 13 del ftdi.
bueno entonces vamos a hacer una cosa
aca te subo un "limpiador" que borra los archivos de las instalaciones defectuosas
primero pasas ese (interfaz enchufada)., y luego (con la interfaz enchufada) instalas el driver que te pase
y comentame como te
Archivos Adjuntos
Tipo de Archivo: rar FTClean.rar (803,2 KB (Kilobytes), 35 visitas)
20/08/2015 #51


buenos días, locodelafonola por poco y me ilusiono jeje hice lo que me dijiste pase el limpiador y reinstale el controlador, pero volvemos a lo mismo, digo que me ilusiono por que duro un poco mas de tiempo antes de dejar de transmitir jejeje pero sigue igual cuando menos piensas solo deja de transmitir.
Conseguí un equipo con Xp y realice las pruebas pero tengo el mismo problema.
estoy por pensar que es algún problema con el FTDI.
¿que otra cosa se te ocurre locodelafonola? de antemano te agradezco toda la buena intención que has tenido de ayudarme a solucionar el problema.
20/08/2015 #52

Avatar de locodelafonola

hola
Niht dijo: Ver Mensaje
buenos días, locodelafonola por poco y me ilusiono jeje hice lo que me dijiste pase el limpiador y reinstale el controlador, pero volvemos a lo mismo, digo que me ilusiono por que duro un poco mas de tiempo antes de dejar de transmitir jejeje pero sigue igual cuando menos piensas solo deja de transmitir.
Conseguí un equipo con Xp y realice las pruebas pero tengo el mismo problema.
estoy por pensar que es algún problema con el FTDI.
¿que otra cosa se te ocurre locodelafonola? de antemano te agradezco toda la buena intención que has tenido de ayudarme a solucionar el problema.
bueno ., yo lo dije desde el principio
esos modulos son un dolor de cabeza ., por eso recomende ., muchas veces ., NO LOS USEN en DMX
ahora bien (teoricamente) si no "sufrio" ., ninguna re-programacion interna .,(porque se usa para otros protocolos tambien como ya explique )
tendria que funcionar., como que inicia., busca la trama ., la encuentra ., pero no envia el ok a la compu
entoces desabilita., y es alli donde corta
explicame con que equipo lo probas y de que manera (eso tambien influye ) !!! ojo ¡¡¡
tambien puede influir (de acuerdo ala electronica que se use) ., la coneccion correcta de D+ y D-
y atencion con esto porque tiene que ser correcta desde la salida de la interfaz ., hasta la coneccion del ultimo equipo de la cadena
una mala soldadura ., o la invercion de D+ y D- ., ya larga error (y es correcto que sea asi ., aunque algunos no les guste)
trata de revisar la electronica (poneme fotos de como quedo ., bien detalladas) a ver si veo algo que se te escapa
fijate bien lo de las conecciones a los equipos ( por eso los conectores canon tiene numero de pin )
y veremos que se puede hacer ., no me molesta ayudar ( lo hicieron !!!! y hacen conmigo ¡¡¡ )
25/08/2015 #53


Buenas nuevas a todos, después de venir con dolores de cabeza "como dijo locodelafonola" a causa de la interfaz USB-DMX y en una de esas búsquedas desesperadas por google me tope con un foro Alemán en el cual tenían el mismo problema y daban una posible solución que era la siguiente:

* Poner un condensador de 330uf en la entrada V+ del FTDI, para prevenir bloqueos a causa de una caída de voltaje del puerto USB del PC.

* Poner una resistencia de 1k en el pin RESET del FTDI, para mantenerlo en 1

* Poner condensadores de 100nf en V+ del SN76175 (estos están en el plano de locodelafonola)

y estaban estos driver que trabajan en windows 7 y 8 32 y 64 bits

Driver X32 X64 USB DMX FTDI Interface.rar

De lo aquí dicho yo lo único que probé es el condensador de 330uf en v+ del FTDI y los driver, no quiero cantar victoria aun pues la interfaz con este modulo es engañoso jejeje pero hasta el momento e tenido estabilidad, trabajando en Windows 7 con freestyler nada de cuelgues "tuve uno después de 6 horas y media" pero solo ese .

estas son las fotos del modulo, esta configurado con el esquema de locodelafonola.









como dije seguiré haciendo pruebas antes de cantar victoria, de momento funcionando.
25/08/2015 #54

Avatar de J2C

.



Niht

Niht dijo: Ver Mensaje
....... * Poner condensadores de 100nf en V+ del SN76175 (estos están en el plano de locodelafonola) .......
Ese condensador de 100 nF (=.1 µF) se debe colocar siempre entre + y - de cada integrado y con las conexiones mas cortas que sean posible cuando se trabaja con integrados en forma digital no importando si son TTL, CMOS, etc.

Parecerá algo innecesario para nosotros pero si uno lee las datasheet's de los integrados siempre lo indican !!!!.




Saludos, JuanKa.-
25/08/2015 #55

Avatar de locodelafonola

Niht dijo: Ver Mensaje
Buenas nuevas a todos, después de venir con dolores de cabeza "como dijo locodelafonola" a causa de la interfaz USB-DMX y en una de esas búsquedas desesperadas por google me tope con un foro Alemán en el cual tenían el mismo problema y daban una posible solución que era la siguiente:

* Poner un condensador de 330uf en la entrada V+ del FTDI, para prevenir bloqueos a causa de una caída de voltaje del puerto USB del PC.

* Poner una resistencia de 1k en el pin RESET del FTDI, para mantenerlo en 1

* Poner condensadores de 100nf en V+ del SN76175 (estos están en el plano de locodelafonola)

y estaban estos driver que trabajan en windows 7 y 8 32 y 64 bits

Archivo Adjunto 133826

De lo aquí dicho yo lo único que probé es el condensador de 330uf en v+ del FTDI y los driver, no quiero cantar victoria aun pues la interfaz con este modulo es engañoso jejeje pero hasta el momento e tenido estabilidad, trabajando en Windows 7 con freestyler nada de cuelgues "tuve uno después de 6 horas y media" pero solo ese .

estas son las fotos del modulo, esta configurado con el esquema de locodelafonola.

http://fdzeta.com/subir/images/3CKj7.jpg

http://fdzeta.com/subir/images/hT1iV.jpg

http://fdzeta.com/subir/images/kc1WY.jpg

http://fdzeta.com/subir/images/2vJ3W.jpg

como dije seguiré haciendo pruebas antes de cantar victoria, de momento funcionando.
!!!!!! Bien amigaso niht ¡¡¡¡¡¡
muy bueno lo tuyo ., asi queda en el foro ., fijate que no sos el unico que le "dolio la cabeza" con esos modulos
Yo le escapo ., de usar la interfaz con una portatil (aunque la uso de vez en cuando ., con una de esas de conectar igualdad)
y no te imaginas la alegria que tengo ., que hay otro integante del foro que usa DMX ., y que se que estas programando tambien
El driver que te pasaron ., es el mismo que yo te pase (vi el INF) y te digo que con ese no he tenido problemas
Cualquier cosa estoy a tu disposicion ., me mandas un "misil " privado ., o apuntame en el post ., y alli estare !!!!!
Hola amigo
J2C dijo: Ver Mensaje
.



Niht



Ese condensador de 100 nF (=.1 µF) se debe colocar siempre entre + y - de cada integrado y con las conexiones mas cortas que sean posible cuando se trabaja con integrados en forma digital no importando si son TTL, CMOS, etc.

Parecerá algo innecesario para nosotros pero si uno lee las datasheet's de los integrados siempre lo indican !!!!.




Saludos, JuanKa.-
sip ., eso siempre lo tengo precente .,y es muy cierto lo que desis ., lo apendi en el foro
25/08/2015 #56

Avatar de J2C

.


Don Rosit0 se que Ud. lo tiene presente, solo trate que le quede clarísimo al otro forista !!!!.


Aparte vi que casi se pelea Ud. con un español, My God !!!, Mon Dieu !!!!.



Saludos, JuanKa.-
25/08/2015 #57

Avatar de locodelafonola

J2C dijo: Ver Mensaje
.


Don Rosit0 se que Ud. lo tiene presente, solo trate que le quede clarísimo al otro forista !!!!.


Aparte vi que casi se pelea Ud. con un español, My God !!!, Mon Dieu !!!!.



Saludos, JuanKa.-
AAAAAAAAAAAAAAAAAAAA ssssssssiiiii ., lo que pasa es que esa la conosco bien ., hice algo de eso
con los laser que tengo ., y que no son chiquitos ., pero de poder se puede
Aunque funciono perfectamente ., no se pudo aplicar por cuestiones mecanicas ., no electronicas jejejejejejejejeje
En cuanto a los capacitores ., si se lo dije en algunos mensajes mas atras
Ahora ese modulo con el capacitor tan grande ., ( en la mia no podria ponerlo) es imposible A menos que sea ., con cables por afuera y atado con cinta aisladorara a la ficha canon JAJAJAJAJAJA
22/10/2015 #58


Solicito su ayuda
buen dia escribo esperando que me puedan ayudar, soy de venezuela, viendo este tema de post decidi adquirir los componentes para realizar mi placa dmx, en Mercadolibre me consegui este y lo compre. (previamente pregunte por aca si servia y me respondieron que si)

Ok este aparentemente ya viene listo unicamente para soldarle el conector hembra canon. Eso hice y el freestyler lo reconoce, los led tx y rx titilan, el led del par led que estoy usando tambien titila pero no responde. Simplemente el par led no hace nada, o a veces enciende erraticamente.

Quisiera su opinion de que puedo estar haciendo mal. Gracias.
Imágenes Adjuntas
Tipo de Archivo: jpg 0012.jpg (40,2 KB (Kilobytes), 73 visitas)
Tipo de Archivo: jpg 20151022_165701.jpg (65,9 KB (Kilobytes), 66 visitas)
Tipo de Archivo: jpg 20151022_165713.jpg (46,9 KB (Kilobytes), 62 visitas)
Tipo de Archivo: jpg 20151022_165719.jpg (47,9 KB (Kilobytes), 60 visitas)
Tipo de Archivo: jpg 20151022_165723.jpg (63,9 KB (Kilobytes), 60 visitas)
22/10/2015 #59

Avatar de locodelafonola

hola
djpcg dijo: Ver Mensaje
buen dia escribo esperando que me puedan ayudar, soy de venezuela, viendo este tema de post decidi adquirir los componentes para realizar mi placa dmx, en Mercadolibre me consegui este y lo compre. (previamente pregunte por aca si servia y me respondieron que si)

Ok este aparentemente ya viene listo unicamente para soldarle el conector hembra canon. Eso hice y el freestyler lo reconoce, los led tx y rx titilan, el led del par led que estoy usando tambien titila pero no responde. Simplemente el par led no hace nada, o a veces enciende erraticamente.

Quisiera su opinion de que puedo estar haciendo mal. Gracias.
Primero y principal ., si estas usando una PC portatil ., es seguro que tengas problemas
Segundo ., en el listado de los driver ¿¿¿ figura la instalacion del mismo ???
Tercero ., ¿¿¿ creaste con el freestyler .,el perfil del equipo ???? (
Cuarto ., no mostras tampoco el setup ., del equipo que usas (par led)
Quinto ., si es posible ., prende una vela y empeza a rezar ., tal vez el milagro ocurra y funcione
Sexto ., mostra una captura de pantalla del freestyler de la parte de del setup ADD/REMOVE FIXTURE
Septimo ., tambien estaria bueno ver que hace el equipo ., eso de los destellos que comentas (un video al menos) ., 3gp comprimido en .RAR
Imágenes Adjuntas
Tipo de Archivo: jpg capture_10222015_200338.jpg (87,4 KB (Kilobytes), 226 visitas)
26/12/2015 #60


Estimados, primero que todo me presento, soy de Chile aficionado a la electrónica desde muy pequeño conforme pasan los años todo se ha ido siendo aun mas y mas pequeño y entretenido....

por razones de estudio estuve varios años alejado de la electrónica... hasta que hace poco escuche la palabra arduino ... arduino... como soy curioso decidí probar suerte me compre una placa " uno r3 " y estoy feliz de echo me acabo de comprar una nano v3.... eh podido programar casi todo lo que me he propuesto, es mas he podido también modificar el codigo variando la informacion por ej que me muestra en las pantallas lcd que tengo y así... soy un aficionado pero amante de la electrónica.

EL motivo por el cual les escribo por que siempre me gusto la iluminación... me compre unos focos par led 36x1 dmx... y buscando vi que podía ahorrar dinero armándolo yo mismo un controlador dmx utilizando mi pc.... y así fue después de mucho ensayo y error logre hacerlo funcionar, utilizando un conversor usb a ttl( foto modulo en uso )y un ic sn75176... la conexión que estoy usando es ( foto conexión actual ) , uso el freestyler entec open dmx y funciona perfecto, pero por tiempos muy muy cortos aveces otras veces mas estable pero no mas de 1 minuto...

pero como no todo puede ser perfecto, tengo el mismo problema que " niht ". logra funcionar pero creo que lo mas estable que ha estado son 45 seg luego se cuelga...

mi consulta es la siguiente, he visto en algunas paginas por ahi una interface en la cual el puerto usb incorpora el modulo ttl y solo de esta salen 4 cables... tal como la que utiliza este proyecto, (foto modulo 2 ) y la otra opción que también eh visto es ( foto variante 1 )

sera esa la solución a todos los problemas utilizar ese modulo y así poder conseguir estabilidad en la conexión ??


bueno es por el momento espero me puedan ayudar... saludos !!!
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.