Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

22/11/2012 #1


problema con interrupcion rda
hola que tal, estoy en un trabajando en un proyecto de microcontroladores solamente como pasatiempo, y me he topado con un poblema que es pero y me puedan ayudar, y es el siguiente, hoy usando moduos de rf, para comunicar dos pic's, o cual ya he logrado y hasta lo he montado en fisico para comprobar, claro fue un programa sencillo de encendido de un led.

El problema se presenta cuando el mismo codigo que ya probe lo introduzco en un progrma mas complejo, por medio de la interrupcion rda, y se me presneta que cuando yo mandalo la señal de transmisor esta llega al receptor y me ejecuta correctamente el progrma que tengo que lo cual hace encender 4 led's y los hace parpadear, esto lo hago con timer0 y desabilito el interrupcion rda, y para apagarlos presiono un boton el cual esta siendo monitoreado por un while(true) cuando este valga uno se desactivan las interrupciones y regresa al inicio.

Pero si presiono el boton del transmisor nuevamente este ya no hace nada, y se supone que tiene que iniciar el programa del parpadeo de led's nuevamente. Asi que la pregunta es que puede estar pasando para que no funciones posteriormente despues de que ya se activo una vez.

Espero y me puedan ayudar.
22/11/2012 #2


Buenas, estaría bien que subieses el código para que la gente vea donde puede estar el fallo.

Un saludo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.