Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

01/03/2016 #1


proyecto de funcionamiento motor paso a paso con SAA1042
Hola a todos. Hoy me incorporo a este foro y me gustaría mandaros a todos mi mas cordial saludo.

Os hago llegar este mensaje, porque estoy realizando un proyecto, que uno de las partes es el funcionamiento de un motor paso a paso mediante el circuito SAA1042. Para ello estamos simulando las señales para ponerlo en marcha. Pin 11 +5v., pin 9 GND. Pin 6 una resistencia de 56K a masa. Un diodo zener de 3,9v entre pin 2(catodo) y pin 15 (anodo). +12v. pin 15. Conexionado del motor en los pines 1 y 3, 16 y 14. pines 10 y 8 (a +5v y GND) para simular que el motor funciones en full/half (pin 8) y CCW/CW (pin 10). Y mediante un circuito NE555 en montaje astable para tener una onda cuadrada conectada al pin 7. Pero no conseguimos hacer funcionar el motor. No sabemos si se nos pasa algo. Quizas la frecuencia del NE555.

Agraceceriamos una indicación para solucionar este problema.

Un Saludo
01/03/2016 #2
Moderador general

Avatar de Fogonazo

Prueba conectar la resistencia de 56kΩ a Vcc
01/03/2016 #3


gracias, a ver que ocurre
02/03/2016 #4


Esto no va. acabo de tomar medidas con el osciloscopio sobre las patillas del SAA1042. Y no me salen las cuentas. A la patilla 7 de clock le llega la señal del NE555, pero el nivel de la señal es de 3,2 voltios mas o menos. En la patilla 15 tengo 12v. y en la patilla 2 tengo una señal cuadrada de la misma frecuencia que la del pin 7 pero con casi 4v. de pico. si pongo el zener de 3,9v. entre el pin 2 y 15, es como si el zener fuera un corto, tengo los 12v. también en el pin 2 y 15. En el pin 6 si quito la resistencia de 56 k y mido tengo 12 voltios también.

No me suena nada, puede ser que se haya roto el SAA1042..

Acepto sugerencias.

Gracias
03/03/2016 #5

Avatar de albertoxx

Puede ser la frecuencia, tu fuente de poder de 12V no es suficiente, tu 555 no esta bien armado;
Revisa primero la parte logica sin el SAA1042 o puedes probar al revez solo el SAA1042 yo cuando los pruebo uso un botoncito para step a ver si asi se oye que empieza a girar la mayoria son 200 pasos por vuelta
03/03/2016 #6

Avatar de John Miller

Hola buen día este diagrama funciona excelente, mira y compara a lo mejor algo tienes mal, sin diagrama es difícil saber que tienes mal.



MK.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.