Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

01/08/2006 #1


puerto paralelo que funciona a 3.3v ??
hola

estoy intentando hacer el control de un dispositivo por puerto paralelo, soy principiante en este tema pero me resulta muy interesante.

la cuestion es que al medir el voltaje de salida de los pines D0 al D7 es de 3.3 voltios y yo tenia entendido que era de 5v, mi computadora no es muy vieja, la compre hace un año.

lei por ahi que hay q cambiar un pin en la placa madre para tener voltaje de 5v, pero no se exactamente donde ni como hacer esto

si alguien sabe como resolver esto porfavor ayudeme

gracias
01/08/2006 #2


Re: puerto paralelo que funciona a 3.3v ??
El pin que dices se llama jumper,tenes o buscastes si tenes el plano de la motherboard?
02/08/2006 #3
Moderador

Avatar de Nilfred

Si el control de dispositivo lo tenes que fabricar, reemplaza las resistencias que encienden los optos por una de menor valor para que la corriente en el led alcance para encenderlo.
Ejemplo: El MOC3041 requiere entre 15mA y 60mA, para 3.3v va una resistencia de 130 Ohm o menor. Si conectas a otra PC con 5v la corriente asciende a 28mA, el LED enciende igual y queda por debajo del límite máximo de 60mA.
130 Ohm es un valor comercial, pero soy consciente que por ahi no suele haber, cualquiera de estas te sirve en orden de preferencia:
130, 120, 110, 100, 91, 82, 75, 68, 62
02/08/2006 #4


si es de 3.3v diria que es un portatil ...

el MOC3041 es un opto triac mejor usa un 4N27
02/08/2006 #5
Moderador

Avatar de Nilfred

Existen ultimamente en el mercado varias placas madre de PC de escritorio con micros de portátiles, es la onda verde.

¿Y que carajo es un 4N27? :p
Andá saber que está queriendo controlar con su PC, pero se aplica lo mismo (corregime si me equivoco):
El LED del 4N27 es de 1.5v 60mA/100mA max según el color del encapsulado y enciende con 5mA por lo que dedusco del gráfico.
Con eso controlas 30V 250mW

No viene igual al caso, ya que aparentemente el circuito lo tiene visto, habría que ver que opto esta usando/por usar y calcular las resistencias para 3,3v en vez de 5v
02/08/2006 #6

Avatar de EinSoldiatGott

Nilfred dijo:
Existen ultimamente en el mercado varias placas madre de PC de escritorio con micros de portátiles, es la onda verde.

¿Y que carajo es un 4N27? :p
Andá saber que está queriendo controlar con su PC, pero se aplica lo mismo (corregime si me equivoco):
El LED del 4N27 es de 1.5v 60mA/100mA max según el color del encapsulado y enciende con 5mA por lo que dedusco del gráfico.
Con eso controlas 30V 250mW

No viene igual al caso, ya que aparentemente el circuito lo tiene visto, habría que ver que opto esta usando/por usar y calcular las resistencias para 3,3v en vez de 5v
Hola, yo trabajé con una pc que también daba 3...V, y no hay ningún problema, no modifiqué nada de la pb pues la pc no era mía, simplemente utilicé resistencia de bajor valor como le comentaron antes creo que use 270 y todo perfecto tanto con moc3010 como con opto 4n26.

Ahora si no va usar ni mocs ni optos, tampoco hay problema pero sería mejor usarlos por simple precaución.

Moveré este tema a Intefáses y programación.

Saludos
02/08/2006 #7


hola

gracias por sus respuestas, buscare el esquema de mi placa madre y lo posteare mas tarde.

la idea es controlar un motor que funciona a 220v CA , la idea para controlarlo la saque de un tutorial de este foro, pieso hacerlo asi como muestra la imagen



suponiendo que trabaje con mi puero a 3.3v que le modifico para que funcione al circuito?
o debo usar otra cosa para controlar el motor?

gracias
02/08/2006 #8

Avatar de EinSoldiatGott

alvarog423 dijo:
hola

gracias por sus respuestas, buscare el esquema de mi placa madre y lo posteare mas tarde.

la idea es controlar un motor que funciona a 220v CA , la idea para controlarlo la saque de un tutorial de este foro, pieso hacerlo asi como muestra la imagen



suponiendo que trabaje con mi puero a 3.3v que le modifico para que funcione al circuito?
o debo usar otra cosa para controlar el motor?

gracias
Lol, esa imágen es mía , baje la resistencia a unos 270, la intensidad sería I=3.3/270=12mA

Deje la resistencia a 560, estoy casi seguro que funcionará bien son casi 6mA, entre menos corriente le pida al puerto hay menos probabilidad de quemarlo.

Si no quiere encender ponga una de 270 .

Saludos cualquier otra duda nos avisa
02/08/2006 #9


holas

a ver si entendi la resistencia 2 la pongo a 270 y la resistencia 1 la dejo como esta, si no enciende cambio la resistencia 1 por una de 270 ??

vi en algunas paginas q a este circuito le agregan un fusible por seguridad, deberia agregar uno? cual es su funcion?

gracias
02/08/2006 #10

Avatar de EinSoldiatGott

alvarog423 dijo:
holas

a ver si entendi la resistencia 2 la pongo a 270 y la resistencia 1 la dejo como esta, si no enciende cambio la resistencia 1 por una de 270 ??

vi en algunas paginas q a este circuito le agregan un fusible por seguridad, deberia agregar uno? cual es su funcion?

gracias
R2 se queda tal cuál 220.

Estaba leyendo el datasheet del moc 3010 http://pdf1.alldatasheet.com/datashe...A/MOC3010.html

Y dice que ocupa 15mA el led para hacer el trigger.

Entonces 3.3v R=V/I R=3.3/15mA=220

Si r1 la pone de 220 el moc enciende perfecto, el único detalle es que casi estamos llegando al máximo de la corriente que el puerto no spuede proprocionar 20 mA.

Así que yo le sugerí poner una de valor mayor, puede probar con 470 o 560 si funciona con esos valores perfecto así no arriesgamos el puerto.

Si el moc no quiere encender peus ya le pone la de 220 en R1.

El fusible es por seguridad, si quiere peude agregar uno en serie con la resistencia, de menos de 20mA, sirve para que si pasan más del valor del fusible, este se queme y ya no fluya más corriente y el puerto no se queme

Saludos
02/08/2006 #11


ok, lo intentare

gracias
02/08/2006 #12


holas

fui a comprar los componentes, encontre el MOC, pero no pude conseguir el triac que aparece en la figura (TIC225S) y me dieron uno equivalente (weno, eso me dijo el vendedor)
lo que aparece en el triac es esto : MEKSE BT136 600E

puedo usarlo en reemplazo del TIC225S?

gracias
02/08/2006 #13


probe el circuito con el nuevo triac, funciona bien

tengo otra pregunta, si mi puerto paralelo trabaja con 3.3v la salida (D0-D7) si quiero mandar datos al puerto desde el dispositivo los mando a 3.3v? o a 5v ?
03/08/2006 #14

Avatar de EinSoldiatGott

alvarog423 dijo:
probe el circuito con el nuevo triac, funciona bien

tengo otra pregunta, si mi puerto paralelo trabaja con 3.3v la salida (D0-D7) si quiero mandar datos al puerto desde el dispositivo los mando a 3.3v? o a 5v ?
Primero debe saber si su puerto es bidireccional.

En caso de serlo, no ocupa meterle voltaje, simplemente conecta el pin a tierra con una resistencia de 4.7k y recibe un 1 lógico.

EN los puertos nuevos no se ocupa la resistencia yo lo hice sin resistencia y no paso nada

Saludos
03/08/2006 #15


como se si mi puerto es bidireccional?

lo q quiero hacer es enviar un 1 logico cuando se cierre el contacto de un sensor.
03/08/2006 #16

Avatar de EinSoldiatGott

alvarog423 dijo:
como se si mi puerto es bidireccional?

lo q quiero hacer es enviar un 1 logico cuando se cierre el contacto de un sensor.
Es que yo le entendí que quería leer con el mismo bus de datos.

El puerto paralelo tiene 8 pines de datos, si su puerto es bidireccional, con esos 8 pine spuede leer y escribir.

Si no lo es, para leer solo tiene 5 pines que no recuerdo que npumero son .

Si quiere que su pc este leyendo un sensor? o el sensor es activado desde el PC?

Cheque este link

http://www.pablin.com.ar/electron/in.../lpt/index.htm

Saludos
03/08/2006 #17


holas

el sensor detecta un nivel bajo de liquido en un recipiente, al detectarlo manda un 1 logico al pc por el puerto, en la parte de la programacion (lo hare en visual C++ ) hare un programa q lanza un proceso q correra siempre (demonio) en espera de algun mensaje del sensor, cuando lo detecte dara la alerta

la parte de la programacion no es problema, solo quiero saber si al enviar la señal y el puerto la detecte como 1 logico esta tiene q ser de 5v? o de 3.3v? me da miedo mandar 5v y quemar el puerto, ya q por el titulo del tema mi puerto envia señales a 3.3v

gracias
03/08/2006 #18

Avatar de EinSoldiatGott

alvarog423 dijo:
holas

el sensor detecta un nivel bajo de liquido en un recipiente, al detectarlo manda un 1 logico al pc por el puerto, en la parte de la programacion (lo hare en visual C++ ) hare un programa q lanza un proceso q correra siempre (demonio) en espera de algun mensaje del sensor, cuando lo detecte dara la alerta

la parte de la programacion no es problema, solo quiero saber si al enviar la señal y el puerto la detecte como 1 logico esta tiene q ser de 5v? o de 3.3v? me da miedo mandar 5v y quemar el puerto, ya q por el titulo del tema mi puerto envia señales a 3.3v

gracias
No se asuste, no le va a meter voltaje simplemente al mandar al pin a tierra detecta un cambio de estado, solo debe checar si ese pin que esta usando no esta con lógica inversa o negado

Saludos
04/08/2006 #19
Moderador

Avatar de Nilfred

EinSoldiatGott dijo:
R2 se queda tal cuál 220.

Estaba leyendo el datasheet del MOC3010

Y dice que ocupa 15mA el led para hacer el trigger.

Entonces 3.3v R=V/I R=3.3/15mA=220

Si r1 la pone de 220 el moc enciende perfecto, el único detalle es que casi estamos llegando al máximo de la corriente que el puerto no spuede proprocionar 20 mA.
En la fórmula: R=V/I
V=3.3v-1.5v (V F Max, caida de tension del LED según el Datasheet)
I=0.015A (I FT Max, corriente máxima necesaria para encender el led según el Datasheet)
R=1.8v/0.015A=120 Ohm

R2 depende de la corriente que necesita el Triac BT136-600E para dispararse, IGT, Gate trigger current, 25mA, lo máximo que soporta el MOC3010 a su salida, ITSM=1A.
Para 110v:
R2=220v/1A=220 Ohm y lo cerca que arranca desde cero la onda V=IGT*R2=5,5v
Para 220v:
R2=360v/1A=360 Ohm y lo cerca que arranca desde cero la onda V=IGT*R2=9v

No me quedo claro si es para 220v o 110v CA este asunto ya que el BT136-600E es de 600v 4A y el MOC3010 de 250v 1A 15mA, osea que así como está es para 110v

Notesé que en el mismo Datasheet del MOC3010 figuran versiones de 5mA: MOC3012 (110) y MOC3023 (220)

Copipasteo otro dato interesante textual:
Note 3: All devices are guaranteed to trigger at an IF value less than or equal to max IFT. Therefore, recommended operating IF lies between max IFT (30 mA for MOC3020M, 15 mA for MOC3010M and MOC3021M, 10 mA for MOC3011M and MOC3022M, 5 mA for MOC3012M and MOC3023M) and absolute max IF (60 mA).
04/08/2006 #20


holas

gracias por sus respuestas ya estoy entendiendo mejor el tema

el motor trabaja a 220v CA, una pregunta en su calculo para 220v lo hace asi :

R2=360v/1A=360 Ohm y lo cerca que arranca desde cero la onda V=IGT*R2=9v

porq toma la cifra 360v?? no deberia ser 220v?

estoy trabajando con el MOC3011

gracias por su ayuda
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.