Haz una pregunta
  Foros de Electrónica » Diseño digital » Interfaces y Programación
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/03/2013 #1

Avatar de emurriper

Usar UTP para transmitir en RS485
Hola a todos, busqué por todos lados y no pude encontrar una respuesta clara a mi inquietud.
Bueno al grano, estoy haciendo una red basándome en protocolo RS485, mi intención es controlar unos relevos, las distancias que voy a manejar están en el orden de los 300 metros o un poco mas, y mi pregunta Es si puedo usar cable UTP cat 6 para este protocolo. Mi idea es utilizar 2 pares para transmitir datos y los otros 2 pares para el voltaje que va a alimentar los pics que cierran y abren los relevos. Es viable lo que estoy pensando o son locuras mías.
Gracias ante todo y sigamos apoyando a nuestro foro
11/03/2013 #2

Avatar de Scooter

Supongo que funcionará dependiendo de la distancia y de la velocidad.
Lo digo porque según el consumo la distancia será una u otra.
11/03/2013 #3

Avatar de emurriper

Scooter dijo: Ver Mensaje
Supongo que funcionará dependiendo de la distancia y de la velocidad.
Lo digo porque según el consumo la distancia será una u otra.
Bueno voy a usar 9600 bps y la distancia mas grande que usaré es de 300m
11/03/2013 #4
Moderador general

Avatar de DOSMETROS

Estimo (no aseguro) que a esa baja velocidad es bastante probable que si te funcione.

Podrias hacer la prueba conectando el rollo de cable antes de tenderlo

Saludos !
11/03/2013 #5

Avatar de emurriper

Gracias, buena idea la del rollo, pruebo y les cuento
12/03/2013 #6

Avatar de emurriper

FUNCIONÓ
Buenos días a todos, efectivamente funcionó, conecté 30 módulos(pic12f629 + 75176 + 2n3904 + relevo 5v) al BUS RS485, cada uno con un "ID" diferente (1,2,3,4...30) y del módulo maestro mando un "ID" y se activa solo un relevo. Del cable UTP tomé los pares azul-blanco azul y naranja - blanco naranja, uní azul con naranja y uní blanco naranja con blanco azul, para la alimentación de los pics utilicé los dos pares sobrantes y los uní de igual manera. La transmisión la hice a 9600bps. El último módulo está alejado del maestro unos 320 metros y el retardo en la respuesta es imperceptible. Gracias a los amigos que me ayudaron y ya saben si alguien les pregunta si el UTP sirve para RS485 la respuesta es un SI. Cabe aclarar que en el ambiente donde se instaló el sistema no había motores o cosas que produzcan ruido electrico
12/03/2013 #7

Avatar de Scooter

Bueno, la ventaja del 485 es que es diferencial si no me equivoco, y si es un par trenzado la misma "porquería" le entra a los dos hilos así que debería de ser bastante inmune.
Otra cosa será la alimentación que esa no es tan inmune, supongo que podrías alimentar a por ejemplo 24V y reducir a 5 en cada equipo para quitar posibles ruidos y bajadas de tensión.

Se me olvidaba; gracias por compartir los resultados, ese es el espíritu de los foros, que todos aprendamos de la experiencia compartida.
13/03/2013 #8
Moderador

Avatar de Chico3001

Lo que tambien seria interesante es que compartieras si hubo una caida de voltaje apreciable... con 300m de cable deberia haber unos mV de caida en el par de alimentacion...
13/03/2013 #9

Avatar de emurriper

Chico3001 dijo: Ver Mensaje
Lo que tambien seria interesante es que compartieras si hubo una caida de voltaje apreciable... con 300m de cable deberia haber unos mV de caida en el par de alimentacion...
Hola, listo apenas pueda mido el voltaje que me llega al ultimo módulo; usé una fuente ATX de PC de 450W y mando por el UTP 12V y en cada módulo regulo con un 78L05. Mañana les traigo el dato
16/03/2013 #10

Avatar de emurriper

Hola a todos, listo ya medí el DC en el último módulo y llegan 8.5V, suficiente para el 78L05 que es el regulador que utilizo en cada módulo
16/03/2013 #11
Moderador

Avatar de Chico3001

3.5V de perdida!!!??? eso es considerable...
16/03/2013 #12

Avatar de Melghost

¡Claro, pero qué remedio! Está alimentando 30 módulos a 300 metros de distancia y con sólo 12V. Es de esperar que haya caída en la línea. De todas formas, 3.5 V repartidos en 300 m no me parece preocupante. Yo ni lo tocaría.

---------- Actualizado después de 8 minutos ----------

Lo que sí mediría es la intensidad máxima que llega a circular por los cables de alimentación, a ver si se van a quemar porque son muy finos.
16/03/2013 #13

Avatar de emurriper

Melghost dijo: Ver Mensaje
¡Claro, pero qué remedio! Está alimentando 30 módulos a 300 metros de distancia y con sólo 12V. Es de esperar que haya caída en la línea. De todas formas, 3.5 V repartidos en 300 m no me parece preocupante. Yo ni lo tocaría.

---------- Actualizado después de 8 minutos ----------

Lo que sí mediría es la intensidad máxima que llega a circular por los cables de alimentación, a ver si se van a quemar porque son muy finos.
Pero recuerda que yo uní 2 pares para el DC y es UTP CAT 6 para intemperie, calibre 22 y los 30 módulos no estan todos a 300 metros. Están distribuidos en todo el recorrido
17/03/2013 #14

Avatar de emurriper

Aquí hacen algo parecido a lo que yo hice.
04/04/2013 #15

Avatar de emurriper

INSTALACION FINALIZADA
Hola a todos la instalación que estaba realizando fué un éxito, quedaron 4 ramas o lineas de UTP de las cuales alimento 13 módulos en cada una a través de cable UTP cat 5e para intemperie, el consumo por módulo teniendo el relé encendido fue de 88mA, el cable no se tibia en lo mas mínimo, incluso con todos los módulos activando el relé. Gracias a todos los compañeros que ayudaron y gracias al foro por permitir que nos ayudemos entre todos.

Si necesitan pcb's de módulos de relé conectados mediante rs485 me avisan, tienen muchos usos en domotica.
05/04/2013 #16
Moderador

Avatar de Chico3001

No.. gracias a ti por compartir tus experiencias... esa informacion es de mucha ayuda para otras gentes con el mismo problema..
08/08/2013 #17


tengo una pregunta que tipo de conectores utilizaste?
09/08/2013 #18

Avatar de emurriper

Usé regletas
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Interfaces y Programación

Lenguajes de programación, gestión y manejo de puertos

Cerrar
Foros de Electrónica » Diseño digital » Interfaces y Programación

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.