Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/11/2014 #21

Avatar de Ardogan

heimmer dijo: Ver Mensaje
Hola, gracias por la ayuda a todos.
Si, conecto todo de la misma fuente, supuse que con proveer unos 9V al Vin del Arduino y esos mismos 9V al VCC del L298 debería funcionar por el regulador interno de 5V del Arduino, parece que no porque al accionar el motor cae la tensión y se apaga el arduino.

Las conexiones son:
Arduino L298
Pin 5 >> ENA
Pin 2 >> IN1
Pin 4 >> IN2

Fuente
+9v a VCC (L298) y a Vin del Arduino.
El negativo de la fuente va a GND del Arduino y a 0V del L298.

Luego tomo los +5V del Arduino y lo conecto a +5V del L298.
...
A ver... este es el esquemático de la placa del L298 (fuente):




No conectes los +5V del Arduino a los +5V de la placa del L298, porque quizás estás conectando juntas la salida del regulador de la placa del L298 y la salida del regulador de 5V del arduino.
Y poner 2 reguladores a regular la misma línea de tensión = problemas

Eso siempre y cuando si ahora está habilitado el regulador de la placa del L298 (ver switch).
Si no está habilitado ese regulador entonces sí hay que conectar los +5V del Arduino con el terminal +5 de la placa del L298.

Lo que me marea de esa placa del L298 es que no coincide la foto de la tienda con la foto de la página del blog, y en el esquemático del blog aparecen las entradas ENA y ENB conectadas a +5

Si esto último es cierto en tu código tenías

Código PHP:
void avanzaA() {
    
    
digitalWrite(IN1LOW);
    
digitalWrite(IN2HIGH);
    
velActualA=1000;
    
analogWrite(ENAvelActualA);

Pero como ENA = 1 siempre (por el hardware de la placa del L298), entonces vas a tener que hacer algo como


Código PHP:
void avanzaA() {
    
    
digitalWrite(IN1LOW);
    
velActualA=1000;
    
analogWrite(IN2velActualA);

Aunque desconozco si IN2 se puede usar con analogWrite (no uso Arduino por ahora).

////////////////////////////
Edición:

Ahora que veo la primera foto bien en grande hay 2 jumpers arriba del conector azul que son para puentear ENA y ENB con 5V. Si vos tenes esos jumpers en tu placa deberías dejarlos abiertos (retirar jumpers).
Y si tu placa no es como esa foto, por favor sacale una foto y adjuntala, porque no se a que hacerle caso (a la foto de la tienda?, a la foto del blog?, al esquemático del blog?, me mareé)
26/11/2014 #22


Hellmut1956 dijo: Ver Mensaje
No heimmer, creo que el problema se debe a la capacidad de la fuente de alimentación que usas!Si te interesa es muy facil ver el efecto en un experimento.

Primero mide la tensión que da tu fuente, cuando no está conectada a nada. ese valor por lo general es un valor por encima del nomnal de la fuente, en tu caso 9VDC si te entendí bien.

Segunda, alimenta con esa mismafuente la placa Arduino creo que la que tienes y mide el valor de la tensión ahora, veras que el valor es inferior al de la primera medición y probablemente casi los 9VDc nominales.

Tercero, mide el valor de la corriente que fluye si conectas esa fuente de tensión a algún motor DC que tengas de 12VDC por ejemplo. la multiplicación del valor de la corriente con el de la tensión en ese mismo momento te dara el dato sobre cuantos vatios esta surtiendo la fuente. Si este valor calculado es superior al nominal, entonces probablemente estaras midiendo una tensión inferior a los 9VDC.

Pero existe un efecto dinámico que probablemente es el responsable que el Arduino deje de funcionar. Cuando se conecta la tensión electrica a una carga, en tu caso al motor de paso, entonces en el momento del encendido va a fluir una corriente aún mayor a la continua que has medido en el tercer experimento. La razón es que en el momento del encendido, cuando el circuito alimentado por la fuente eléctrica es sometido a la carga ocurre un breve máximo de solicitación de tu fuente eléctrica. eso se puede contrarrestar y minimizar conectando un capacitor grande en paralelo a la fuente eléctrica. Este capacitador tiene que cargar suficiente energía para contrarrestar la carga adicional durante el encendido. Así su energía se le suma a aquella que es provista por la fuente.
Es verdad que la corriente hace un pico al momento del arranque en cualquier motor de continua, la verdad que este efecto no lo tuve en cuenta. El capacitor de cuanto recomendas que sea?

A todos los que me escriben les agradezco, leo todas las respuestas y se que el inconveniente está en la fuente no regulada, el tema es que no se como resolverlo. Use varias fuentes y todas hacen lo mismo, está la chance que sean todas una porquería claramente. Hoy que puedo voy a la casa de electrónica y voy a comprar un zócalo para 4 pilas AA y voy a alimentar el motor desde ahí, para el arduino voy a usar una bateria de 9V con un 7805. Aún así, supongo que el pico de corriente se va a seguir sintiendo por ende el uso de este capacitor que me recomienda Helmut sería la solución al menos teórica del problema.
26/11/2014 #23

Avatar de Hellmut1956

De cuantos vatios es la fuente que usas?
26/11/2014 #24

Avatar de papirrin

a parte de los vatios hay que considerar que el L298 tiene una caida de voltaje del 1.8V a 4V(si mal no recuerdo)... que quizas no esta considerando.

yo digo que faltan datos que no ha mencionado con respecto a corrientes.
27/11/2014 #25

Avatar de Hellmut1956

@papirrin: La caida de voltaje del L298 no tiene importancia, ni para explicar el fallar de la placa arduino, ni de forma relevante del motor!
01/12/2014 #26


Hola a todos! Pude solucionar el problema usando una bateria Duracell Alcalina de 9v para el l298 y 4 pilas aa para el arduino. Quería evitar usar baterías porque tengo que hacer muchas pruebas con el robotito pero la verdad usando otra fuente externa no era una solución fiable. Ahora no tengo problemas de subcorriente por el consumo pico que tiene la inercia inicial de los motores.

Gracias a todos.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.