Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/11/2013 #1


Comunicacion sim900 con hyperterminal
Holas a toda la comunidad........
mi problema es el suiguiente....
He comenzado con un proyecto a_través de mensajes por medio del sim900 , me he leido el foro de Uso de un celular GSM con PIC o PC pero aún asi no puedo conectar el hyperterminal con el sim900.
Estoy usando el rs232 (hice la prueba este circuito conectando rx con tx por lo cual es correcto) pero cuando conecto al sim900 no se escribe nada en el hyperterminal, también configure el hyperterminal de la siguiente forma:
bits por segundo 115200
bit de datos 8
paridad ninguno
bits de parada 1
control de flujo ninguno
pero aún asi no funciona ya no se que hacer , responda alguien por_favor os agradecere en el alma ...
12/11/2013 #2

Avatar de Ardogan

Probaste configurando el puerto con otras velocidades?: 9600 bps, 19200, 38400, 57600.
La PC tiene un puerto serie o estás usando un cable USB a serie?
13/11/2013 #3


Si probe con todas las velocidades,la computadora tiene puerto serial
13/11/2013 #4

Avatar de Ardogan

Estás usando una placa de evaluación como esta?:
http://elecfreaks.com/store/download...uide_V1.03.pdf

Para encenderlo primero poner los switchs "Download" y "Charge"en off, y "Power" en on. Enchufar la fuente, luego presionar el botón pwrkey más de 1 segundo y soltar.

Recién entonces enchufar el cable serie, abrir el hiper terminal con la configuración de puerto deseada (se puede elegir velocidad, pero siempre 1 bit de stop, sin control de flujo ni bit de paridad).
Darle al iconito de llamada y escribir AT en mayúsculas. Esto es importante porque el SIM900 usa esa combinación para autodetectar el baud rate. Puede ser que no aparezca eco al principio, pero no importa.

Si no funciona verificar que los leds de power y status estén encendidos/titilando, que el cable serie está enchufado en el conector de aplicación(main) y no en el de depuración (debug), que todo este bien enchufado.
Podrías probar que no sea problema del puerto serie de la PC ni del cable enchufando algún otro aparato a la PC y viendo si se puede trabajar bien.

Si no estás usando una placa de evaluación comentalo detallando como están hechas las conexiones (si es un esquemático mejor).
14/11/2013 #5


Muchas gracias Ardogan por responder.

Estoy usando una similar pero ya resolvi el problema del hyperterminal lo que sucede es que conecte a la salida del max 232 unas resistencias y diodos lo cual no dejaba salir ni entrara datos, pero al ver otro circuito vi q no usaban y los retire y pan funciono.

Ahora tengo otra duda estoy programando en PICBASIC para el y en el momento de resepcionar o mandar datos del sim se debe poner la velocidad de bits por minuto la cual es 115200la q hacepta pero en PICBASIC solo acepta 9600 el codigo es el sguiente:

TESTEO:
SEROUT PORTC.6,N115200,["AT"]
SERIN PORTC.7,N115200,CONEC
IF CONEC ="O" && CONEC="K" THEN PASO2
GOTO TESTEO

o el codigo lo estoy haciendo mal ayuda por fa
14/11/2013 #6

Avatar de Ardogan

No manejo picbasic, pero no deberías ser la comparación algo como:
if conec = "OK" then paso2

Creo que eso es todo lo que puedo decir sin conocer el lenguaje.
Suerte!!
19/11/2013 #7


de la sentencia if tendria q ser como dices pero:

CONEC VAR BIYTE ;en este lugar se declara la variable conec pero solo recibe un cararcter

TESTEO:
SEROUT PORTC.6,N9600,["AT"]
SERIN PORTC.7,N9600,CONEC ;en este sector el sim me retorna 2 bcaracteres
IF CONEC="OK" THEN DETECCION ;COMPARACION SI ESTA OK VA A OTRA FUNCion
GOTO TESTEO

o como puedo declarar un variable para q me resiba n caracteres
20/11/2013 #8

Avatar de Ardogan

Al parecer picbasic no tiene capacidad de manejo de cadenas :
http://www.picbasic.co.uk/forum/show...hlight=strings

Como dije antes, no tengo idea de picbasic, jamás lo usé. Esperemos que alguien que lo sepa usar nos deje sus comentarios.
Siendo una duda específicamente de lenguaje, no está demás darse una vuelta por el foro de picbasic:
http://www.picbasic.co.uk/forum/forum.php

Una primera búsqueda (combinando términos serin, string, parsing, array) me lleva a:

Usando sim900 con picbasic:
http://www.picbasic.co.uk/forum/show...=string+hserin

Leer array por puerto serie:
http://www.picbasic.co.uk/forum/showthread.php?t=717
Código:
myVar VAR byte[32]  ' Array for inbound serial data
HSERIN [STR myVar\32\13] ' Terminate with CR
Podrías tratar de hacer un código que en vez de leer una longitud fija de caracteres lea caracteres hasta recibir un enter (\13), y de ahí pasar a analizar la respuesta.
21/11/2013 #9
Moderador

Avatar de D@rkbytes

nieves dijo: Ver Mensaje
¿Cómo puedo declarar un variable para que me reciba n caracteres?
Mira este Tema: Interfaz RS232 PIC PC (Proyecto Completo VB6)
Descarga el archivo PICSIM.rar y dentro de la carpeta PBP encontrarás otra llamada Strings
En esa carpeta viene un ejemplo para reconocer cadenas como requieres; "OK", "AT", etc.

Suerte.
27/11/2013 #10


muchas gracias D@rkbytes lo revisare ahora mismo y luego comento resultados
gracias.........
04/01/2014 #11


hola como andan?.
tengo una consulta.
tengo un modulo sim900 y e podido comunicarme bien con la pc e utilizado el hyperterminal y el tera term.
lo que encuentro raro es que en ambos al escribir los comandos me escribe cada letra doble, si bien asi los comandos los interpreta la sim y me devuelve una respuesta correcta me choca a la vista jeje, y he visto ejemplos en la red y no se ven dobles. quizas sea una bobada pero si a alguien tiene alguna sugerencia les agradeceria.
gracias y saludos.
04/01/2014 #12

Avatar de chclau

Fijate si tenes una opcion Echo o Local echo, proba de cambiarla a off
04/01/2014 #13


hola. gracias por tu respuesta.
si me fije eso en hyperterminal tiene esa opcion y estaba destildada la seleccione por las dudas y con eso escribe cada letra tres veces. es raro probé en el microcode studio y escribe bien pero no puedo usar el comando control + z para dar el ok para el envio de mensaje ya que esa combiancion me hace el undo o deshacer.
05/01/2014 #14


hola gente, pude resolver mi problema, les comento por si alguien le sirve je : estaba relacionado con lo que me comento chclau ( desactivar la opcion eco ) yo la desactivaba desde el hyperterminal sin resultados y resulta que el modulo tiene un comando AT (el ATE ) este controla la opcion eco desde el sim para desactivarlo se manda el comando ATE0 el cero desactiva esta opcion de eco y resuelto.
bueno de a poco le voy agarrando la mano je.
saludos
06/01/2014 #15

Avatar de chclau

Me alegro que lo hayas solucionado y gracias por compartir con todos la solucion de tu problema.
26/12/2014 #16

Avatar de PHelectronica

Chicos hola! y cierto felices fiestas!, Tengo una cuestión que no puedo resolver, casi bajo ningún medio. El tema es que me quiero comunicar con estos módulos, ya logre hablar por teléfono y todo sin problemas, el problema es que quiero llamar al 0800 222 1919 que es la llamada por cobrar y por ejemplo seleccionar opciones de operadora, como puedo hacer esto? como puedo elegir una opción, pasa que si marco y vuelvo a marcar la opción "1" por ejemplo me corta la comunicación y me marca el numero 1, como soluciono esto?

Gracias de antemano Saludos!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.