Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

23/07/2013 #1


Consulta Simple y Concreta Vumetro
Hola!
Estoy a punto de comenzar este proyecto. Es un Vumetro tipo Array (columna, de 1.20 mts de altura aproximadamente) con el integrado LM3915. En cada salida del integrado, se situarán 3 leds de 3mm y algunos de 5mm tambien, conectados en serie.

El circuito es el descripto en la imagen. Es muy simple. En la entrada de la señal, se acoplará un filtro pasa bajos para causar un efecto mas "movido y agradable". Tiene como fin la decoracion. No esta diseñado para mediciones especificas de señal.

Circuito Vumetro.JPG

Mis consultas son las siguientes:

*Asi como esta, deberia funcionar bien, no? Los transistores van a ser los PNP BC327, aunque no figuren en el diagrama (no se encuentran en la libreria del Livewire)

*No habrá problemas de consumo por ningun lado, ni daños en los componentes? Sobre el LM3915 me marcaba un consumo de -15,45mA y en el ánodo de los led, -10,5mA.

*El circuito será montado en una placa, pero luego de las resistencias de 100ohm, habrá cables hasta los led, con un largo maximo de 1.2mts (hasta la cima de la columna). Esto no debería interferir en nada, o no?
(En un esquema de la serie Plaquetodo, esta este mismo circuito con un solo led por salida pero sin transistores y recomendaban un largo menor a 9cm. Debido a esta cuestion va mi consulta)


Como ultimo detalle. Estoy muy preocupado con el asunto, ya que lo arme anteriormente, de manera muy similar, y casi seguro que queme misteriosamente el integrado y todos los transistores (BC558).

Sin mas para decir. Espero su pronta respuesta. Este proyecto me es de suma importancia laboral.

Muchisimas gracias de antemano!
Saludos Coordiales

Mariano

PD: Adjunto la imagen y el archivo del Livewire
23/07/2013 #2

Avatar de Daniel Meza

Saludos.
No creo que haya problemas por el largo del alambrado. Luego, el valor del resistor de base de los transistores en muy bajo, cámbialos por un valor de algunos 2.2K. Otra cosa, los leds pueden variar en consumo de corriente y por su color, tu usarás colores distintos así que te sugiero hagas la prueba de obtener la corriente min y el VLED que necesita el led para dar un buen brillo (sin llegar a quemarlo) y en base a este valor de corriente y voltaje calculas la caída de tensión en los 3 leds y así calculas el valor del resistor limitador de corriente que tu pusiste de 100 ohms
24/07/2013 #3


Hola Electronica Twety

Lo importante es
conocer las características eléctricas de los LED’s que vas a utilizar. No los del LiveWire.
Las características eléctricas del transistor que vas a utilizar. No el del LiveWire.
Las características eléctricas del LM3915. No el del LiveWire.

Una ves teniendo esos datos podemos proceder a calcular todo.
Estás, según se ve en tu esquema, polarizando el circuito de los LED’s con 12V.
3 diodos en serie sería VF1 + VF2 + VF3 = VFT.
Suponiendo que encienden con 20mA.
1 transistor; de este se requiere saber la ganancia para poder calcular la corriente IB que requeriría para que por colector-emisor circulen 20mA para que enciendan los LED’s.
supongamos que tiene una ganancia G = 50. entonces 0.020/50 = 400uA de IB.
Sin embargo ese transistor no creo que sea necesario por lo que se menciona en las hojas de datos del LM3915.

LED current drive is regulated and programmable, eliminating the need for current limiting resistors. The whole display system can operate from a single supply as low as 3V or as high as 25V.
Output current programmable from 1 mA to 30 mA.
Traducido con: http://translate.google.com.mx/?hl=es&tab=wT#en/es/

La corriente del LED es regulada y programable, lo que elimina la necesidad de resistencias limitadoras de corriente. El sistema de visualización de conjunto puede operar desde una fuente de alimentación tan bajo como 3V o tan alto como 25V.
La Corriente es programable desde 1 mA a 30 mA de salida.

Así que si tus LED’s requieren para encender una corriente que esté en el rango de 1 a 30mA. No se requiere el transistor.

Algo de lo largo de los cables entre el circuito y los LED’s también es mencionado en esas hojas de datos.
Vamos a suponer que se utiliza cable calibre 18. de 1.2Mts. de largo.
La especificación AWG para el calibre 18 dice que tiene: 6.3851 Ohms por mil pies.
Si 1 pie tiene Aprox. 30.5cm. 1000 pies serían: 0.035 X 1000 = 35 Mts.
Así que los Ohms por metro serían 6.3851/35 = 0.1825 Ohms.
Circulando 30mA –el peor caso- por un cable Calibre 18 con una longitud de 1Mt. Habría una caída de tensión de: 0.30 X 0.1825 = 0.005475 Volts = 5.5mV. prácticamente despreciable.

Sin embargo en las hojas de datos se menciona algo más pernicioso: el ruido electromagnético que se induciría en esos cables largos. Pero allí mismo dice cómo solucionar ese problema.

saludos
a sus ordenes.
24/07/2013 #4


mrcarlos dijo: Ver Mensaje
así que si tus led’s requieren para encender una corriente sin embargo en las hojas de datos se menciona algo más pernicioso: El ruido electromagnético que se induciría en esos cables largos. Pero allí mismo dice cómo solucionar ese problema.
Creo que este colega tiene razon,pero se soluciona usando cable mallado del bueno,en especial los que se usan para los microfonos que son re aislados.Con respecto a la corriente que manejan estos cables no tendrias problemas porque aunque es bajo puede soportar esta clase de corrientes en miliamperes.
Estos cables estan calculados para que una tension de 1µV a 10mV,en todo la longitud que tiene, no tenga perdidas de tension o tambien llamada caida de tension en todo su recorrido.
Yo hice una instalacion de una consola en un lugar que desde la consola al microfono habia unos 12 metros y no tuve problemas de ruidos ni perdida de tension.
24/07/2013 #5

Avatar de Dr. Zoidberg

Tenés que hacer lo que dice MrCarlos y no usar transistores ni resistencias ni nada, por que las salidas del LM391X son fuentes de corriente constante y NO son a colector abierto convencionales, así que solo ponés los 3 LEDs en serie por cada salida del LM y listo. Solo tenés que asegurarte que la tensión de alimentación sea suficiente activar los tres leds y sumarle dos o tres voltios extra para asegurarse de mantener operativas en forma correcta cada fuente de corriente.
Otra cosa importante es, si vas a usar el vumetro en modo barra, asegurarse de no exceder los 10 o 12 mA de corriente por que se va a calentar el LM y tal vez vuele. El cálculo de las resistencias de rango y de regulación de corriente DEBE HACERSE CORRECTAMENTE o te vas a comer el chip.
24/07/2013 #6


Dr. Zoidberg dijo: Ver Mensaje
Tenés que hacer lo que dice MrCarlos y no usar transistores ni resistencias ni nada, por que las salidas del LM391X son fuentes de corriente constante y NO son a colector abierto convencionales, así que solo ponés los 3 LEDs en serie por cada salida del LM y listo. Solo tenés que asegurarte que la tensión de alimentación sea suficiente activar los tres leds y sumarle dos o tres voltios extra para asegurarse de mantener operativas en forma correcta cada fuente de corriente.
Otra cosa importante es, si vas a usar el vumetro en modo barra, asegurarse de no exceder los 10 o 12 mA de corriente por que se va a calentar el LM y tal vez vuele. El cálculo de las resistencias de rango y de regulación de corriente DEBE HACERSE CORRECTAMENTE o te vas a comer el chip.
Entonces la idea de los transistores es lo ideal ya que si por cada salida no podes exeder lo 10mA para no destruir el LM391x y sabemos que cada led consume mas de 10mA,aunque segun la configuracion puede ser menos,es mejor colocar un driver para que maneje los leds
24/07/2013 #7


Hola Gente!!
Antes que nada, les agradezco por contestar.
Les comento que probé el circuito sin resistencias ni transistores, y la verdad anduvo todo impecable. En cuanto a la corriente de los leds, mañana les confirmo cuanto me esta midiendo. El vumetro va a funcionar en modo barra.
En el circuito, entre el pin 7,6 (puenteados) y el 8, coloqué una resistencia de 1k y de este a tierra, un potenciometro de 10k. Con esto varié la corriente de salida. Estoy en lo correcto?
Lo he usado unos 15 minutos y no he observado calentamiento en el LM3915. Mañana lo compruebo bien.

La unica consulta que me queda seria... como se calcula especificamente esas 2 resistencias de rango?

Muchisimas gracias por responder! Saludos coordiales

Mariano.
24/07/2013 #8

Avatar de Dr. Zoidberg

Electronica Twety dijo: Ver Mensaje
La unica consulta que me queda seria... como se calcula especificamente esas 2 resistencias de rango?
Por acá está como se hace...

---------- Actualizado después de 4 minutos ----------

tinchusbest dijo: Ver Mensaje
Entonces la idea de los transistores es lo ideal ya que si por cada salida no podes exeder lo 10mA para no destruir el LM391x y sabemos que cada led consume mas de 10mA,aunque segun la configuracion puede ser menos,es mejor colocar un driver para que maneje los leds
Para los LEDs comunes de 3 o 5mm con 10mA te sobra para encandilar a la gente, y no necesitan más de 10mA o se queman rápido (eso de los 20mA es una mentira derivada de uno que no sabe leer los datasheets ).
Para LEDs de mas potencia....podés usar transistores o poder usar fuentes de corriente constante con PWM, el problema es que para usar transistores HAY QUE HACER EL CIRCUITO CORRECTO y no la barbaridad que muestran en los esquemas por ahí, por que así no se polarizan los transistores a la salida de una fuente de corriente constante como las salidas del LM...
26/07/2013 #9


Hola Electronica Twety

Ayer (25/jul/2013) dijiste:
En cuanto a la corriente de los leds, mañana les confirmo cuanto me esta midiendo
Y Hoy (26/jul/2013) es mañana.

saludos
a sus ordenes
26/07/2013 #10


Si disculpas carlos. Tuve un inconveniente personal. Ya hice las mediciones. El consumo máximo que logré tener fue de 8,5mA... Y en promedio, la mayoria, variaba entre 5,5mA y 7,5mA....

Luego voy a hacer las cuentas para Vref: 1,5V y Iled: 8mA

Apenas las termino, les paso los valores para ver si estan bien... Ya que ando limitado de tiempo en este momento.

Saludos y gracias por todo!
30/07/2013 #11


Hola gente! Les comento que estuve haciendo los calculos correspondientes para R1 y R2, y realmente no me dieron para nada. A groso modo, R1=15,65 Kohm y R2=3,13 Kohm... Pero esta muy seguro que estan mal.

Use un Vref= 1,5V (este es con respecto a la señal de audio, no?) y Iled= 8mA (fue el consumo maximo que llegué a tener experimentalmente).

Traté de hacer los calculos como tiene el amigo Dr. Zoidberg en su post, pero ni siquiera me da la primer ecuacion y no entiendo principalmente la parte de las unidades.

Les pido una ayuda en esto final nada mas. Tengo bastante claro con las matematicas, pero nunca resolvi una de electronica). El resto esta todo en proceso y mañana ya armo la PCB. (aunque no tenga estos datos aun y no pueda probarla).

Gracias de antemano y discupas por las molestias!

Saludos a todos!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.