Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/07/2006 #1


Controlar la direccion de motores con L293B
e visto por internet que este integrado sirve para controlar la direccion de motores, 2 motores en la misma direccion o 1 hacia derecha o icquierda.(corregidme se me eqiboco) por internet e encontrado este circuito para controlar la direccion a derechas o izquierdas de un motor, pero hay patitas del integrado que no se qu hacer con ellas... aver si me podeis ayudar.
otra cosa, las patitas 7 y 2 no se conectan no??
y la ultima ese circuito haria que el motor girara hacia la derecha no¿?

saludos
25/07/2006 #2


controlador motores
Hola Zapeitor, como cacharreas con motores, te envio esta pagina espero te ayude ,suerte un saludo
http://www.x-robotics.com/motorizacion.htm
25/07/2006 #3


lo que pasa esque me parece muy complicado y solo vale para cambiar el sentido de giro del motor cuando eso se puede hacer con un commutador... algo mas hara que no se..

saludos
26/07/2006 #4


Aunque efectivamente el sentido de giro o activación de un motor se puede hacer con interruptores o conmutadores, hay que presionar estos conmutadores o moverlos mecánicamente, pero cuando se quiere hacer el control por medios electrónicos, por ejemplo que abras la puerta de un garage por un control remoto y que se cierre (invirtiendo el giro), y sobre todo CONTROL DE VELOCIDAD con PWM un conmutador no te va a servir de mucho, pero el L293 te vendrá como anillo al dedo
26/07/2006 #5


pepe puerto: este esquema lo seque de esa web, gracias de todas formas

roberto moreno: sigo sin saber que hay que hacer que para que el motor cambie de direccion (en la web pone algo que yo entiendo como si para que cambiara de direccion hay que conectarlo a las patitas del otro lado, la 9, 10 ,11, etc es asi¿?¿?)

saludos
26/07/2006 #6


Basta con entender un poquito de electrónica digital y una tabla de verdad, hay tres entradas en el esquema que presentas. terminal 1, 2 y 7 la 1 es el enable es decir una terminal que definirá si se usa o no el sistema (Imagina que está abierta la puerta del garaje y por seguridad no se debe cerrar, el enable dirá si funciona o no el dispositivo) y las de control que son la 1 y la 2 un 0 lógico en terminal 1 y un 1 lógico en terminal 2 hará que gire a la derecha, la situación inversa (un 1 lógico en terminal 1 y un 0 lógico en terminal 2) hará que gire a la izquierda, ceros lógicos en ambas entradas detiene el motor (un 1 lógico es el voltaje de por ejemplo un ttl 5v, si digo un 1 lógico digo 5V, un 0 lógico es desde luego cero volts o tierra, al menos en el sentido más básico)
26/07/2006 #7


ok gracias (esque no tengo ni idea de electronica digital)

saludos
07/05/2009 #8


hola: tengo entendido que los motores paso a paso se detienen dejando dos bobinas internas energizadas (necesito que se quede quieto y firme), mi pregunta es ¿puedo hacer que se detenga
el motor con el l293 utilizando las de control de giro? por ejemplo poner 1 y 1 lógico en dichas entradas, o se pude hacer detener firmemente por medio de la entrada ENABLE

desde ya gracias
20/05/2009 #9


deja te explico algo de elect. digital basico:
---- 1 logico o nivel alto equivale a conectar de 2.5 a 5 volts .
----0 logico o nivel bajo equivale a conec tar de 0 a 0.8 volts o a tierra.
nunca conectes un voltaje intermedio entre 0.8 y 2.5 volts por que se considera indefinido!
-----Vcc es el voltaje de alimentacion del circuito integrado que en este caso puede ser de 4.5 a 7 volts te recomiendo que uses 5v.
-----Vss es el voltaje con el cual vas a alimentar los motores que en este chip va de 4.5 a 32 volts y corriente maxima de 1A.
ya con esto podras saber como hacer girar el motor y cambiar su direccion cuando quiereas en el punte H (l293d). En el digrama que tienes el pin que dice Enable (abilitar) debes conectar un 1 logico (2.5 a 5v) para que funcione depues en el pin 7 le pones un 1 logico y al pin 2 un 0 logico (tirra) esto hara que el motor gire para un lado (no recuerdo hacia cual) si quieres cambiar el giro solo le pones al pin 7 un 0 logico(tierra) y al pin 2 un 1 logico (2.5 a 5v) y asi cambiara la direccion del giro ahora si pones niveles logicos iguales en los dos pines el motor se detendra por ejemplo si le pones 0 logico al pin 7 y al pin 2 el motor se detendra al igual que si le pones un 1 logico en ambos.
te recomiendo que uses el punte H L293D por que este no ocupa diodos externos ya los tiene adentro otra cosa tambien seria bueno que te bajes el pdf de sus instrucciones de uso puedes bajarlo de datasheet para que veas que hace cada pin ya que puedes controlar dos motores si quieres para controlar dos motores haces lo mismo que te explique para cada uno
te dejo una tabla de verdad para que quede mejor entendido
enable pin7 pin2 giro del motor

1 1 0 hacia la derecha
1 0 1 hacia la izquierda
1 0 0 se detiene el motor
1 1 1 se detiene el motor rapidamente

suerte
31/07/2009 #10


Hola a todos! q tal? yo m encuentro con este problema, necesito controlar la direccion d giro d un motor d 4v cc, creo q es d un cd, a travez del puerto paralelo. Compre el L293D, pero todavia no tngo bien en claro como iria conectado cada cosa, m fije en la pag x-robotics.com y mi gran duda es a q conectar el pin 8 del L293D, yo directamente le conecte y lo estoy alimentando con un pin y dandole 5v con el puerto paralelo, pero solo a ese pin, de alguna forma tambien tengo q relacionarlo con los cables del motor? la conexion la estoy haciendo con un protoboard y los demas pines del l293d creo q los conecte bien, gracias a todos!

pd: entendi el funcionamiento q describio miyatronics
02/08/2009 #11


que tal, me imagino que quieres controlar el giro del motor para ambos lados osea que gire a la izq. o a la derecha. Lo que tienes que hacer es lo siguiente:
el pin 8 va el voltaje que que le quieres poner al motor que en tu caso le vas a meter 5v.
tu motor va a ir conectado al pin 3 y al pin 6 y las entradas para manejar el motor son el pin 2 y el pin 7.
si quieres conectar otro motor solo lo conectas en los pines 11 y 14 y las entradas estan en los pines 10 y15. si le pones dos motores el voltaje que le pones al pin ocho sera para ambos motores.
espero que te haya ayudado.
p.d. el pin 16 es para alimentar el integrado el cual es de 5v te recomiendo ver la hoja de datos del integrado lo puedes encontar en alldatasheet suerte
05/08/2009 #12


Gracias x la respuesta, = ya tube que entregar un proyecto para la uni que tenia q hacer con ese motor, igualmente me hize una conexion rara y m funciono, pero no se movia con toda la potencia el motor, lo q hize es conectar al pin 1 y 16 una union q comparten 5v, lo mismo con el 8 y el 16, los pines 4, 5, 12 13 a tierra. los 3 y 14 en 5v cada uno para el motor, y el 2 y el 15 eran los que tenia q alimentar para q giren para un lado o para el otro, bueeno una forma algo mas complicada pero m funciono, gracias miyatronics igualmente voy a probar cuando pueda la manera "correcta" de hacerlo
05/04/2012 #13


hola:
tengo un ploblema con el L293, ya lo conecte de todas formas y solamente logro que el motor gire hacia un solo lado,

cuando:
los pines son 7=5v y 2=0v -----el motor gira
los pines son 7=0v y 2=0v -----el motor no gira
los pines son 7=5v y 2=5v -----el motor no gira
pero el problema es cuando:
los pines son 7=0v y 2=5v-----el motor no gira
creo que hasta ya queme el integrado, porque no creo que sea normal que los pines 7 y 8 se cortocircuiten, verdad???, esto lo he comprobado con el multimetro, con el modo de continuidad.

espero me puedan ayudar,.....
05/04/2012 #14


Yo creo que te estas equivocando (o yo) pero las entradas son 2,9,12,19 y para habilitar las salidas son 1 y 11, no entiendo de donde sacas que el pin 7 tiene 5v...

podrias poner un esquema de como lo estas conectando?

---------- Actualizado después de 24 minutos ----------

Mmmm.. ya vi mi error.. el que tienes es el L293B y yo hablaba de L293D, mmm... si, algo esta raro con lo que mencionas... en lugar del motor ya has probado conectar el multimetro para verificar que te de los voltajes correctos...

el motor que tienes cuanto consume???
05/04/2012 #15


gracias
no se a detalle los parametros de mi motor pero hasta con 5v minimo se mueve y el maximo que le conectado sin que pase nada es a 15v.

en lugar del motor coloque las terminales del multimetro, y da 7v cuando solo presiono el pusch del pin 7
este voltaje es suficiente para que mi motor gire

y me da 0.03v (o sea nada), cuando solo presiono el pusch del pin 2.y,......... no se porq???
es por esto que el motor no gira.......

si ningino de los dos pusch estan presionados o los dos los presiono al mismo tiempo meda 0.03v y no gira, pero esto esta bien.
05/04/2012 #16


y me da 0.03v (o sea nada), cuando solo presiono el pusch del pin 2.y,......... no se porq???
me parece que si se quemo tu integrado deberia con el multimetro marcar +V con el pin7 y -V con el pin2...

ya probaste con el otro canal (pines del 9 al 15 )???
05/04/2012 #17


en el sig. archivo pongo como lo he estado conectando .
Archivos Adjuntos
Tipo de Archivo: pdf diseño.pdf (247,8 KB (Kilobytes), 329 visitas)
05/04/2012 #18


con respecto al motor verifica su consumo puesto que el L293 solo aguanta 1A....
05/04/2012 #19


sip, ya lo intente, con este otro diseño pero nada....... ahora no gira hacia ningun lado
tendre que comprar otro integrado, no se que paso, pero se daño todito..


agradesco de ante mano tu ayuda!!

con respecto al motor consume 70mA
Archivos Adjuntos
Tipo de Archivo: pdf diseño2.pdf (58,9 KB (Kilobytes), 82 visitas)
05/04/2012 #20


Algo veo mal en las conexiones...

con respecto a tus preguntas... si... si puedes poner los diodos 1n4007 sin problemas, y no se debio haber quemado si pones 5v en el pin 1, aguanta hasta 7v ....

las tierras de ambas fuentes si deben de ir conectadas... pero algo esta raro en las conexiones de los positivos...

deja preparar un dibujo para que hagas una prueba...

---------- Actualizado después de 15 minutos ----------

A ver conectalo asi y mide los voltajes....



presionando el pulsador del pin 7 y 2, pero no simultaneos, en teoria si activas ambos hace corto circuito, estuve buscando si el l293b tiene proteccion contra eso pero no le encuentro... deja le sigo leyendo...

---------- Actualizado después de 18 minutos ----------

Pues activando ambos se detiene el motor rápidamente, y tiene protección térmica... así que la unica manera que yo creo que se haya quemado es que le pusiste 12v en las entradas 1,7, 2 o la alimentacion(16), o que el motor demande demasiada corriente, puedes describir el motor o una foto???

hiciste la prueba segun el dibujo?
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.