Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

03/01/2011 #1


Dudas básicas sobre un circuito muy básico pero enrevesado...
Saludos, me presento al foro con una duda que seguro que para la mayoría será muy sencilla.
Mi nombre es Aitor y estudio quinto curso de psicología. Como os podréis imaginar, psicología no tiene mucho que ver con la electrónica, sin embargo estoy haciendo un prácticum de investigación y necesitamos un par de circuitos para montar un experimento; y yo de electrónica se lo poco que recuerdo de la ESO y el bachillerato (cursé el tecnológico, pero de eso hace casi 5 años...)

En fin, ya no me lío más, espero explicar esto lo más claramente posible.

El experimento sitúa al sujeto de estudio en una sala aislada y oscura, y se registran sus movimientos oculares por un canal. Por otro canal se envían ciertas señales lumínicas por medio de unos LEDs conectados al ordenador (que se encuentra fuera de la sala) por un puerto serie (9 pins).

Bien, pero lo que me interesa ahora mismo es lo que hay fuera. Fuera tenemos un circuito pequeño y sencillito que se conecta al ordenador (tb por un puerto serie), y su función es indicar cuándo se encienden las señales lumínicas del interior de la sala.
Este circuito tiene 2 LEDs, uno rojo y otro verde. Cuando el experimento comienza pero no hay señal lumínica en la sala experimental, el circuito está en reposo (LED rojo encendido, LED verde apagado), en el momento en el que se enciende la señal lumínica dentro de la sala, se apaga el rojo y se enciende el LED verde; para volver a la situación de reposo cuando vuelve a desaparecer la señal de dentro.

Cuando yo llegué al proyecto, ya estaban utilizando este circuito que había hecho un chico que ya no está y que al parecer sabía de estas cosas. El circuito es aprovechado de otras cosas, pero no me han dado más datos...:/

Al caso! He estado dándole vueltas al circuito pq tengo que replicarlo, pero es que no le veo ningún sentido... No entiendo cómo puede funcionar estando como está....:/
Veamos, es un circuito impreso y tiene esta forma (lo he copiado):



Bien, lo primero, lo que tiene forma de resistencia son efectivamente resistencias...xD No son iguales (una tiene las rayas de unos colores y otra de otros colores).
Lo que pone PL es una puerta lógica que no se cual es, pq el circuito está en el laboratorio y no pude copiar la referencia, sin embargo, la he puesto clarita para que veáis pq yo creo que ahí no hace nada....
Del lado derecho de la puerta salen dos cables que parecen de sonido (delgaditos, uno rojo y otro negro) que se enganchan a una clavija finita que pone "SPEAKERS", por lo que me imagino que en algún momento ese circuito se conectaba a un altavoz, pero no me han dado información sobre esto; actualmente esa clavija está suelta.
Como vemos, del lado derecho está eso, que no es más que un cable suelto y del lado izquierdo de la puerta queda el resto del circuito.... De tal modo que en realidad el circuito no atraviesa la puerta lógica, por lo que no hace nada ahí.... :/ Al menos eso es lo que creo.

Luego, esos dos símbolos de bombilla en realidad son LEDs, los he puesto así para entendernos, puesto que no puedo saber cómo están orientados (al estar soldados es imposible para mi saber cual es el cátodo y cual el ánodo...). Lo que se indica ahí no es que estén en paralelo, sino que cada rama es una pata del LED.

Por último, y lo que para mi es si cabe más extraño de todo (ya la propia disposición del circuito y la situación del polo negativo me parecen ridículas...), es que esas 3 uniones que he marcado con la elipse roja están unidas por una misma soldadura... Es decir, hay una soldadura de estaño larga que abarca todo eso....
Entonces claro!Yo flipo un rato, pq así me da la impresión de que los LEDs están puenteados y no entiendo entonces cómo pueden funcionar así.... -.-u
Sin embargo, el circuito funciona....

Ah, se me olvidaba, al polo positivo llega un pin del puerto serie y al negativo llega otro pin del mismo puerto serie.... He estado preguntando y me han dicho que eso es imposible, que tiene que tener un tercero de tierra para que cierre el circuito, pq no puede cerrar en el mismo ordenador, y que si no hay un tercer cable que será pq probablemente libere la corriente por la propia clavija o algo así...
Yo no le veo inconveniente a que un pin ejerza de polo positivo enviando el pulso eléctrico y el otro de negativo liberándolo... Pero no se, muy poco se de estas cosas.


En fin, hasta aquí la presentación del caso. Ahora mi pregunta es simple:

¿Puede funcionar el circuito así? ¿O es que lo he copiado mal?? (dudo haberlo copiado mal pq lo miré y confirmé 30 veces....)

Ahora, aun a riesgo de hacer el post todavía más largo y que por tanto no lo leáis, os presentaré lo que yo haría...

Lo que he pensado, es que lo más sencillo para cumplir la función requerida sería esto:



Lo suyo sería programar al ordenador para que en reposo enviara corriente solo por el pin 1, de este modo el pin 2 funcionaría como polo negativo liberando esta corriente. El LED de la izquierda se encendería (sería el rojo), pero el LED de la derecha permanecería apagado puesto que está orientado al reves.
Luego, cuando se quisiera indicar la señal luminosa, el ordenador dejaría de enviar corriente por el pin 1 y empezaría a enviarla por el pin 2; de este modo los polos se invertirían y la corriente circularía en sentido contrario, haciendo que se encendiese el LED de la derecha y se apagase el de la izquierda....

Por lo que he leído, la resistencia se puede colocar antes o después del led, por lo que no habría problema; lo único que al ser LEDs de distinto color quizá no me sirva una misma resistencia para ambos, pero eso es un detalle mínimo que se resolvería poniéndo las resistencias en la rama de su respectivo LED.

Lo que me interesa es saber si ese circuito funcionaría, si podría hacer que el ordenador haga ese cambio (yo no le veo nada malo a eso...:/).

En fin.... Muchísimas gracias por leer, se que es un tocho enorme y apuesto a que la mayoría pasarán de él, pero bueno tengo que intentarlo...xD
Espero que vosotros, que sabéis más que yo podáis resolverme esas dudas. Muchas gracias de nuevo!!
03/01/2011 #2

Avatar de Eduardo

angelcafe dijo: Ver Mensaje
Conectando asi vas a tener un brillo diferente en cada led. No seria gran problema, aunque con solo usar una resistencia para cada led los podes dejar iguales.

Pero el problema es el puerto de la PC te maneja poca corriente y encima, en general el nivel alto no llega a los 5V y entrega bastante menos corriente que la que absorbe en nivel bajo.
No todos los puertos son iguales, algunos estan mas cerca del standard (lo anterior) y otros con salidas buffereadas con las que si te encenderian los leds.

Para evitar los problemas de que te funcione diferente con cada PC, usa directamente transistores:

Los 5V los podes sacar del puerto USB o de la misma fuente de la PC.
Las resistencias de 220 son de ejemplo y dependen del brillo que quieras darle a los leds.
03/01/2011 #3

Avatar de Black Tiger1954

Si mirás bien, vas a ver que el circuito está conectado de la misma forma a la que vos proponés, salvo por el detalle de esa gota de estaño, si están unidos el cátodo y el ánodo de los LED´s NO pueden encender, revisá bien eso porque quizás es una gota de estaño que ha caído y en realidad no hace contacto.
Para saber que función cumplía esa "puerta", es indispensable saber la nomenclatura que tiene.
03/01/2011 #4


Gracias por contestar.

@Eduardo: Gracias por dedicar tu tiempo a diseñar ese circuito. Como bien dices, los LEDs así montados compartiendo resistencia no alumbrarán de forma óptima pues son de distinto color, pero como dije podría solucionarlo (hasta cierto punto) poniéndo su correspondiente resistencia para cada uno (ponerlos en paralelo y cada LED con su resistencia). En principio, y aunque agradezco tu ayuda, no utilizaré transistores pq no los se usar y a fin de cuentas este circuito es solo para indicarnos a nosotros (los investigadores) cierta información así que no es imprescindible que se iluminen al 100%...

@Black Tiger: Gracias tb por tu respuesta. Efectivamente el segundo montaje que os he representado es algo que se me ocurrió pensando sobre el primero.... Yo no se exactamente cómo funciona el programa que envía las señales al circuito; de hecho al principio pensaba que la puerta lógica era una OR y que dependiendo del voltaje que le llegara encendía un LED u otro (o algo por el estilo), pero al ver como esta colocada elaboré la hipótesis del cambio de polaridad de los pins....

Veamos pues, según dices, el montaje sería básicamente el mismo... Podríamos interpretar pues que efectivamente el programa funciona de ese modo?? (utilizando como positivo un pin y negativo otro y luego cambiando la polaridad).
Podría comprobarlo con un polímetro, no??

Ahora lo de la gota de estaño.... La verdad es que yo tb he querido pensar que esa gota está ahí encima pero no une pero...buf, es que lo veo imposible! xD Parece una soldadura perfectamente normal... Pero es que cubre toda esa parte!! Lo único que podría ser es que esa gota cayera sin querer y que entre ella y los elementos del circuito haya un aislante... Sinó tendrías que estar haciendo cortocircuito (creo, y por lo que entiendo de tu respuesta tu tb lo crees).... Pero es que eso me parece imposible...xD
Un lío... Cada vez entiendo menos cómo puede ser que funcione, pq de hecho funciona...xDD

Sobre la puerta, veré el código que tiene impreso encima, me imagino que con eso ya se podrá saber qué función tiene... Yo me imagino que será una AND, para que cuando se da señal en el LED tb de tono en el altavoz o algo así, pero pf... Son solo suposiciones....:/

En fin, entonces a fin de cuentas, me confirmáis que el 2º circuito funcionaría, y que el puerto serie puede hacer ese cambio de polaridad sin problema??
Me confirmáis tb que un LED con el cátodo y el ánodo unidos no puede funcionar?

Muchas gracias
03/01/2011 #5

Avatar de Black Tiger1954

Lo que yo sospecho es que uno de los pines es GND, y luego con que el pin usado cambie de estado, ya estaría funcionando pues no hay que olvidar que en estado alto, tiene unos 12 volts y en bajo, -12.
Y si, te confirmo que un LED con cátodo y ánodo unido NO puede funcionar.
03/01/2011 #6


Ok, perfecto, entonces cuando vuelva de vacaciones volveré a revisarlo a ver donde está el error....:/

En cuanto a los pins... Me podrías explicar (o indicarme donde puedo informarme) lo de los pins? Es que tengo unos conocimientos muy muy básicos de electrónica y de informática....:/

Por lo que he visto en google, un pin GND es un pin tierra, por tanto por ahí es por donde "se liberaría la corriente", no?

Lo del "estado alto" y "estado bajo" no sabía lo que era, acabo de buscarlo e informarme un poquitín y he visto que se refiere al voltaje que produce un elemento y representan los valores lógicos de 1 y 0 respectivamente, no?

Lo que no entiendo muy bien es entonces cómo funcionaría.... Sería que en una punta del circuito (donde pone "pin 2" en el 2º circuito, por ejemplo) se usa un pin GND, que tendrá la función de liberar la tensión del circuito y que en la otra punta del circuito (donde pone "pin 1") se usaría un TXD (que he visto que es de "transmisión de datos") y que estaría enviando 0 (-12v) cuando el circuito estuviese en reposo (LED rojo) y 1 (+12v) cuando el circuito estuviese activo (LED verde)??

Y así se daría el efecto deseado con ese montaje?? Es que no entiendo muy bien como sería eso de "enviar -12 voltios"...xDD Me imagino que será algo como "tirar de 12v" pero pff.. Yo que se, seguro q es una burrada eso q digo... xDD

En fin, perdona que te pregunte cosas tan básicas pero estoy aprendiendo desde la nada y me cuesta un poco encontrar información.... ^^u
Gracias de nuevo por tu tiempo.
03/01/2011 #7

Avatar de Black Tiger1954

por tanto por ahí es por donde "se liberaría la corriente", no?
Depende. En un caso entrega corriente y en el otro, la recibe. En el adjunto que subí, seguramente lo vas a entender mejor.
Cuando la llave (que en tu caso sería el pin), está en 1 el LED encendido es el rojo, y la corriente circula desde los 12 volts hacia el GND.
Ahora cuando la llave está en 0, el LED encendido es el verde, y la corriente circulará desde GND hacia los -12.
y representan los valores lógicos de 1 y 0 respectivamente, no?
Sí señor!
Y los -12 volts, los entrega la misma fuente del PC.
Imágenes Adjuntas
Tipo de Archivo: jpg ledrs232.jpg (36,6 KB (Kilobytes), 12 visitas)
03/01/2011 #8


Fuck yeah! Así si!! jaja
Ok, creo que lo he entendido, tu ejemplo ha sido muy gráfico :]

Lo único que no estoy muy seguro es esa representación que has puesto de Key = Space. Ese "interruptor" es teórico no?? Es decir, ahí estará conectado al pin 3 (TXD) y ese "interruptor" solo es para que yo vea cómo cambia la situación al estar enviando en "estado alto" y en "estado bajo" no?

Esa imagen que has hecho es una representación más precisa del segundo circuito que puse en mi primer post, enchufando la punta que pone "pin 1" al pin 3 (TXD) y la punta que pone "pin 2" al pin 5 (GND), no? (Es que necesito verlo así a nivel más práctico para aclararme las ideas y saber qué tendré que hacer...xD).

Una cosita más, si desestaño los dos cables que le llegan al circuito que se está usando actualmente, los engancho a cada una de las puntas de un polímetro y pongo el programa que dirige el circuito a funcionar, se supone que el polímetro debería indicarme una señal de 12v cuando está en reposo (LED rojo) y -12v cuando está activo (LED verde), no? Sería una buena forma de corroborar que efectivamente funciona así?

De verdad, muchísimas gracias eh, me están siendo de gran ayuda tus posts
03/01/2011 #9

Avatar de Black Tiger1954

Ni siquiera tenes que sacar los cables, podes medir directamente.
03/01/2011 #10


Ok, pues muchas gracias una vez más!
Dentro de una semana pondré todo esto a prueba y si acaso te cuento como ha ido!

Un saludo.
03/01/2011 #11

Avatar de unmonje

Black Tiger1954 dijo: Ver Mensaje
Lo que yo sospecho es que uno de los pines es GND, y luego con que el pin usado cambie de estado, ya estaría funcionando pues no hay que olvidar que en estado alto, tiene unos 12 volts y en bajo, -12.
Y si, te confirmo que un LED con cátodo y ánodo unido NO puede funcionar.
Estoy de acuerdo con TIGER....No me entra en la cabeza que el desaparecido colaborador que diseño este circuito se haya vuelto loco...Para mi funciona con +/- 12 ,tal como resa la norma RS232 ...Eso si ...el chico tenia malas costumbres tal,como poner 2 diodos en paralelo...sin sus respectivas resistencias limitadoras.(yo le llamo,filosofia CHINA)
03/01/2011 #12


Será así pues. Todo lo que expliqué en el primer post son hipótesis que yo hago intentando entender el circuito....xD

^^
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.