Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/05/2009 #1


Estoy utilizando un dac0800 pero no logro configurarlo
El esquematico que viene en la pagina de los fabricantes no me ha funcionado. ya intente con la etapa de amplificación y sin ella. mi duda es si alguien tiene conocimiento de alguna otra configuracion para convertir de digital a analogico con este dac o si conocen alguno otro mejor.
03/06/2009 #2


el esquematico que viene en el datasheet funciona correctamente. Cual es especificamente tu problema ?
probaste con otro 0800? te adjunto el circuito por las dudas, pero tiene que estar funcionando.

por ahi te podes armar un R ponderadas si es una aplicación simple, en el caso de que no puedas hacer funcionar este dac integrado.
03/06/2009 #3


gracias rulkas, de hecho encontre uno muy similar y si funciono. solo use un opamp 741 y el resto del circuito es practicamente igual. gracias
03/06/2009 #4


me alegro de que hayas solucionado el problema.

un saludo
28/07/2009 #5


hola podrias publicar el que tiene el opamph para compararlo o es el que viene dentro del datasheet
28/10/2009 #6


Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
Hablando del mismo circuito de Datasheet de Dac0800 me surgieron varias dudas.

Yo lo he armado de la siguiente manera:

-Mi fuente que utilice fue a 5 V y en ella conecte el V-,V+, pin 15,pin 14 y el terminal que va a las resistencia de los pin 4 y 2 ( En resumen, donde me pedian un voltaje, lo puse de 5V)

Ahora hablando del proceso en que puse a funcionar mi circuito, hice lo siguiente:

- Primeramente todas mis entradas ( B1-B8) las puse a 5V (nivel alto 1) y en mi salida "Vout" obtuve valor de 0.5 V.Esto quiere decir que puse todas mis entradas en 1 y por lo tanto debe dejar pasar el maximo de voltaje en mi salida

- Despues todas las entradas las puse en -5V (nivel bajo 0) y mi salida fue de 0 V. Esto quiere decir que puse el valor digital (ceros y unos) el cual no deja pasar voltaje en mi salida.

Esto lo digo, porque en cierta forma se podria decir que esta funcionando, pero yo siento que no del todo bien ya que cuando hacia otras combinaciones de las entradas no me daba los valores que debian de ser.

Entonces mi preguntas son:

1.- Alguien pudiera dar mas detalles de como funciona el DAC0800 con respecto a la salida "Vout" y los voltajes "V-" y "V+" ?, seria genial¡¡¡¡.

Tambien un poco mas de referencias de como se arma el circuito, por ejemplo cuantas funtes de voltaje se nesecitan?

o si todo se puede poner a un mismo voltje con un misma fuente?

De antemano gracias
28/10/2009 #7

Avatar de Dr. Zoidberg

Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
ivaxxx dijo: Ver Mensaje
- Despues todas las entradas las puse en -5V (nivel bajo 0) y mi salida fue de 0 V. Esto quiere decir que puse el valor digital (ceros y unos) el cual no deja pasar voltaje en mi salida.
Si pusiste las entradas a -5V te comiste el DAC.
Las entradas son compatibles con lógica TTL, así que no se de donde sacás que hay que conectarlas a -5V!!!
Si leyeras el datasheet verías cuales son los valores válidos para nivel 0 y nivel 1, y todo lo que necesitas para hacer funcionar el DAC.

PD: En la configuración sin A.O. la salida es en modo diferencial.
04/05/2010 #8


Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
Hojo con la tierra virtual ; una pregunta ¿puedo usar un op lm324n? Y lla hice el montaje y no me funciona alguien me puede ayudar?
05/05/2010 #9


Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
Que es lo que no te funciona y de que forma tienes tu circuito? Saludos
06/05/2010 #10


Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
no es que el circuito consiste en usar un adc0804 para hacer una convercion analga digital, esta funcionó muy bien en un principio; pero luego se daño ya que es suceptible a al estática. DEscues... se usó un integrado dac0808; este hace lo inverso pero este nunca me funcionó, usé el circuito implementado en tipical aplication:http://www.national.com/ds/DC/ADC0801.pdf y también use el circuito implementado http://www.national.com/ds/DA/DAC0808.pdf en la tipical aplication y no me sale.

tener en cuenta que uno está a continuacion del otro y que usé una smith trigger entre las salidas del adc y las entradas del dac
14/05/2010 #11


Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
Como estan colegas soy estudiante de electronica, ya he usado varias veces el dac en mis practicas, pero mi inquietus es si es posible alimentar el dac con +5v en v+(pin 13) y el v-(pin 3 ) llevarlo a tierra. Les pregunto porque lo simule en proteus y me funciono y busque en el datesheet pero no consegui ninguna informacion salvo el diseño interno del dispositivo que a mi criterio, no presenta ningun problema si se alimenta solo con voltaje positivo. Corrijanme si me equivoco.Muchas gracias.
02/07/2010 #12


Respuesta: Estoy utilizando un dac0800 pero no logro configurarlo
Haber colegas electrónicos, yo creo que todos tenemos el mismo problema, o por lo menos es similar, para empezar:
1.- Hay que saber si en este DAC0800 las entradas de los pines V+ y V- pueden ser conectadas a 5v la positiva y a tierra la negativa, ojala alguien pueda confirmarlo.
2.- Otra parte donde hay problema es que los pines Vref+ y Vref- no nos queda muy claro cual es su funcion y un ejemplo de que conectarle a esas entradas.
3.- Sabemos que este DAC ala salida entrega corriente, por loq ue debemos poner la configuracion del Op.Amp. para poder ver la salida en señal de voltage, pero cual es la configuracion correcta ???
4.- Y que onda con el pin de COMPENSACION ... ojala exista algun buen samaritano que nos saque de estas malditas dudas ...

Gracias de antemano, ayudennos porfavor !!!
02/09/2010 #13


DAC0800 - Conectado con una sola fuente de +12V.
Este DAC0800 también me dio dolores de cabeza.
Para conectarlo con una sola fuente de 12V hice lo siguiente:

1)
Las entradas de alimentación del DAC son:
  • Pin 13 (V+) conectado a +12V
  • Pin 03 (V-) conectado a GND
2) Los pines Vref+ y Vref- se utilizan para indicarle al DAC cuál es el rango de corriente que se espera en la salida. Es necesario conectar resistencias entre estos pines y los potenciales de alimentación, para establecer una corriente de referencia, de la siguiente manera:
  • Pin 14 (Vref+) conectado a +12V a través de una resistencia de 10k
  • Pin 15 (Vref-) conectado a GND a través de una resistencia de 10k
3) La forma más sencilla de obtener una tensión a la salida es conectar un amplificador operacional con retroalimentación negativa. La resistencia que se utiliza es del mismo valor que las resistencias utilizadas en los pines de Vref.

4)
El pin de compensación se conecta a tierra a través de un capacitor de 100nF.


Fuente:
http://www.national.com/an/AN/AN-1525.pdf

También tengo una simulación en
Proteus 7.6 pero no se usarlo muy bien.
Aquí se las dejo, espero que a alguien le sirva.

Imágenes Adjuntas
Tipo de Archivo: png DAC0800.PNG (43,2 KB (Kilobytes), 977 visitas)
Archivos Adjuntos
Tipo de Archivo: zip DAC0800.zip (12,9 KB (Kilobytes), 909 visitas)
21/05/2011 #14


dudas con el dac0800
Hola, felices tranquilidades ^^...

Podría alguien explicarme porque tuve que poner una resitencia de 4.98kohms en la corriente de referencia a tierra y una de 6.2kohms a mi voltaje de referencia +5V para que mi respuesta fuese lineal? que no deberían ser los mismos valores? mi circuito es el que viene en el datasheet, a excepción de que lo hice a +-5V pues a 15V se calienta y no me da respuesta... según entiendo para +-15V o +-10V la corriente ref debe ser de 2mA y para +-5V de 1mA.
Con los valores antes mencionados de las resistencias que coloqué me da 0V a 00000000, 10000000 me da 1.955V y a 11111111 me da 3.9V , tengo dos dac0800 y los dos funcionan igual...

aa lo olvidaba dando el mismo valor a las resistencias ese 10000000 se mueve a 2.4V con un potenciometro fui incrementando la resitencia y vi que el offset se corregia, y me dio los 6.2k mmm ahora mi incoveniente es que bailan mucho los voltajes pues mis dos fuentes son proyectillos de escuela de esos que le pones 5V y va desde 4.9 a 5.1V xD mmm mejor me buscaré uno de más precisión, chance y cambie algo D: o si!! la conexión con el opamp es la pata 4 del dac la mando al voltaje de referencia negativo del tl081 y la pata 2 a tierra, el voltaje de referencia positivo del tl081 lo lleve tambien a tierra, la retroalimentación se llava a cabo con una resistencia de 4.98 kohms... :/ la alimentación es +-5V

por si piensan que es el opamp, a la salida del dac sin conectarlo aún a este, andive haciendo comprobaciones y la respuesta seguia siendo no lineal :( de hecho ahora que me pongo a pensar ooo checare algo pero es que ya hasta me da cosa moverle al circuito llevo tres semanas queriendolo hacer funcionar :/ y he probado con circuitos propuestos aquí hasta el de alimentación con una sola fuente pero nada :L... así lo dejo? o algo andará mal

solo falta verificar con un osciloscopio la famosa onda senoidal que quiero hacer... u.u

gracias por su atención compañeros


Pd. casi fue lineal :( mejor me quedo con mis resistencias buu

Pd. Pd. hah ahora entiendo porque dice +-LSB haha bueno que me recomendarían lo que pasa es que mi proyecto es monstruoso y quiero usar componentes de montaje superficial nunca he trabajado en mis proyectos con miniresistencias no se si tengan tolerancias similares (me pondré a investigar) por eso quería usar eldac0800 de montaje superficial para este circuito mmm saludos!!!! que esten bien ya me funciona el dichoso dac
03/08/2011 #15


Dad0800
blitz827 dijo: Ver Mensaje
Este DAC0800 también me dio dolores de cabeza.
Para conectarlo con una sola fuente de 12V hice lo siguiente:

1)
Las entradas de alimentación del DAC son:
  • Pin 13 (V+) conectado a +12V
  • Pin 03 (V-) conectado a GND
2) Los pines Vref+ y Vref- se utilizan para indicarle al DAC cuál es el rango de corriente que se espera en la salida. Es necesario conectar resistencias entre estos pines y los potenciales de alimentación, para establecer una corriente de referencia, de la siguiente manera:
  • Pin 14 (Vref+) conectado a +12V a través de una resistencia de 10k
  • Pin 15 (Vref-) conectado a GND a través de una resistencia de 10k
3) La forma más sencilla de obtener una tensión a la salida es conectar un amplificador operacional con retroalimentación negativa. La resistencia que se utiliza es del mismo valor que las resistencias utilizadas en los pines de Vref.

4)
El pin de compensación se conecta a tierra a través de un capacitor de 100nF.


Fuente:
http://www.national.com/an/AN/AN-1525.pdf

También tengo una simulación en
Proteus 7.6 pero no se usarlo muy bien.
Aquí se las dejo, espero que a alguien le sirva.

Hola, yo armé ese circuito pero no importa la palabra digital que le mande al dac, a la salida del 741 siempre obtengo los 12V. No se por que no está funcionando.
Saludos.
03/08/2011 #16

Avatar de pandacba

porque no subes tu esquema ya que asi sin ver nada ni poder medir nada imposible saber
03/08/2011 #17


pandacba dijo: Ver Mensaje
porque no subes tu esquema ya que asi sin ver nada ni poder medir nada imposible saber
Hola, disculpá, ahi subí el circuito.
Gracias por responder.
Saludos.
Imágenes Adjuntas
Tipo de Archivo: png DAC0800.PNG (43,2 KB (Kilobytes), 263 visitas)
13/08/2011 #18


Trabajo en un generador de rampa apenas empece hoy escribo otro código y lo subo espero les sirva esto.

en el adjunto va la simulación en proteus
Archivos Adjuntos
Tipo de Archivo: rar Prueba.rar (15,6 KB (Kilobytes), 332 visitas)
27/05/2014 #19


Estoy utilizando un dac0800 pero no logro configurarlo
Hola amigos del foro. Soy novato en la electrónica, por esto necesito de toda la ayuda posible.
Les cuento que tengo problemas con el DAC0808. Necesito controlar una válvula proporcional cuyo rango de trabajo varía entre 0 y 12 Vcc. He armado un circuito con un DAC0808. Para ir por partes es que comencé a probar el funcionamiento del DAC. Lo he conectado según me indica la hoja de datos con la diferencia que en la entrada de VEE (pin 3) lo puse a GND ya que no tengo una fuente que me entregue una tensión negativa. He simulado con cables el armado de un dato digital en sus entradas para poder medir con un voltímetro las modificaciones que debería obtener a la salida. La prueba la hice colocando todas las entradas a 1 y luego a 0. Me encontré con la sorpresa que el dato de salida no varía... queda todo el tiempo en 12mV. Cuando coloqué el 0 lógico en las entradas, me encuentro con que en cada una tengo una tensión de 160mV. Para poner un 0 en las entradas, las mismas las referencié a GND con una resistencia de 1M. Pese a esto sigo teniendo 160mV en las entradas y la salida no varía. Alguien puede orientarme por favor??? Desde ya muchas gracias!!! ...
27/05/2014 #20


Hola danionkel

Una cosa importante que quizás no notaste al estudiar las hojas de datos del DAC0808 es que en su salida entrega una corriente la cual está relacionada con los estados de sus BIT’s de entrada.

Da una corriente NO un voltaje.

Ahora, probablemente este DAC no pueda manager directamente esa válvula proporcional que mencionas.

saludos
a sus ordenes
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.