Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/02/2012 #1

Avatar de ilcapo

falla en plaqueta al desconectar alimentacion
hola gente del foro queria preguntarles si conocen la causa de porque me esta fallando una plaqueta al desconectarla de la alimentacion de red 220 Vac


la plaqueta es basicamente un pic y a la salida un rele que activa un solenoide... el tema es que al desenchufarla sucede algo raro que me activa nuevamente el temporizador (controlado por el pic) y por ende el solenoide (se activa y desactiva casi instantaneamente), pero a pesar de ser por tan poco tiempo este es un problema grande porque en la rom del pic se guarda el numero de veces que se activa el solenoide,,, entonces cada vez q se desconecta la placa de la alimentacion me esta guardando falsas activaciones!!!!,,, si a alguno le paso esto necesitaria de su ayuda, porque me lo han devuelto varias veces y no logro repararla,, no creo que sea un tema del solenoide ya que se activa el temporizador tambien,,, creo que debe ser algun elemento de proteccion del pic ,,, no se ustedes que opinan ???
muchas gracias saludos !!
25/02/2012 #2
Moderador

Avatar de elaficionado

Hola.

Pon el diagrama del circuito.

Chao.
elaficionado.
25/02/2012 #3

Avatar de DJ DRACO

Por lo general cuando se quita la alimentación de un circuito la falla más común es que deje de funcionar por completo


jajajaja

poniéndonos un poco más serios supongo que te toma la conexión y desconexión de la alimentación como un flanco de subida o bajada, y por ende se activa el timer...

eso deberías solucionarlo colocando los debidos capacitores cerámicos de uno 22pF a 100nF en los lugares correctos para filtrar los rebotes!
26/02/2012 #4

Avatar de ilcapo

hola elafincionado no tengo diagrama del circuito si te sirve te subo una imagen de la plaqueta

hola DJ DRACO donde coloco el o los capacitores ceramicos ?? a la entrada de alimentacion del pic ? o a la entrada del pin del pic que activa el timer ? o a la salida del pin del pic que activa el rele ? o en la entrada de la plaqueta donde esta el transformador de 12Vac ? o en otro lugar XD! ?

gracias por molestarse en responder, saludos!
26/02/2012 #5
Moderador general

Avatar de Fogonazo

ilcapo dijo: Ver Mensaje
.....la plaqueta es basicamente un pic y a la salida un rele que activa un solenoide... el tema es que al desenchufarla sucede algo raro que me activa nuevamente el temporizador (controlado por el pic) y por ende el solenoide (se activa y desactiva casi .........
¿ Como es el dispositivo que te permite "Desenchufar" ?
26/02/2012 #6

Avatar de ilcapo

Hola fogonazo me referia a desenchufar el cable de 220Vac , ese cable va al transformador de 12Vac y luego de rectificarla y regularla (7805) alimenta al pic ,,, cuando desenchufo de la red al cable de 220 me da ese error que me habilita de nuevo al temporizador un ratito hasta que por falta de energia se apaga,, pero como decia ese ratito que se activa es suficiente para guardar en la Rom del pic la falsa activacion

saludos
26/02/2012 #7
Moderador general

Avatar de Fogonazo

Tal vez (Casi con seguridad) al retirar el tomacorriente exista un instante en que se generan transitorios a la desconexión que alteran el funcionamiento de tu micro.

Coloca un interruptor y sobre este una red de Snubber y prueba nuevamente.
27/02/2012 #8

Avatar de DJ DRACO

Claro, es lo que le digo! tiene que haber un rebote o transitorio...

Capacitores y resistencias pull-down para solucionarlo
27/02/2012 #9
Excluido


tenes activado el tema ese que usa el pic de detectar baja tension ??
yo hace años que no hago cosas con pic pero se que tenia un flag que detectaba problemas con la tension .
bueno, la idea es que si la tension cae de a poco el pic como cuialquier ci puede hacer boludeces.
es mas, fijate esta secuencia por dar un ejemplo:

solenoide activado (o sea circuito con mucha carga) >>> la tension cae rapido por lo que pic palma y solenoide se desactiva >>> al desactivarse el solenoide puede ocurrir que la fuente recupere tension y el pic intente reactivar.

por eso debes poner el tema de proteccion por baja tension Y ADEMAS en el programa , cuando inicia darle un delay antes de que se ponga a correr el programa, asi te quedas tranquilo.,

no pregunte..........que salame: vos hiciste el programa, ?? o es una placa que solo estas reparando ??
27/02/2012 #10

Avatar de ilcapo

Fogonazo: bueno gracias voy a investigar un poco eso de la red snubber solo se que es un capacitor y una resistencia , pero si tenes tiempo de hacer algun diagrama (a mano aunque sea) para saber donde conectarlo desde ya muchas gracias

DJ DRACO: perdon por la ignorancia pero que serian las resistencias pull down ??

Fernadob: gracias por la respuesta me va a ser muy util seguramente pero en este caso es una placa que tengo que reparar, si no logro hacerlo con los capacitores tal vez me lanze a programar el pic con estas sugerencias porque activar un rele y un temporizador no debe ser muy complicado, pero no vale la pena perder ese tiempo en una reparacion :p aunque queda mal devolverla sin poder darle solucion como que mi dignidad no me deja ! ja
27/02/2012 #11
Excluido


ah, listo entonces, no problem, por que no pones la etapa de salida , desde el pin del pic a (seguro dispara un T y este maneja un rele o el mismo solenoide) .
pues que bastaria con :

1 -- hacer una etapa de salida con retardo
2 -- si el tema es que el pic mande pulsos que encima los cuente (error de programa) , no te queda otra que jugar con la fuente para evitar eso.....
hacer unas pruebas vos.
un Cf mas grande a ver que pasa por ejemplo.

o hay otra mas >>> le haces un detector de baja tension, apenas la tension baja a un nivel perjudicial para el pic >>> reset a la pata del pic duro y machazo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.