Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

05/03/2015 #1


¿Que función cumple el zener en este circuito?
Hace mucho que me aleje de la electrónica, era un lindo hobby cuando estudiaba en la escuela técnica, ahora he vuelto a retomar haciendo un vigía para mi auto con arduino. La cuestión es que estoy armando el tacómetro y me surge una duda sobre un diodo zener.

El circuito en cuestión en el siguiente.




La resistencia de arriba R1 la calculo para 12V de entrada con el 4N35 consumiendo 1.5V y 10mA
Lo único que se me ocurre es que el zener impide el paso de corriente hasta los 5.1V, pero en ese caso no estaría protegiendo al optoacoplador de sobre tensiones.

En fin, ¿Creen que esta bien colocado el zener ó debería ir en paralelo con C1 y una resistencia para proteger el opto acoplador.?
05/03/2015 #2


Tené en cuenta que el punto de donde se toman los pulsos para el tacómetro, son mucho mas que 12V, no se específicamente cuanto, pero no es 12V ya que es el retorno de la bobina de encendido al momento de la desconexión.
05/03/2015 #3


Si Sergio concuerdo, por eso mismo antes de probarlo me puse a analizar el circuito y veo que ese zener me va a dejar pasar TODO, creo que debería estar en paralelo pero no estoy seguro. Por eso mejor consultar a los que saben. Vivo lejos de las grandes ciudades y los componentes electrónicos no se consiguen, la casa de electrónica mas cercana está a 200km.

Mi idea es conectarle en el cable que va del distribuidor (es a platinos) al la bobina, de ahí mismo sale el cable que va al taco-metro original.
05/03/2015 #4
Moderador general

Avatar de DOSMETROS

En un antiguo sistema de ignición platinos-capacitor-bobina , los pulsos presentes en el primario de la bobina eran de -400 Vpico.

Así que ese circuito con el D1 corta esos picos negativos y con el zener le resta unos volts a los 12 Vdc
05/03/2015 #5


Hola DOSMETROS, muchas gracias por tu respuesta, igual me queda la duda si es correcto usar el zener de esa forma, dado que por lo que entendí va a limitar algunos volts, es decir a los 12V le restara 5.1V quedando 7V en el optoacoplador.

No sería mejor ponerlo en paralelo y así me aseguro que el optoacomplador va a tener siempre 5.1 y así calcular R3

05/03/2015 #6
Moderador general

Avatar de DOSMETROS

De nada che

Si , o quitá D2 y cambiá Dz por tres o cuetro díodos 1N4007 en conducción directa y quizas achicar R3 , habría que probar un poco
05/03/2015 #7
Moderador general

Avatar de Fogonazo

Exactamente ¿ De donde sacaste este esquema ?

05/03/2015 #8


El circuito lo saque de acá http://forums.sohc4.net/index.php?PH...topic=127364.0

Acá aparece otra vez: http://www.mikroe.com/forum/viewtopi...1874&view=next

Me pareció interesante usar un optoacoplador para evitar inferencias en arduino.

Lamentablemente no tengo 1n4007 sólo tengo varios de 4,7v pero por lo que decís es mejor poner varios zener en paralelo en el sentido de la imagen para repartir la corriente que los atraviesa, no estaba tan errado.
¿Algún consejo más antes de poner manos a la obra?
05/03/2015 #9

Avatar de papirrin

como que yo creo que ese circuito va al negativo de la bobina, no en el cable que va de la bobina al distribuidor no?
05/03/2015 #10


Como una imagen vale mas que mil palabras, mas cuando se intenta explicar donde estaba ubicado el coso del cosito, acá les muestro donde tengo pensado conectarlo. Ver imagen en grande



El cable celeste de la bobina va al contacto de la llave, y el marrón esta conectada a los platinos pero no es el que manda la chispa a las bujias, es el que le indica a la bobina cuando esta abierto y tiene que mandar la chispa por el cable rojo.

Para los que no tienen ni idea del tema y quieren aprender un poco este video explica muy bien el funcionamiento de la bobina y platinos de forma muy simple y con imágenes.

06/03/2015 #11

Avatar de miguelus

Buenos días l88_782.

El esquema original, está muy bien pensado, recomiendo que no te dediques a empeorarlo

Todo tiene un porqué, poner ese Diodo Zener en serie con el Opto es muy buena idea...

Recapacita, analiza despacio el circuito y verás y entenderás las razones que ha tenido el diseñador del circuito para hacerlo así.

Sal U2
06/03/2015 #12


Hola miguelus gracias por tu respuesta, no tengo oscilocopio por lo cual no podía saber que pasaba pero por suerte encontré un video en internet de alguien que lo filmo. Si entendes como funciona y sos tan amable de explicarme realmente estaría muy agradecido, soy bastante curioso y esto de armar un circuito y no entenderlo, es como comprarlo hecho en un armazón sellado.



En una imagen





Lo único que se me ocurre es que el primer diodo quita la parte negativa, y le zener en teoría solo deja pasar el pico de tensión (esto es una suposición) osea todo lo que tiene mas de 5.1V pasa. Si es así (me puedo estar equivocando), los otros 300V del pico pasarían directo al optoacoplador.

Evidentemente hay algo que no estoy entendiendo
06/03/2015 #13


Considerá que el pico de tensión es muy corto, por lo cual puede que al opto no le suceda nada, no es que le llegan esos 300v en forma continua como para destruirlo en un instante.
06/03/2015 #14
Moderador general

Avatar de Fogonazo

l88_782 dijo: Ver Mensaje
. . . Lo único que se me ocurre es que el primer diodo quita la parte negativa, y le zener en teoría solo deja pasar el pico de tensión (esto es una suposición) osea todo lo que tiene mas de 5.1V pasa. Si es así (me puedo estar equivocando), los otros 300V del pico pasarían directo al optoacoplador.

Evidentemente hay algo que no estoy entendiendo


No pasan los 300V porque el LED del optoacoplador trabaja por corriente y existe en medio una resistencia que limita esa corriente.
06/03/2015 #15


Hola sergiot, que el pico sea corto creo que es relativo, pero es un punto interesante para analizar, porque por ejemplo por cada vuelta del motor tendría 2 chispas, osea que a 4000rpm tendría.

4000/60= 66 vueltas de motor por segundo

osea 133 chispas por segundo.

Fogonazo dijo: Ver Mensaje


No pasan los 300V porque el LED del optoacoplador trabaja por corriente y existe en medio una resistencia que limita esa corriente.
Bien hice la simulación y con 300V de entrada le llegan unos 60V.




Vuelvo a consular ¿No sería mejor agregarlo un diodo zener de protección?
Como solo tengo diodos de 4.7 tengo que agregar una resistencia limitadora, ¿Que opinan?

06/03/2015 #16
Moderador general

Avatar de Fogonazo

1) Estas empleando una fuente de continua en tu simulación cuando en realidad es alterna, de alta frecuencia y pulsante.
2) Le propio LED del optoacoplador se comporta (Relativamente) como un zener, cuando aumenta la tensión sobre sus terminales adsorbe una mayor corriente y provoca una mayor caída de tensión sobre la resistencia.
3) El simulador que empleas es "Poco serio"
06/03/2015 #17


No te olvides que el periodo de la chispa es muy corto, no importa que sean 2 chispas por segundo, el tiempo de duración es lo importante, sería el duty cicle.
06/03/2015 #18


Actualizo, arme el circuito original en un protoboard y realice la prueba.
La primer prueba conectado al negativo de la bobina el auto no arrancaba aunque el display me reportaba los pulsos.



Al desconectar el cable que va de la bobina al circuito el auto arrancó normalmente, me di cuenta que acercando el cable el circuito comenzaba a marcar, así que opté por colocarlo en el cable rojo que tiene alta tensión y capturar la señal por inducción, los valores fueron correctos aunque muy variables.
Es decir dejo el motor en 2000rpm y el display muestra 1800, 2000, 2500 (sin números redondos) variando constantemente.




Habrá alguna forma de sacarlo conectado al negativo de la bobina haciendo que el auto arranque. O esta es al forma correcta de armarlo.
06/03/2015 #19
Moderador general

Avatar de Fogonazo

Aumenta el valor de R1 a 1,2KΩ y prueba
06/03/2015 #20


Gracias Fogonazo ¿Ese cambio es para poder conectarlo al negativo de la bobina o para que sea estable?

Otra cosa que se me estaba diciendo un compañero del trabajo que a el le paso con su torino hace unos años es que hay que darle varias vueltas sobre el cable de alta tensión para que sea mas estable, eso le paso con el reloj analógico original del tablero.

El fin de semana verificaré con mas tiempo esas dos cosas, prometo algún video para compartir los logros.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.