Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/04/2012 #1


Problema con Amplificador Integrador
Hola a todos,

el motivo por el que abro este tema es que me estoy encargando de realizar un pequeño proyecto para un profesor y hay una parte en la que estoy atascado y no encuentro manera de hacerla funcionar.

Esta parte es un Amplificador Operacional como Integrador, a la entrada yo le pongo una señal cuadrada y a la salida quiero tener una señal triangular. Hasta ahora no estoy consiguiendo que esto pase y el integrador "sigue" perfectamente la señal de manera que no se crean los triángulos.

La frecuencia de la señal cuadrada de entrada es de 3.8 KHz, he estado probando con AO tipo VFA y CFA también he probado con distintos valores de R y C pero no consigo que funcione. Adjunto una imagen de mi circuito y de las señales.

Si alguien me pudiera echar una mano lo agradecería mucho ya que estoy atascado en este punto y me frustra bastante que me pase con un circuito sencillo.

Un saludo y gracias por adelantado,
Óscar
10/04/2012 #2


La resistencia deberias conectarla en serie a la entrada negativa...no en paralelo con el condensador. Ya me contarás.
10/04/2012 #3


Hola Kalamarus,

primero de todo gracias por responder.

He conectado la R en serie a la entrada negativa pero el integrador continua sin funcionar, te adjunto la captura para que lo puedas ver. El problema es que cuando la señal cuadrada sube, la salida del integrador tendría que ir subiendo poco a poco (dependiendo del valor de C) y no pasa. Sube muy rápido y para bajar si que baja más lentamente.

Saludos y gracias,
Óscar
Imágenes Adjuntas
Tipo de Archivo: jpg int.jpg (32,6 KB (Kilobytes), 33 visitas)
10/04/2012 #4

Avatar de Eduardo

oalvarea dijo: Ver Mensaje
...Esta parte es un Amplificador Operacional como Integrador, a la entrada yo le pongo una señal cuadrada y a la salida quiero tener una señal triangular. Hasta ahora no estoy consiguiendo que esto pase y el integrador "sigue" perfectamente la señal de manera que no se crean los triángulos.
La frecuencia de la señal cuadrada de entrada es de 3.8 KHz, he estado probando con AO tipo VFA y CFA también he probado con distintos valores de R y C pero no consigo que funcione. Adjunto una imagen de mi circuito y de las señales.
- Lo que mostrás en la imagen no es un integrador. Te falta una resistencia entre e- y la fuente de señal.

- Agregada esa resistencia, tomate la molestia de calcular los valores de Rin,Rf y Cf , porque con .16n y 4k7 estás a kilómetros de que se comporte como integrador a 3.8kHz.
10/04/2012 #5


Gracias por contestar Eduardo.

Añado pues la R en serie, debo mantener la que está en paralelo?

Mi profesor no me ha proporcionado teoría del Integrador y lo que he encontrado en la red solo referencia al AO ideal, he buscado en el foro pero no encuentro las fórmulas para elegir los valores correctamente de las R y C (solo he encontrado la imagen que te adjunto)

Me podrías pasar algún link o documento con esas fórmulas de diseño?disculpa mi desconocimiento sobre el tema, pero es que soy muy principiante en esto y me veo un poco perdido.

Saludos y gracias,
Óscar
Imágenes Adjuntas
Tipo de Archivo: gif integrator_626.gif (25,6 KB (Kilobytes), 39 visitas)
11/04/2012 #6


Hola de nuevo, he encontrado el pdf que adjunto y en las páginas 16-17 aparece la expresión t = R*C, teniendo en cuenta que me interesa una f=3.8kHz -> t=0.26ms, considerando una R=1k y aislando C, obtengo C= 0.26F, es correcto el procedimiento que estoy siguiendo?

ahora estoy fuera de casa y en cuanto llegue probaré en LTSpice si funciona.

Cualquier ayuda será bienvenida.

Saludos y gracias,
Óscar
Archivos Adjuntos
Tipo de Archivo: pdf analogico_guia.pdf (193,8 KB (Kilobytes), 35 visitas)
11/04/2012 #7


Hola,
Creo que el cálculo te da 260nF, 0,26F es algo que casi no existe de lo grande que es. Podes poner dos condensadores de 470nF en serie para obtener ese valor.

No recuerdo lo de la frecuencia, pero creo que está bien.

Saludos
11/04/2012 #8

Avatar de Eduardo

oalvarea dijo: Ver Mensaje
he encontrado el pdf que adjunto y en las páginas 16-17 aparece la expresión t = R*C, teniendo en cuenta que me interesa una f=3.8kHz -> t=0.26ms, considerando una R=1k y aislando C, obtengo C= 0.26F, es correcto el procedimiento que estoy siguiendo?
- C no es 0.26F sino 0.26uF = 260nF

- Con 3.8kHz, t no es 0.26ms sino 0.13ms (se supone que vas a usar una onda cuadrada-cuadrada)

- No puede hablarse de que si está bien o mal el procedimiento porque no estás siguiendo ninguno. Simplemente ves una fórmula y le mandás dedo a la calculadora.
Primero tenés que decidirte que amplitud va a tener la cuadrada y que salida pico a pico querés.

ahora estoy fuera de casa y en cuanto llegue probaré en LTSpice si funciona.
Claro que va a funcionar. Mientras no te delires con la amplitud de entrada y satures el AO vas a ver una triangular.
06/10/2012 #9

Avatar de anthony123

Buenas:

Actualmente estoy trabajando con un integrador (con componentes no ideales). Como es bien sabido, para que el opamp no se valla a Vsat se coloca una resistencia en paralelo con el capacitor, lo que se asemeja a un amplificador inversor.

Justamente es lo que me está pasando, en lugar de integrar el circuito se comporta como un amplificador y empieza el !CAOS!

Existe algún otro truquillo para eliminar este desagradable hecho?

Saludos y gracias!
06/10/2012 #10

Avatar de Eduardo

¿Que frecuencia de corte le diste y en que rango estás trabajando?
06/10/2012 #11

Avatar de anthony123

Con lo de la frecuencia de corte tengo dos criterios, como se trata de la realimentacion de un clase D:

1.- En DIY audio hablan de una constante de tiempo RC mayor o igual a 20mS para el capacitor y la resistencia anti-saturacion (es decir, la que se pone en paralelo con la C).

2.- En un paper hablan de una F de 60KHz para una fundamental ubicada entre 250 y 300Khz.

Además de integrador, el operacional (TL081, alimentado a ±9V) funciona como restador para la señal de audio y la señal que sale del totem polem (también denominado pre-filter feedback).

Saludos y gracias!
06/10/2012 #12

Avatar de Eduardo

1.- En DIY audio hablan de una constante de tiempo RC mayor o igual a 20mS para el capacitor y la resistencia anti-saturacion (es decir, la que se pone en paralelo con la C).
2.- En un paper hablan de una F de 60KHz para una fundamental ubicada entre 250 y 300Khz.
Está bien, es usar una frecuencia de corte por lo menos unas 5 veces menor que la mínima frecuencia de interés.

Además de integrador, el operacional (TL081, alimentado a ±9V) funciona como restador para la señal de audio y la señal que sale del totem polem (también denominado pre-filter feedback).
Pero al restador, le pusiste en la rama no-inversora lo mismo que en la inversora? Porque si no, no te va a integrar la diferencia ni por casualidad.
06/10/2012 #13

Avatar de anthony123

http://users.ece.gatech.edu/mleach/e...01/ClassD2.pdf

Fijate en la figura número 5. La cuestion es que estoy un poco confundido con lo del integrador, es decir, como le estoy introduciendo dos señales con frecuencias totalmente alejadas en el espectro (audio y HF) no sé que criterio tomar:

Por una parte 1/(2*pi* Rf*Cf ) debe estar ubicado por el orden de 60Khz, sin embargo como combinaria eso con la parte de audio que viene por R2?

Tomando Rf=47KΩ, Cf me da un valor de 56pF, lo que ameritaria un resistor en paralelo de casi 360MΩ.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.