Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/04/2008 #1


problema con LM324
hola a todos,

pues mi problema viene con el LM324, es un integrado con 4 A.O dentro, yo por ahora solo uso uno de ellos, la alimentación la hago con Vcc a 12v y GND a tierra ( a diferencia del 741 creo que este va sin alimentacion simétrica)
La configuracion es en diferenciador con ganancia 1, por lo que todas las resistencias usadas son iguales, de 1kohm.
El problema: al poner una tensión de 72mV en V+ y de 119 mV en V- , el resultado a la salida no es (V+)-(V-), ademas, puedo variar el valor de V+ sin que varie el valor de la salida, por el contrario, si vario el valor de V- si que varia la salida.
el Montaje lo he hecho según la configuración del dibujo que he adjuntado

Gracias de antemano.
R3, R4, R5 y R26 son de 1K y lo otro son unos divisores de tensión que me dan las tensiones anteriores. Por si vale de algo:
PR1' =1k, PR1=1K
R1=20K, R2=26,9k
07/04/2008 #2


Ignacio, me parece que el problema que estás teniendo es que al varias las resistencias Pr1 y Pr1' para cambiar el voltaje en V+ y V- esto agrega una resistencia en serie a R3 (hacé el thevenin de tus divisores de tensión). La tensión a la salida depende de los valores de R3, R4, R5 y R26, así que no sólo cambiás la tensión de entrada sino que también cambiás la ganancia a la vez.
Probá usar dos OP AMP más del integrado que tiene 4 y usalos como buffers para la entrada de tu amplificador diferencial a ver si mejora.

Te adjunto el amp diferencial con la fórmula completa como referencia.

Slds...
07/04/2008 #3

Avatar de Ardogan

Y está bien....
Está bien, la salida no va a ir a valores de tensión negativos, o mejor dicho, no va a ir a valores de tensión más negativos que la tensión que va en GND (V- en realidad, porque si fuera con fuente dual acá iría la alimentación negativa).
Cuando se utilizan operacionales "single-supply" se suele utilizar una referencia de tensión (puede ser un simple divisor resistivo, lo podrías hacer con los operacionales que te sobran en el integrado) para evitar ese problema, es decir, se lleva el cero a la tensión de referencia.
Todo lo que tendrías que hacer es poner el terminal de R26 en vez de a tierra, ponerlo a la tensión de referencia.
También tené en cuenta que la salida puede ir hasta (V+) - 1.5V.

Si usas 5V yo pondría una referencia de [(Vsal-max) - (Vsal-min)]/2 = (3.5 - 0) / 2 = 1,75 V (un poco menos, el 0 en realidad son 30 mV o algo así).

Otra cosa, si la tensión de salida va a trabajar cerca de 0 V, se recomienda poner una resistencia en serie >100ohms en la salida, para limitar la corriente del pin de salida (con 100 ohms sería 5/100 = 50 mA, fijate en la hoja de datos cuál es la máxima corriente de salida que puede dar el LM324).

Entonces en resumen, en la salida nunca vas a tener una tensión más alla del rango (V-) a (V+ - 1.5V), con 5V sería desde aprox. 0 a 3.5V)
07/04/2008 #4


Aaaah, perdón, no me di cuenta de que V- estaba por arriba de V+... Ardogan tiene razón, interpreté cualquier cosa. Mis disculpas.

Slds...
07/04/2008 #5


muchas gracias a ambos, tanto por la celeridad como por la claridad en las explicaciones. Mañana por la mañana probaré esas modificaciones y os diré que tal me ha ido. Muchas gracias por todo.
Un saludo.

Espero que mañana os de buenas noticias.
08/04/2008 #6


hola!

Pues hice los cambios que me indicasteis, y ahora si que varia la tension a la salida cuando vario cualquiera de los dos ponteciometors, pero aun no me va bien, por que con los siguientes valores:
PR1 427mV
PR1' 422mV

a la salida me da 0,97v, y ese valor ademas de ser + en vez de -, no se corresponde con la diferencia (V+)-(v-), ademas tengo el problema de que por ejemplo, si yo PR1 y PR1' los ajusto sin conectarlos al A.O a unas tensiones de 211mV y 187mV, en el momento que los conecto a las entradas V+ y V- esas tensiones se suben a 427mV y a 422mV.

Los cambios que hice fueron la resistencia en serie a la salida de 250ohm y la patilla de R26, en vez de a tierra la he puesto a una V de 1,66v (pero solo esa patilla, y lo hice con un divisor de tension)

Un saludo y gracias.
08/04/2008 #7

Avatar de Ardogan

Bueno, ahora voto por la respuesta de Sigma-O. Es cierto lo que él dice arriba, que al mover pr1 y pr'1 estás modificando la ganancia del circuito.
Creo que lo que proponemos los dos en conjunto es algo como:

[img]LM324.jpg[/img]

Fijate que no se carga a la señal (los potenciómetros), la tensión de referencia también es necesario pasarla por operacional, porque si va por un divisor resistivo simple también está agregando resistencia serie de la pata + del opamp a tierra, y eso cambia la ganancia.

De esa forma, a la salida las tensiones negativas te quedan en el rango 0 a 1.75V y las positivas 1,75 a 3.5V. Y la diferencia máxima entre las tensiones de entrada medible es V1-V2 = +-1.75V, si hay más diferencia de tensión el opamp C va a saturar. Podrías expandir el rango dándole ganancia <1 al opamp C, por ejemplo, cambiando R6 y R5 a 470 ohms el rango sería ahora V1-V2 = +- 3.7V.

Vsal = (V2-V1) * R6/R3 + Voffset

El rango también lo podés controlar con el divisor que hacés con los potenciómetros de entrada (relación entre R1 y RV1 y entre R2 y RV2).
Imágenes Adjuntas
Tipo de Archivo: jpg lm324_110.jpg (29,6 KB (Kilobytes), 1370 visitas)
08/04/2008 #8


Hola otra vez!

he introducido los cambios, es decir que ahora la salida de los divisores de tension las paso cada una de ellas por un seguidor de tension y de ahi a R3 y R5, y lo mismo he hecho para la R26 que he usado otro divisor para la tension de referencia. He observado que ahora, si la tension en la salida de los potenciometros era de 185mV, ahora si que se mantiene esa tension aunque mi problema ahora es que esos 185mV se mantienen a la entrada del seguidor de tension y tambien a su salida, pero en el momento en que conecto la salida de los seguidores al diferenciador, esa tension pasa de 180mV a 666mV,
De esta forma a R3 y a R5 me llegan 675mV y a la salida tengo 1,66v (que curiosamente es igal a la tension de referencia que uso en R26)

gracias.

Si en R26 en vez de tension de referencia, lo pongo a masa directamente la tension se mantiene aunque conecte las salidas de los seguidores al dirferenciador, pero aun a pesar de eso, la salida del diferenciador no se corresponde con (V+) - (V-)

Gracias
08/04/2008 #9


Ignacio, el OP-AMP que conectaste como diferenciador va a tener a su salida una tensión igual a (V2-V1) + Vref si R3, R4, R5 y R26 son iguales (Vref es la tensión que ajustás como referencia), tal cual lo dijo Ardogan en su post. Por lo tanto si V2 = V1 a la salida vas a tener nada más ni nada menos que Vref (que es tu caso por lo que decís que "a R3 y a R5 me llegan 675mV).
Por otro lado, me parece muy raro que te cambie la tensión a la salida de los buffers cuando los conectás, armaste el circuito tal cual te lo pasó Ardogan? Si lo armaste diferente posteá un diagrama.

Slds...

PD: hice alusión a las resistencias según la nomenclatura del circuito original porque es la que usó Ignacio en el último post, pero pongamonos de acuerdo así no hacemos matete . Propongo que sigamos con las nomenclaturas del circuito de Ardogan que es el más completo.
08/04/2008 #10


me parece estupendo lo de tomar un cocuito como base. Yo el que he montado es el mismo que el de ardogan, salvo en R9 que no la tengo.
me lio un poco en dos cosas,
- la tension de referencia que uso de 1,66v es como si en vez de tomar el 0 como referencia tomo el 1,66v ¿no? pero no entiendo por que se hace eso asi.
-por otra parte no entiendo a que se refier ardogan con: "De esa forma, a la salida las tensiones negativas te quedan en el rango 0 a 1.75V y las positivas 1,75 a 3.5V. Y la diferencia máxima entre las tensiones de entrada medible es V1-V2 = +-1.75V, si hay más diferencia de tensión el opamp C va a saturar"

por ultimo, segun el circuito de ardogan, es logico que al tener las mismas tensiones en R3 y R4, a la salida tenga la tension de Vref, pero es que si yo vario el potensiónmetro VR2 o el VR1, la salida no cambia. Es decir, la salida a la entrada del seguidor de tension varia, pero a la salida se mantiene invariable a 667mV en ambas salidas (patillas 1 y 7 del diagrama) (esto sucede mientras tengo la salida conectada al diferenciador, si la desconecto la variacion a la entrada del seguidor se ve reflejada a la salida)

Gracias
08/04/2008 #11


Ignacio, respecto de la tensión de referencia se hace así porque el operacional es diferencial, esto quiere decir que la salida va a ser positiva o negariva según sea postiva V+ respecto de V- o lo contrario. El probleme de no tener una alimentación simétrica es que tu circuito puede darte valores de tensión únicamente comprendidos entre Vcc (positivo de alimentación) y 0V (negativo de alimentación). Si tu tensión de referencia es el negativo, es decir 0V, la salida de tu operacional nunca va a ser menor que 0V por más que se esfurece.
Por este motivo se le da un valor de referencia normalmente situado en Vcc/2 y el "cero" del operacional va a ser ese valor. Él te va a dar una salida "positiva" o "negativa" respecto de ese valor de referencia.
Por eso Ardogan bien dice que los valores positivos van a estar por arriba de 1.75V (positivos respecto de la referencia) y los valores negativos estarán por abajo de 1.75V (negativos respecto de la referencia).

Respecto del segundo problema, la verdad es que no sabría qué decirte, es raro. Asegurate que los buffers tengan la pata (-) conectada directamente con un cable a la salida y a nada más, ni resistencias al negativo ni nada, tal cual está en el diagrama.

Slds...
08/04/2008 #12

Avatar de Ardogan

IgnacioD6 dijo:
me parece estupendo lo de tomar un cocuito como base. Yo el que he montado es el mismo que el de ardogan, salvo en R9 que no la tengo.
R9 la puse para simbolizar una carga conectada a la salida del último opamp, para no dejarlo abierto.

IgnacioD6 dijo:
- la tension de referencia que uso de 1,66v es como si en vez de tomar el 0 como referencia tomo el 1,66v ¿no? pero no entiendo por que se hace eso asi.
Exactamente, el "cero" (la salida cuando V1=V2) va a ser la tensión de referencia. Se hace así para repartir el rango de salida por igual. Si no estuviera la referencia pasará que cuando la tensión en el pin 3 sea mayor que en el pin 5 la salida va a ser siempre 0, no importa cuanto mayor sea la tensión en el pin 3. Con la tensión de referencia podemos ver que la salida va a responder linealmente (no va a saturar) mientras que
(tensión pin 3) - (tensión pin 5) < -Vref (=-1.66V)

IgnacioD6 dijo:
-por otra parte no entiendo a que se refier ardogan con: "De esa forma, a la salida las tensiones negativas te quedan en el rango 0 a 1.75V y las positivas 1,75 a 3.5V
Sí, está poco claro, tuve que decir que era comparándolo con el integrado trabajando en "dual-supply", sin tensión de referencia. Las tensiones que en dual-supply serían negativas en la salida del último op-amp van ahora al rango 0 a Vref.
Ahora edito el post anterior.

IgnacioD6 dijo:
Y la diferencia máxima entre las tensiones de entrada medible es V1-V2 = +-1.75V, si hay más diferencia de tensión el opamp C va a saturar"
Me refiero a la diferencia máxima entre (tensión pin 3) y (tensión pin 5), es decir, la salida va a reflejar cambios en las entradas mientras que

(tensión pin 5) - (tensión pin 3)< (Vcc - 1.5) - Vref

y (tensión pin 5) - (tensión pin3) >-Vref

Por eso, si uno quiere que quede simétrico se elige

Vcc - 1.5 - Vref = Vref => Vref = (Vcc - 1.5)/2

Bueno, eso respecto de las dudas. Ahora veo que los valores de entrada a los op-amp, es decir, los que medís en la salida del potenciómetro son bajos (100 mv o menos).
Con esos valores bien podría ser que molesten las tensiones de offset (si bien son bajas) y corrientes de polarización.
Otra cosa que cambiaría entonces son las resistencias que en tu primer post nombraste R1 y R2 a valores más bajos para que cuando muevas los potenciómetros haya cambios más grandes de tensión.
Si esas resistencias las pones a 2Kohm, la tensión máxima que salen de los potenciómetros serían de 5/3 x 1 = 1.66 V, lo que vendría bárbaro, porque ahí te aseguras que cualquiera sea la posición de los potenciómetros siempre estás trabajando dentro del rango del último operacional.

¿Se pueden cambiar esas resistencias?
09/04/2008 #13


si, puedo camiar amas resitencias, pero la salida del operacional al hacer la diefencia me interesa en mV. Me explico, el sistema es así: (segun el circuito que puse en el primer post)
- la red de PR1' es una red de ajuste, que como maximo me dará 200mV, en principio la fijare a 180mV

- la red PR1 es una red en la que PR1 es un potenciometro de 10k y 10 vueltas, es decir 1k por vuelta aprox. Yo lo situaré de forma que a 180º de giro del potenciometro tenga 180mV.

- el operacional lo que me hace es: tengo en la red PR1' 180mV fijos que no varian (le he puesto 200mV para un posible ajuste), solo varian los de PR1, de forma que si por ejemplo muevo 90º el potenciometro PR1, su resistencia bajará a la mitad y con ello tendré una tension de 90mV, de esa forma a la salida del operacional me indicará 180-90= 90mV que se corresponden con los 90º girados.

Espero a ver aclarado algo.

por otra aprte, yo he ido probando cosillas y tengo algunos datos:
una vez que he entendido lo de la tension de referencia, la he quitado y puesto a 0v la patilla de R26, con la condicion de que (v+)-(v-) sea menos que 0, es decir un valor negativo, que al quedar invertido seria positivo, es decir en un rango de 0 a 5v, y de esta forma me va bien (creo, aun he de hacer mas pruebas), si uso la tension de referencia, la salida de los buffer se me bloquea, no se por que pero no se corresponde con su entrada, y en ambos buffer la salida es la mima independientemente de que la entrada en amis es distinta.

gracias por la ayuda que me prestais.
09/04/2008 #14


he hecho unas pruebas para confirmar lo que dije antes de que con la tension de referencia en GND me iba bien, lo que he obtenido:
- Siempre que V+ es mayor que V-, la tension de salida semantiene fija a 96,9 mV, es lógico que no varíe porque: Vo=-[(V+)-(V-)] será de valor negativo, y ese valor a la salida no lo puedo tner con la tension de referencia a 0, ya que solo tendré entre 0v y 5v
- Si V+ es menor que V- el sistema funciona muy bien, es decir, si tengo:
V+=78mV
V-=166
teorico: Vo=-[78-166] = -(-88 )=88 y en la practica me sale 87,3mV

pero tengo algo raro en los extremos:
caso I:
V+=138,4mV
V-=166
teorico: Vo=-[138-166] = -(-28 )=28 y en la practica me sale 77,3mV
casoII:
V+=61mV
V-=166
teorico: Vo=-[61-166] = -(-105)=105 y en la practica me sale 103mV lo cual es aproximado, pero puedo bajar el valor de V+ sin que varie la salida (queda fija a 103mV) esto es debido a que si bajo la entrada del buffer de V+ (de 61,mmV a 0mV) que a la salida del buffer se me queda la tension en 61,1mV que es la que entra en el operacional que hace la diferencia.
09/04/2008 #15

Avatar de Ardogan

Aaaaahhhh, eso es otra cosa. Si el potenciómetro pr'1 es de ajuste es como decís, fijándolo apropiadamente no hace falta armar la referencia y nos ahorramos eso.

Ahora lo raro es que al no usar la referencia y meter 0V la cosa ande. Estuve simulando y con la tensión de referencia se comporta como habíamos mencionado antes. Quizás el problema fué en la conexión para obtener la tensión de referencia.

Pero bueno, es irrelevante ya que no precisás la tensión de referencia en realidad.

Sí insisto con que la señal (la del potenciómetro multivueltas) convendría trabajarla con valores más altos si se puede (que entre en vez de 0 a 180 mV, 0 a 1.8V por ejemplo). Para no tener que pensar en la tensión de offset de los opamps, de 2mV. Aunque también eso se puede compensar con pr'1, pero siempre está la desviación de la tensión de offset (por temperatura principalmente).
Con pr1 te interesa medir el ángulo de 0 a 180º solamente (1/2 vuelta)?.

Bueno, si te va bien así como lo hacés ahora lo dejamos ahí. Tu problema original en definitiva se arreglaba poniendo seguidores de tensón a los potenciómetros.

Un placer poder dar una mano (si bien se enredó todo con la tensión de referencia cuando no hacía falta, tendría que haberlo preguntado al principio).

Saludos y a ver como te fue.
09/04/2008 #16

Avatar de Ardogan

Mi último post lo hice antes de ver tu último post.
Sería conveniente que mandes un esquema de como tenés conectado todo, no te olvides de los valores de las resistencias (de que tolerancia son?).
La salida la tenés conectada a algún lugar?, eso también puede ser importante.
La salida mínima va a andar cerca de 20mV (en la hoja de datos, V0L parámetro "output voltage swing") por las propias limitaciones del opamp.
09/04/2008 #17


desconcertado
adjunto os envio el diagrama del circuito que he montado, y a continuacion os doy los valores obtenido en las pruebas:

V1= 191mV V2=180mV Vo= 106mV
V1= 191mV V2=82mV Vo= 106mV
V1= 191mV V2=17mV Vo= 106mV

V1= 100mV V2=181mV Vo= 82mV
V1= 110mV V2=181mV Vo= 72mV
V1= 82mV V2=181mV Vo= 100mV
V1= 66mV V2=181mV Vo= 115mV

Además, V1 no baja de 66mV, es decir, a la salida de P2, bajo la tension y el buffer va bien, hasta que llego a 66mV, a partir de ahi, puedo bajar la tension a la salida del potenciometro, sin que se refleje a la salida del buffer.

Siento molestar tanto, pero estoy desconcertado, yo pensaba que
Vo=-[(V+)-(V-)] en mi caso Vo=-[(V2)-(V1)] por tanto al dejar la referencia a GND, en caso de que V2>V1, la salida seria negativa, y como esto no es posible, el sistema no funcionaria, pero veo que es al revés, que se cumple para V2<V1

Gracias.
Imágenes Adjuntas
Tipo de Archivo: jpg diagrama_241.jpg (122,0 KB (Kilobytes), 108 visitas)
09/04/2008 #18


por si vale de algo...
esa es la placa de montaje, por si vale de algo. Por cierto, los divisores los hice asi para ahorar resistencias y ver todo mas claro.
Imágenes Adjuntas
Tipo de Archivo: jpg placa_186.jpg (135,8 KB (Kilobytes), 74 visitas)
09/04/2008 #19

Avatar de Ardogan

Re: desconcertado
IgnacioD6 dijo:
Siento molestar tanto, pero estoy desconcertado, yo pensaba que
Vo=-[(V+)-(V-)] en mi caso Vo=-[(V2)-(V1)] por tanto al dejar la referencia a GND, en caso de que V2>V1, la salida seria negativa, y como esto no es posible, el sistema no funcionaria, pero veo que es al revés, que se cumple para V2<V1
La salida del último operacional, que está en configuración diferencial, va a ser Vo = (V2 - V1) * Rf/ Rin; con Rf = resistencia realimentación = resistencia de pin (+) a tierra; y Rin = resistencia de V1 a terminal - = resistencia de V2 a terminal +

Es correcto lo que decís, los cambios a la salida se van a reflejar mientras sea V2>V1
Por eso en el primer conjunto de valores que das:

IgnacioD6 dijo:
V1= 191mV V2=180mV Vo= 106mV
V1= 191mV V2=82mV Vo= 106mV
V1= 191mV V2=17mV Vo= 106mV
Está bien que sea así porque V2<V1. Fijate que ahí pasa lo que decía antes, que la salida del último operacional no llega a ir a 0 V, sino un valor un poco más alto, que en tu caso es 106 mV.

Por lo tanto vas a empezar que la salida varia con las entradas cuando V2>V1 + 106 mV

La salida nunca va a ir a un valor más bajo que esos 106 mV.
Pero tené en cuenta también que eso mismo pasa con los buffers de entrada, es decir, si les metés un tensión menor a 100mV (o el valor mínimo que puedan dar a la salida, digo 100mV por ser un valor parecido al del último operacional y redondear) los buffers a la salida no van a ser iguales a la entrada, sino que se van a "clavar" en 100 mV.
Otra razón para no trabajar con tensiones pequeñas a la entrada de los buffers (seguidores de tensión, los operacionales que se conectan a los potenciómetros).

Algo rápido para solucionar eso sería que en vez de hacer:

5V ------- resistencia ------potenciómetro ------tierra

usar

5V ------- potenciómetro-------resistencia--------- tierra

para que la tensión minima que entra los buffers sea >0. En otras palabras, en los circuitos de entrada intercambiar tierra y 5V.

Aaaahhhh, ahí veo en el protoboard que en la entrada no pusiste la resistencia fija, solo los potenciómetros.

Bueno, igual no está mal si tenés en cuenta que no podés usar potenciómetro por debajo de una posición mínima (la que sea que de 100 mV = umbral inferior de tensión de salida de los buffers), y no podés pasar de una posición superior (que la da tu potenciómetro de ajuste, que en los mensajes anteriores decías que era de 166 mV).

Y bueno, remarco que a la salida del operacional que hace la resta tampoco vas a lograr tensiones menores a los 106mV que mediste.
09/04/2008 #20


ok, creo que ya me quedo mas claro. Solo una cosa mas, los 106 mv a los que tu haces referencia vendrian a ser el "output voltage swing" que me mencionaste antes, y eso es algo porpio del operacional. He mirado la hoja de caracteristicas y solo me pone el minimo de 26mV, supongo que el valor que me da a mi es normal.

Gracias.
Mañana trabajaré mas en ello a ver si lo termino ya todo.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.