Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/04/2008 #21

Avatar de Ardogan

Exacto, el output voltage swing traducido es rango de tensión de salida, que según la hoja de datos del LM324 el valor inferior del rango es máximo 20mV (típico 5mV) y el valor superior del rango es Vcc-1.5V.

Habría que ver por qué en tu caso llega a 106mV y no a 20mV o menos. Si me doy cuenta por qué aviso (tal vez por tolerancia en las resistencias, tendría que verlo).
10/04/2008 #22


hola de nuevo,

considerando esos 106 mV, he pensado en cambiar la estrategia un poco, es decir, que yo antes intentaba una variacion de 0 a 180mV, pero ahora pense en tomarlapor ejemplo de 100mV a 280mV. y tengo que: (los asteriscos son marcas para aclaraciones, no signos de multiplicar)

V1= 80,7mV V2=179mV Vo= 100mV
V1= 80,7mV* V2=259mV Vo= 168,2mV
V1= 80,7mV** V2=360mV Vo= 232mV

*no se porqué, pero al variar el valor de V2 de 179mV a 259mV, la salida del buffer de V1 ha cambiado sola, ha pasado de 80,7 a 91,7, estando su entrada a 80,7mV
** lo mismo que antes, he variado V2 de 259 a 360 y la salida del buffer V1 ha cambiado sola a 127mV mientras que a la entrada del buffer tengo 80,7mV

Además, los valores de Vo se corresponden con los de las salidas del buffer cambiadas.

Gracias.
10/04/2008 #23

Avatar de Ardogan

Estaba viendo la protoboard, y no creo que solucione nada del problema, pero las entradas de los opamps que no se usan (1 solo en este caso) siempre conviene dejarlas conectadas a algo (+5V, tierra, cualquier lugar no importa porque no toman corriente y no representan carga para el circuito al que se conecten), pines 9 y 10 si veo bien.
Luego no veo ningún error en el proto, si veo que alimentaste el LM324 con 12V pero eso no debiera cambiar nada.
Para esas diferencia entre entradas y salidas de los buffers, lo único que se me ocurre es algún mal contacto... no sé, debe ser algún problema de armado, en la teoría funciona. Un capacitor electrolítico en los 5V que entran a la placa, y en los 12V que van al LM324 (1uf, 10uf, no importa, lo que tengas).
En fin, no sé por qué pasan esos cambios en los buffers, veremos si alguien más puede decirnos por qué.
Saludos
10/04/2008 #24


Yo estoy más perdido que turco en la neblina... qué raro que cambie la salida de los buffers, nunca me pasó algo así. Tampoco he usado el LM324 en niveles de tensión tan chiquitos, siempre los usé en el orden de los volts.
Lo único que se me ocurre, mirando la protoboard, es que intentes eliminar cables, por ejemplo hay un par de resistencias que en cambio de estar conectadas entre pata y pata están conectadas a una pata, de ahí a un cable que va a la otra pata. Intentá porner la resistencia sola.
Igualmente, es un manotazo de ahogado, no creo que cambie nada, pero bueh, es cosa de probar y ver que pasa. Eso sí, si le encontrás la vuelta contanos cuál era el misterio, por favor! jaja...

Si se me ocurre alguna idea escribo.

Slds...
10/04/2008 #25


gracias a ambos por vuestro interés. En la placa podia poner menos cables, pero la monte con mas cables para que la foto se viese clara, por que sino quedaba todo muy junto. Esta noche probaré a quitar esos cables y a poner la alimentacion en el op que no uso, asi como los condensadores.... en caso de no solucionar nada, mañana ire a la universidad a ver que me dice el profesor.

Gracias.

Pd: en cuanto tenga la solucion os la pondre aqui.
12/04/2008 #26


hola de nuevo,

Aun no pude hablar con el profesor, pero como era sábado me dedique a probar el sistema, lo desmonte todo, lo cambie de sitio en la placaboard (por si algo fallaba en ella, y los resultados son:
para V+>V-
en el orden de los voltios el sistema funciona perfectamente, metiendo en V+ valores del orden de 5v, y en v- valores de 2v, la salida de Vo se correspondia con la teorica.
si continuo con valores de voltios en amas entradas, diferenciados en milivoltios, siempre y cuando la diferencia sea superior a 662mV, el sistema va bien, por ejemplo con un margen de 778mV a 864mV el sistema ha ido muy bien.

Lo unico que no entiendo es por que he de mantener esa diferencia minima entre V+ y V- de 662mV, (la salida del operacional no baja nunca de hay.

si conecto V+ y V- a tierra, la salida de unos 5mV.
si conecto V+ y V- a la misma tension, la salida es de:
12V en ambos, a la salida 0,87
3,28V en ambos, a la salida 0,707
2,59V en ambos, a la salida 0,679
2,13V en ambos, a la salida 0,670
1,44V en ambos, a la salida 0,655
0,89V en ambos, a la salida 0,600
0.02V en ambos, a la salida 7mV

Gracias.
14/04/2008 #27

Avatar de Ardogan

Menos sé ahora que puede estar andando mal... las resistencias en el último opamp son todas del mismo valor?.
Podría pensar en que el rechazo de modo común puede estar causando eso... pero no, es de 65dB mínimo en la hoja de datos, para 2V de modo común explicaría menos de 1mV en la salida...
Si fuera problema de offset también sería algunos milivoltios, no fracciones de volt como las que mediste.
No tenés otro LM324 a mano para ver si no es problema del chip?
No se me ocurre qué es, si encontrás el problema hacenos el favor de comentarlo, que le puede pasar a cualquiera de nosotros.
Saludos
14/04/2008 #28

Avatar de aguevara

Yo se que muchos de nosotros elegimos operacionales como este para no tener que usar una fuente partida (+V y -V) pero en experimentos recientes que hice con el mismo chip LM324 para un circuito igual, comprobe que para la funcion que requieres es necesaria la fuente doble, no me pregunten porque, por que en este momento no tengo ni el animo ni el tiempo de hacerlo, pero si lo haces te seguro que no tendras problemas de ningun tipo, bueno considerando que haz calculado bien tus resistores y la ganancia del OPAM y no lo satures.

Saludos
14/04/2008 #29


Qué loco esto! cuando pueda voy a hacer la prueba, la verdad es que me sorprende! :(
15/04/2008 #30


Pues si este da problemas lo cambiaré por otro integrado. ¿cual me recomendais que sea similar?

Un saludo.

No ostante quiero preguntarle al profesor si el sabe donde puede estar el fallo
15/04/2008 #31

Avatar de aguevara

Haganlo con una fuente partida y veran que no se arrepentiran, yo tambien pase todo un dia intentando hacer funcionar un sumador-restador con el LM324 con fuente sencilla y fue un asco, cambie a una fuente partida de +/- 12 v y todo perfecto.
15/04/2008 #32


ok, mañana lo haré en simetrico y os diré que tal va
16/04/2008 #33


El LM324 es mejor alimentarlo en simetrico para pequeñas V
eureka! problema solucionado. He alimentado en simétrico, a +/-12v y todo va genial, me da tensiones negativas y positivas, y no se bloquea nunca, por ejemplo, si V+ es 2,08v y V- es 2,07, la salida Vo me da 0,1v.

Muchisimas gracias a todos por la ayuda prestada.

Pd: solo una cosa mas, yo he continuado usando los buffer, lo unico que cambie es la alimentacion. ¿es necesario el uso de esos buffer? ¿recomendable? ¿que justificacion podria dar por esos buffer a la hora de explicar mi diseño?.
16/04/2008 #34

Avatar de Ardogan

Sí, es necesario usar los buffers por lo siguiente: cuando variás la entrada de tensión con los potenciómetros también estarías variando la ganancia del operacional que hace la diferencia. Además si no los usás tendrías que tener en cuenta las resistencias del operacional que hace la resta para determinar exactamente que tensión vas a tener en el potenciómetro. Como una imagen vale más que mil palabras, ver imágenes adjuntas.

Con los buffers nos aseguramos que al operacional diferenciador entran las tensiones de los potenciómetros con resistencia cero, es decir, es como que mirando de la salida de los buffers (terminales de la izquierda de R31 y R32) hacia atrás se vé unicamente una fuente de tensión, siendo el valor de tensión el que dan los potenciómetros. (Es cierto que la resistencia de salida de los operacionales no es nula, alguna decena de ohms, pero es despreciable respecto de la resistencia del operacional diferenciador, que suele ser mayor a 1Kohm).

Sin los buffers esas resistencias que "se ven hacia atrás" no van a ser "nulas", sino que van a tener un valor (que se puede sacar haciendo thévenin), lo que va a hacer que la ganancia del operacional diferenciador que antes era = 1 ahora tenga otro valor, que va a depender de R29 y RV7, para la rama que hace la resta, y de R30 y RV8 para la rama que hace la suma. Peor aún, la ganancia del diferenciador va a variar al mover los potenciómetros.
No solamente eso, también la tensión que sale de los potenciómetros va a ser distinta con sin buffers a la que habría con buffers. Porque se deriva corriente hacia R31 y R32 que con buffers no se derivaba por ser muy alta la impedancia de entrada del buffer.

Resumiendo, usar los buffers separa los circuitos de entrada del circuito de salida, en este caso el circuito de los potenciómetros del operacional en modo diferenciador. Con los buffers eliminamos las interacciones; esto es, evitamos que el circuito de entrada me cambie la ganancia del operacional diferenciador; y que el circuito de salida me cambie la tensión de entrada que dan los potenciómetros (derivando corriente a través de R31 y R32).

Qué bárbaro, así que lo de fuente única para el LM324 será solo para vender?, les voy a mandar un mail a los de national a ver que dicen. Yo iba a usar el LM358 con single supply, que es parecido al LM324 solo que usa dos operacionales en vez de 4. Voy a probar a ver si pasa lo mismo con el LM358.

Saludos a todos, voy a armar el proto para el LM358.
Imágenes Adjuntas
Tipo de Archivo: gif lm324__sin_buffers_815.gif (18,3 KB (Kilobytes), 61 visitas)
Tipo de Archivo: gif lm324__con_buffers_944.gif (24,9 KB (Kilobytes), 73 visitas)
16/04/2008 #35

Avatar de Ardogan

Pasa lo mismo con el LM358
Estuve viendo que pasaba con el LM358, y pasa lo mismo, la salida no baja de 308 mV.
Estaba viendo la hoja de datos, y me encuentro con
The output voltage needs to raise approximately
1 diode drop above ground to bias the on-chip vertical PNP
transistor for output current sinking applications.
en la página 8 abajo a la izquierda.

Y también aparece la siguiente figura en la página 7 (ver adjunto).

O sea que parece que la salida nunca puede ir a menos de (V-) + 308mV; porque hay que polarizar el transistor de salida PNP.
Por eso al alimentar (V-) con tensiones negativas el problema desaparece.

Lo mismo dice en la hoja de datos del LM324.

Entonces, si uno quiere que la salida pueda llegar a 0 (o a los 25-30 mV que dice en la hoja de datos) hay que alimentar el terminal (V-) con al menos -300mV.

Esto es así en la medida en que para bajas tensiones en la salida la corriente circule entrando por la salida
current sinking applications.
.
"Lo que va a ser cierto casi siempre si nuestro circuito es single supply"

Edito el mensaje para corregir ésta última frase.
Como digo arriba, la salida va a ser mínimo 308mV si la corriente entra al terminal de salida, pero si la corriente sale del terminal de salida el mínimo es de 20mV.
Esto lo medí armando el circuito con dos buffers y un diferencial similar al de Ignacio, y veía que a la salida de los buffers el mínimo es 308mV.

Pero después puse solamente una resistencia a tierra desde la salida de uno de los buffers y ahí sí la salida llegaba a los 20mV.

Cuando se usa el diferencial la corriente entra por el terminal de salida del buffer, y al usar la resistencia la corriente sale del terminal de salida.

Quería aclarar eso.
Imágenes Adjuntas
Tipo de Archivo: gif lm358__respuesta_al_pulso__seguidor_de_tension_377.gif (16,1 KB (Kilobytes), 317 visitas)
17/04/2008 #36

Avatar de aguevara

En mi primer post les indique que se requeria fuente simetrica y seguidamente les comente "No me pregunten porque, porque no tengo el animo ni tiempo de explicarlo" bueno lo escrito por Ardogan es la respuesta, gracias por escribirlo Ardogan, la verdad a mi me da pereza escribir tanto.

Saludos
17/04/2008 #37

Avatar de Ardogan

Jaja, lo empecé a escribir, ví que se hacía largo, fuí a buscar algo para comer, seguí, fuí al baño, y cuando volví lo terminé, para despues editarlo de vuelta.
Fué un poco la calentura de no saber que pasaba y la necesidad de saber porque tengo que usar el LM358 (iba a usar el LM324 pero me quedó un layout más fácil con el LM358), por suerte ya puse de entrada un terminal "Vshift" y me ahorro ese dilema. Algo que no hice y ahora me arrepiento es dejar por las dudas la opción de alimentar con single o dual supply.
Pero al final, no sabría decir que es mejor, si usar single supply o dual supply, porque con single supply surgen todas esas consideraciones que te hacen desear poner un regulador más y olvidarte de las saturaciones, tensión de referencia, corrimiento del cero...
Aguevara tu aporte fué concreto y salvador, porque nos deja una vía de escape si single-supply no funciona.
De ahora en más diseño siempre dejando la opción de usar fuente partida o única (usemos castellano, que tanto single supply/dual supply, jaja).
Saludos
18/04/2008 #38


muchas gracias por la explicación tan detallada ardogan, asi como a todos los demás por que después de 4 páginas y gracias a vuestra ayuda se ha solcioado el problema.

Muchisimas gracias de nuevo.

Pd: me voy a leer esta última página poco a poco, por que creo que he de arender mucho de ella.
02/08/2009 #39

Avatar de DJ DRACO

Pasabajos Con LM324
Hola amigos del foro, me puse en el plan de realizar una etapa de potencia cuadrafonica para moto con 2 TDA2005S, y quiero configurar todo para que 1 TDA mueva solo los graves, y el otro TDA mueva los medios y agudos.

para tal fin necesito hacer un crossover o divisor de frecuencias, y en lo posible activo para no perder ganancia.

la onda es que hay pocos operacionales que trabajan con alimentación sintética (solo voltaje positivo), y quiero usar el LM324 para hacer el crossover.

alguien tiene algun diseño de un pasabajos y pasaaltos con este integrado?

gracias desde ya.

saludos.
02/08/2009 #40
Moderador

Avatar de elaficionado

Hola.

Todos los operacionales similares al LM324 pueden trabajar con polaridad simple, como el LM324.

Chao.
elaficionado.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.